[Tizen Application-dev] On ubuntu x86_64 cannot build packages from 'sbs -c -A i386'

Timmy Douglas tizen at timmyd.info
Thu Jan 12 02:07:35 GMT 2012


I was hoping to find an -A for x86_64, but I couldn't find anything.

Following the README in sbs:

1. git clone git://112.106.1.251/pkgs/e/ecore.git
2. cd ecore
3. ~/sbs-install/bin/sbs -e dpkg-buildpackage -b # will fail because of 
missing build deps
4. ~/sbs-install/bin/sbs -et apt-get install ... # install list of build 
dependencies
5. ~/sbs-install/bin/sbs -e dpkg-buildpackage -b



This scrolled by during the 'sbs -A i386 -c' earlier:

I: Extracting sysv-rc...
I: Extracting sysvinit...
I: Extracting sysvinit-utils...
I: Extracting zlib1g...
Target architecture set to i686
Reading mode-specific settings..
ld: error while loading shared libraries: ld: cannot open shared object 
file: No such file or directory
Finished writing sb2.gcc.config
gcc configured.
sb2-init: Target architecture is 'i686'
sb2-init: Host architecture is 'x86_64'
sb2-init: WARNING:
sb2-init: *******  Host architecture is different than target architecture,
sb2-init: *******  but CPU transparency was not set. This may not be what
sb2-init: *******  you want (maybe you should run sb2-init again and
sb2-init: *******  specify 'qemu-i686' as the CPU transparency method?)
Reading mode-specific settings..
Finished writing sb2.config

I tried modifying ~/sbs-install/bin/sbs:Line 526, by removing the 
tools|i386 line. This seemed to make the 'sbs -A -c i386' command run 
longer when I killed and recreated, but I still get the error below. I 
was hoping it would set $emul to run sb2-init with -c qemu-i686 to cure 
the error above, but it seems like it didn't judging from the output of 
sb2-init when I run it after the sbs create. Re-running sb2-init after 
it was done seemed to add the flag, but I didn't have the qemu-i686 
binary or it didn't have that cpu emulation.

Anyways, the error is here (after running sbs -c -A i386 to completion):

timmy at timmy-desktop:~/src/tizen/git/pkgs/ecore$ ~/sbs-install/bin/sbs -A 
i386 -e dpkg-buildpackage -b
/home/timmy/sbs-install/bin/qemu-i386: error while loading shared 
libraries: /home/timmy/sbs-install/bin/qemu-i386: wrong ELF class: 
ELFCLASS64
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): 
-g -O2
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor):
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: 
vendor): -g -O2
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): 
-g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor):
/home/timmy/sbs-install/bin/sb2-show: error while loading shared 
libraries: /home/timmy/sbs-install/bin/sb2-show: wrong ELF class: ELFCLASS64
dpkg-buildpackage: source package ecore
dpkg-buildpackage: source version 1.1.0+svn.65618slp2+build02
dpkg-buildpackage: source changed by Tae-Hwan Kim <the81.kim at samsung.com>
dpkg-buildpackage: host architecture i386
  dpkg-source --before-build ./
tail: cannot open `./debian/changelog' for reading: No such file or 
directory
dpkg-source: error: tail of ./debian/changelog gave error exit status 1
dpkg-buildpackage: error: dpkg-source --before-build ./ gave error exit 
status 1
sbs: failed to perform requested operation


Any ideas?



More information about the Application-dev mailing list