[Tizen Application-dev] tizen SDK arm-linux-gnueabi-gcc

SaschaP sascha.packet at googlemail.com
Tue Jul 24 11:34:16 GMT 2012


Hallo,

I installed the SDK yesterday (1.0)
..., run the emulator, looked the demos...
So far so good!


Now I wanted to test the arm-linux-gnueabi-gcc but I failed 
compiling a simple hello-world.c

---hello-world.c---
#include <stdio.h>
int main(int argc, char *argv[])
{
	printf("hall-welt \n");
	return 0;
}
-------------------


/home/user/embedded/tizen/SDK/tizen_sdk/SDK/build-system/toolchains/gcc-4.5.3.sb2/usr/bin/arm-linux-gnueabi-gcc -o hello-world-tizenarm hello-world.c
...does not work and gives an error:


/home/user/embedded/tizen/SDK/tizen_sdk/SDK/build-system/toolchains/gcc-4.5.3.sb2/usr/bin/../lib/gcc/arm-linux-gnueabi/4.5.3/cc1: error while loading shared libraries: libcloog-debian.so.0: cannot open shared object file: No such file or directory




libcloog-debian.so.0 exists
in  /home/user/embedded/tizen/SDK/tizen_sdk/SDK/build-system/toolchains/gcc-4.5.3.sb2/usr/lib/libcloog-debian.so.0

I tried to set
"PATH="$PATH:/home/user/embedded/tizen/SDK/tizen_sdk/SDK/build-system/toolchains/gcc-4.5.3.sb2/"
and -L/pathtolib... without success?

This is my first tizen-test but in the pasted I allready
worked with a lot of other arm-gcc's
(openmoko,opentom,N900,...)

What am I doing wrong?
Why is the arm compiler not working?

regards
Sascha









More information about the Application-dev mailing list