[Tizen Application-dev] Installing deb package files to Tizen Emulator

Butterfield streep streepbutterfield at gmail.com
Mon Mar 19 06:22:54 GMT 2012


Thanks

>
> On Fri, Mar 16, 2012 at 6:00 PM, Butterfield streep
> <streepbutterfield at gmail.com> wrote:
> > Thanks for your reply. Please let me know which application is using this
> > ecore package to test that the package is installed successfully in
> > emulator?
>
> You can check the dependency with apt-cache in sdb.
> # apt-cache rdepends libecore
>
> Actually, all inhouse applications use ecore. So you can easily
> recognize there will be a problem when you remove libecore.
> # dpkg --purge --ignore-depends=libecore libecore
> # /opt/apps/org.tizen.gallery/bin/gallery
>
> You'll see the error message that ecore library is missing.
> Then install the ecore package that you built and try launching
> applications again.
>
> Thanks.
>
> Daniel Juyung Seo (SeoZ)
>
>
> >
> >
> >
> > On 14 March 2012 10:44, Daniel Juyung Seo <seojuyung2 at gmail.com> wrote:
> >>
> >> Hello,
> >> Ignore that message and do not install dev packages in the emulator.
> >> dev packages are for development and not shipped in the device/emulator.
> >>
> >> Thank you.
> >>
> >> Best Regards,
> >> Daniel Juyung Seo (SeoZ)
> >>
> >> On Wed, Mar 14, 2012 at 1:34 PM, Butterfield streep
> >> <streepbutterfield at gmail.com> wrote:
> >> > Hello,
> >> >
> >> >                 I tried to install the deb package files got after
> >> > building
> >> > pkgs/e/ecore to tizen emulator. But showing some dependency files are
> >> > not
> >> > installed.
> >> >
> >> > I used the following steps to build the package.
> >> >
> >> > test at test-desktop:~/test_build/pkgs/ecore$ ~/sbs-install/bin/sbs -A
> i386
> >> > --depends
> >> >
> >> > test at test-desktop:~/test_build/pkgs/ecore$ ~/sbs-install/bin/sbs -A
> i386
> >> > -e
> >> > dpkg-buildpackage -b
> >> >
> >> > test at test-desktop:~/test_build/pkgs/ecore$ sdb shell dpkg -i
> >> > /opt/apps/libecore_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-bin_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-con_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-config_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-data_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-dbg_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-doc_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-evas_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-fb_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-file_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-imf_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-input_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-ipc_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-x_1.1.0+svn.67695slp2+build01_i386.deb
> >> > /opt/apps/libecore-dev_1.1.0+svn.67695slp2+build01_i386.deb
> >> >
> >> >
> >> > While installing libecore-dev, it shows some dependency files like
> >> > libcurl-dev libeet-dev libeina-dev libevas-dev libglib2.0-dev
> >> > ..........are
> >> > not installed.
> >> >
> >> > What should I do?
> >> >
> >> >
> >> > Thanks
> >> > _______________________________________________
> >> > Application-dev mailing list
> >> > Application-dev at lists.tizen.org
> >> > https://lists.tizen.org/listinfo/application-dev
> >> >
> >
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20120319/ed8dd789/attachment.html>


More information about the Application-dev mailing list