[Tizen Application-dev] MIC fails with proxy settings

Vijay Zanvar vijoeyz at gmail.com
Fri Nov 2 13:34:25 GMT 2012


The mic command fails due to wrong interpretation of proxy.  Generally,
proxy settings are in the form:

http://user:password@proxy.com:8080

I have proxy variable set to following in /etc/mic/mic.conf:

proxy=http://USER:PASSWORD@proxy.com:8080

And the following command has failed for me:

$ sudo mic create raw tizen-min.ks
mic 0.14.1 (Ubuntu 12.04 precise)
Info: Retrieving repo metadata:
Info: Retrieving repomd.xml ... DONE

Info: Use detected arch i686.
Info: Refreshing repository: Tizen-main ...

Error <creator>: History:
 - [|] Error trying to read from '
http://download.tizen.org/releases/daily/2.0alpha/common/latest/repos/tizen-main/ia32/packages/?proxy=
*<USER>*&proxyport=*<PASSWORD at proxy.com>*'
 - Download (curl) error for '
http://download.tizen.org/releases/daily/2.0alpha/common/latest/repos/tizen-main/ia32/packages/content?proxy=
*<USER>*&proxyport=*<PASSWORD at proxy.com>*':
Error code: Unrecognized error
Error message: Empty reply from server

[|] Valid metadata not found at specified URL(s)


What has happened is this: mic considers everything before the first ":" as
proxy and the rest as the port.  Therefore, in the above example, the
operation failed since the proxy is set to "USER" and proxyport is set to "
PASSWORD at proxy.com".  Interestingly, with same setting repomd.xml was
successfully retrieved!  So why mic is failing ?

Best,
Vijay Zanvar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20121102/a7d64421/attachment.html>


More information about the Application-dev mailing list