[Tizen Application-dev] GBS Build

Amit S amit at smargav.com
Fri Oct 5 11:49:46 GMT 2012


Hi,

I think you are using previous version of GBS.

Updating GBS will certainly help, as it has simplified the configuration of
repos.

Just FYI, My working .gbs.conf

[general]
profile = profile.current

[repo.repo1]
url =
http://download.tizen.org/releases/2.0alpha/weekly/tizen-2.0_20120921.19/repos/tizen-base/armv7l/packages/

[repo.repo2]
url =
http://download.tizen.org/releases/2.0alpha/weekly/tizen-2.0_20120921.19/repos/tizen-main/armv7l/packages/

[profile.current]
repos = repo.repo1, repo.repo2



You can always modify the repo URLs to whatever snapshot you want.
This is the link for all the repos
http://download.tizen.org/snapshots/trunk/common/

replace the above URLs with appropriate URLs like this
http://download.tizen.org/snapshots/trunk/common/tizen_20120823.2/repos/base/armv7l/packages
http://download.tizen.org/snapshots/trunk/common/tizen_20120823.2/repos/main/armv7l/packages

Hope that helps!


Regards,
Amit S



On Fri, Oct 5, 2012 at 5:12 PM, Guilherme Íscaro <iscaro at profusion.mobi>wrote:

> Hello Rusty,
>
> Here is my gbs.conf file, Maybe my repo1.url is wrong, I don't know. What
> do you think?
>
> Thanks for the help! :)
>
> [general]
> ; general settings
> tmpdir = /var/tmp
> editor = emacs
> #[remotebuild]
> #; settings for build subcommand
> #build_server = <build server URL>
> #user = <USER_NAME>
> #passwd = <USER_PASSWORD>
> [build]
> build_cmd = /usr/bin/build
> build_root= /var/tmp/build-root-gbs
> su-wrapper= sudo
> distconf= /var/tmp/iscaro-gbs/tizen.conf
> #; optional, repos definitions
> repo1.url = http://download.tizen.org/snapshots/trunk/common/latest
> #repo1.user = <USER_NAME>
> #repo1.passwd = <USER_PASSWORD>
>
> On Thu, Oct 4, 2012 at 5:28 PM, Rusty Lynch <rusty.lynch at intel.com> wrote:
>
>>  On 10/04/2012 10:42 AM, Guilherme Íscaro wrote:
>>
>> Hello Everyone,
>>
>> I'm trying to build (local build) a tizen package with GBS
>> (apps/home/call.git) .
>> Everything looks ok, however gbs it's not generating the RPM package and
>> I receive a warning.
>> What's happening?
>>
>> This is the log:
>>
>> warning: the following packages build failed with missing depends
>> packages:
>> org.tizen.call
>> info: generated RPM packages can be found from local repo:
>>     ~/GBS-ROOT/local/repos/tizen
>> info: build roots located in:
>>      ~/GBS-ROOT/local/scratch.{arch}.*
>> info: Done
>>
>>
>> gbs is unable to find a package it depends on, specifically
>> org.tizen.call.  I can see that this package is being built so it is
>> available which means you are likely not pointing to the correct
>> repositories in your ~/.gbs.conf
>>
>> So... what does your .gbs.conf look like?  What repos are you pointing
>> too?
>>
>>     --rusty
>>
>> _______________________________________________
>> Application-dev mailing list
>> Application-dev at lists.tizen.org
>> https://lists.tizen.org/listinfo/application-dev
>>
>>
>
> _______________________________________________
> Application-dev mailing list
> Application-dev at lists.tizen.org
> https://lists.tizen.org/listinfo/application-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20121005/45ed036d/attachment-0001.html>


More information about the Application-dev mailing list