[Tizen Application-dev] Firefox or Xulrunner problem with Tizen IDE on Ubuntu 12.10 64bit

Raju Bitter rajubitter at googlemail.com
Sat Oct 20 09:41:07 GMT 2012


To be precise, the exception is thrown when I create a new Tizen web project.

Ubuntu 12.04 and 12.10 do not have Xulrunner installed and available
in the repositories:
http://askubuntu.com/questions/125980/how-do-i-install-xulrunner-in-12-04

The current Tizen IDE is based on Eclipse 3.7.1, and this page lists
the required Xulrunner versions for Eclipse:
http://www.eclipse.org/swt/faq.php#browserlinux
> Eclipse 3.7.x/4.1.x: Mozilla 1.4 GTK2 - 1.7.x GTK2,
> XULRunner 1.8.x - 1.9.x and 3.6.x (but not 2.x), WebKitGTK+ 1.2.x and newer

I installed the package libwebkitgtk-1.0-0 and configured Eclipse /
TizenIDE to use webkit instead of Xulrunner by adding this line to the
eclipse.ini:
-Dorg.eclipse.swt.browser.DefaultType=webkit

You might want to add that to the installation instructions for Ubuntu
12.x systems.

- Raju


More information about the Application-dev mailing list