[Tizen Application-dev] gbs build failed with "have choice for libEGL.so.1 needed by evas"

Clark, Joel joel.clark at intel.com
Wed Oct 31 12:53:20 GMT 2012


The reference to a simulator-opengl is incorrect for IVI and an example of an unfinished port of Tizen 2.0 Alpha to IVI.  It would be really good to have a bug report in bugs.tizen.org to track this.



From: Sarath Singapati [mailto:sarath.singapati at ixonos.com]
Sent: Wednesday, October 31, 2012 3:10 AM
To: Clark, Joel
Cc: application-dev at lists.tizen.org
Subject: Re: [Tizen Application-dev] gbs build failed with "have choice for libEGL.so.1 needed by evas"

Thanks a lot Joel. Here is build command:
sudo gbs build -A i586 --include-all --debug --clean

Build is successful with "common" repos.
http://download.tizen.org/releases/daily/2.0alpha/common/latest/repos/tizen-main/ia32/packages/
http://download.tizen.org/releases/daily/2.0alpha/common/latest/repos/tizen-base/ia32/packages/

But fails with "IVI" repos (have choice for libEGL.so.1 needed by evas: simulator-opengl mesa-libEGL)
http://download.tizen.org/releases/daily/2.0alpha/ivi/latest/repos/ivi/ia32/packages/
http://download.tizen.org/releases/daily/2.0alpha/ivi/latest/repos/base/ia32/packages/

Regards,
Sarath

On 31 October 2012 10:59, Clark, Joel <joel.clark at intel.com<mailto:joel.clark at intel.com>> wrote:
Please avoid using "snapshots" for development.  "snapshots" are built automatically every time any code is checked in.  There is no verification that snapshots have all dependencies resolved or build correctly and are bootable.  Also snapshots may be removed at any time.

Please look for "daily" releases, they have at least been shown to boot on one target device.
http://download.tizen.org/releases/daily/2.0alpha/ivi/

Still even daily builds may have very limited functionality and are candidates for testing and validation teams.  So for best results (absent a Monthly or "preview" release to use), please monitor the QA test reports to identify a daily release that has been shown to be functional and stable. https://qarpt.tizen.org/2.0/IVI   Click on the v2.0 tab to see the test results.  Based on the current QA results I suggest trying http://download.tizen.org/releases/daily/2.0alpha/ivi/tizen-2.0_20121029.3/

Which platform are you trying to build for?

regards
Joel


From: application-dev-bounces at lists.tizen.org<mailto:application-dev-bounces at lists.tizen.org> [mailto:application-dev-bounces at lists.tizen.org<mailto:application-dev-bounces at lists.tizen.org>] On Behalf Of Sarath Singapati
Sent: Wednesday, October 31, 2012 1:46 AM
To: application-dev at lists.tizen.org<mailto:application-dev at lists.tizen.org>
Subject: [Tizen Application-dev] gbs build failed with "have choice for libEGL.so.1 needed by evas"

Hi,

I get this build error.

debug: Checking dependencies for org.tizen.myproject
debug: expansion error
debug:   have choice for libEGL.so.1 needed by evas: simulator-opengl mesa-libEGL
warning: the following packages build failed with missing depends packages:

I am using these repos in my .gbs.conf.
[repo.repo1]
url = http://download.tizen.org/snapshots/2.0alpha/ivi/latest/repos/ivi/ia32/packages/

[repo.repo2]
url = http://download.tizen.org/snapshots/2.0alpha/ivi/latest/repos/base/ia32/packages/

Any ideas please?

Thank you
Sarath


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20121031/fb81c1c1/attachment.html>


More information about the Application-dev mailing list