[Tizen Application-dev] Failed to Build Package

Jian-feng Ding jian-feng.ding at intel.com
Tue Jun 4 01:31:34 GMT 2013


I feel the version of SDK/IDE embedded gbs is too low, and should be upgraded
to latest.

thanks
- jf.ding

On Tue, Jun 04, 2013 at 01:50:08AM +0000, Zhang, Qiang Z wrote:
> What's the version of your gbs?
> 
> Start from gbs 0.16, the build roots dir has been moved to individual directory.
> 
> I am not sure this is the root cause.
> 
> DongHee, do you have any comments?
> 
> Thanks
> Qiang
> 
> 
> 
> 
> From: application-dev-bounces at lists.tizen.org [mailto:application-dev-bounces at lists.tizen.org] On Behalf Of Ramesh Adapa
> Sent: Monday, June 03, 2013 11:22 AM
> To: application-dev at lists.tizen.org
> Subject: [Tizen Application-dev] Failed to Build Package
> 
> Hello All,
> 
> I am new to Tizen Application development, while I am building package for Hello Application in Tizen2.1 using Tizen-ide I got build failed error. Below is some error log.
> 
> [   16s] Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.9mwGDI
> [   16s] + umask 022
> [   16s] + cd /home/abuild/rpmbuild/BUILD
> [   16s] + cd org.tizen.hello-0.1
> [   16s] + rm -rf /home/abuild/rpmbuild/BUILDROOT/org.tizen.hello-0.1-1.i386
> [   16s] + rm -rf /home/abuild/rpmbuild/BUILDROOT/org.tizen.hello-0.1-1.i386
> [   16s] + exit 0
> [   16s] ... checking for files with abuild user/group
> [   16s]
> [   16s] rameshadapa-VirtualBox finished "build org.tizen.hello.spec" at Mon Jun  3 03:09:44 UTC 2013.
> [   16s]
> [32minfo: [0mfinished building org.tizen.hello
> [32minfo: [0mupdating local repo
> [32minfo: [0mgenerated RPM packages can be found from local repo:
>      /home/rameshadapa/tizen-sdk/platforms/tizen2.1/rootstraps/tizen-emulator-2.1.platform/local/repos/tizen2.1emul/i586/RPMS
> [32minfo: [0mgenerated source RPM packages can be found from local repo:
>      /home/rameshadapa/tizen-sdk/platforms/tizen2.1/rootstraps/tizen-emulator-2.1.platform/local/repos/tizen2.1emul/i586/SRPMS
> [32minfo: [0mbuild roots located in:
>      /home/rameshadapa/tizen-sdk/platforms/tizen2.1/rootstraps/tizen-emulator-2.1.platform/local/BUILD-ROOTS/scratch.i586.*
> [32minfo: [0mDone
> find: `/home/rameshadapa/tizen-sdk/tools/smart-build-interface/../../platforms/tizen2.1/rootstraps/tizen-emulator-2.1.platform/local//home/abuild/rpmbuild/RPMS': No such file or directory
> 
> My actual RPMS path is:
> '/home/rameshadapa/tizen-sdk/platforms/tizen2.1/rootstraps/tizen-emulator-2.1.platform/local/BUILD-ROOTS/scratch.i586.0/home/abuild/rpmbuild/RPMS/'
> 
> I have no idea how build process is happening. So, kindly let me know how to solve the above issue.
> 
> regards,
> R at me$h Ad at p@,
> 0-813.217.5283

> _______________________________________________
> Application-dev mailing list
> Application-dev at lists.tizen.org
> https://lists.tizen.org/listinfo/application-dev



More information about the Application-dev mailing list