[Tizen Application-dev] how to set User-Agent in Tizen Native Apps

Hanchett, Paul phanchet at jaguarlandrover.com
Mon Oct 14 15:46:16 GMT 2013


It might be useful if you tell us, "*How* does it not work?"  -- Gives
error?  No effect?  If you immediately try to retrieve the value after
setting it, what do you get?

Paul


Paul Hanchett
-------------------
Infotainment Engineer
MSX on behalf of Jaguar Land Rover
One World Trade Center, 121 Southwest Salmon Street, 11th Floor, Portland,
Oregon, 97204

Email: phanchet at jaguarlandrover.com
-------------------

Business Details:
Jaguar Land Rover Limited
Registered Office: Abbey Road, Whitley, Coventry CV3 4LF
Registered in England No: 1672070


On Mon, Oct 14, 2013 at 3:45 AM, Tung Nguyen <nttung at tma.com.vn> wrote:

> Hi All,****
>
> ** **
>
> I have write function to change value user agent, but setuserAgent
> function not work****
>
> ** **
>
> *void* TizenDemoForm::*LoadUrl*(*void*)****
>
> {****
>
>     Tizen::Base::String url(L"http://dev.bookmo.jp/magastore_api/index/ua"
> );****
>
>     String userAgent = GetUserAgent();****
>
>     AppLog("%*ls*",userAgent.GetPointer() );****
>
>     userAgent.Append(L" ABCDDDDD");****
>
>     AppLog("%*ls*",userAgent.GetPointer() );****
>
>     SetUserAgent(userAgent);****
>
>     _web->LoadUrl(url);****
>
> ** **
>
> ** **
>
> }****
>
> ** **
>
> Please help me about this?****
>
> ** **
>
> Thanks,****
>
> Tung****
>
> _______________________________________________
> Application-dev mailing list
> Application-dev at lists.tizen.org
> https://lists.tizen.org/listinfo/application-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20131014/c29368d8/attachment.html>


More information about the Application-dev mailing list