[Tizen Application-dev] Running Crosswalk

Michael Johnson Michael.Johnson at Symphonyteleca.com
Fri Aug 15 13:09:12 GMT 2014


Hi all,

This is an update.  I decided to start from scratch and reinstall the latest release image.  I am no longer seeing the problems I had with the webserver or with weston-terminal starting up as user 'root'.  I'm not sure how it would have gotten to that state.

Xinchao, thanks for trying to help.

Mike
________________________________
From: Application-dev [application-dev-bounces at lists.tizen.org] on behalf of Michael Johnson [Michael.Johnson at Symphonyteleca.com]
Sent: 15 August 2014 9:17 AM
To: He, Xinchao
Cc: application-dev at lists.tizen.org
Subject: Re: [Tizen Application-dev] Running Crosswalk

Hi Xinchao,

I'm using the version which came with the latest release image.

# rpm -qa | grep crosswalk

gives

crosswalk-8.36.161.0-2.2.i686
tizen-extensions-crosswalk-0.79-1.1.i686

Regards
Mike
________________________________
From: He, Xinchao [xinchao.he at intel.com]
Sent: 15 August 2014 6:25 AM
To: Michael Johnson
Cc: application-dev at lists.tizen.org
Subject: RE: Running Crosswalk

Hi Michael,
May I ask which version crosswalk do you use? Can you provide the result
of this command on your Tizen device?

# rpm -qa | grep crosswalk

From: Application-dev [mailto:application-dev-bounces at lists.tizen.org] On Behalf Of Michael Johnson
Sent: Thursday, August 14, 2014 6:09 PM
To: application-dev at lists.tizen.org
Subject: [Tizen Application-dev] Running Crosswalk


Hi all,

I'm using tizen-3.0.m14.2-ivi_20140724.4 and have set up a lighttpd webserver for use with crosswalk.  First of all, I've noticed that opening a terminal in wayland on this image seems to open as a root terminal, is that normal?  I can only open a web page in crosswalk as root.  Trying to open a web page as user 'app' causes the following output:

app:~> xwalk http://www.google.com
[0814/034553:ERROR:browser_main_loop.cc(164)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[0814/034553:INFO:desktop_factory_wayland.cc(15)] Ozone: DesktopFactoryWayland
[0814/034553:INFO:desktop_factory_wayland.cc(15)] Ozone: DesktopFactoryWayland
[0814/034553:ERROR:display.cc(96)] WaylandDisplay failed to initialize hardware
[0814/034553:ERROR:gl_surface_ozone.cc(54)] Ozone failed to initialize hardware
[0814/034553:ERROR:gpu_child_thread.cc(132)] Exiting GPU process due to errors during initialization
[0814/034553:FATAL:display.cc(141)] Check failed: disp_.display(). Ozone: Wayland server connection not found.
Aborted (core dumped)

When I try to open a local test html web page located at /srv/www as the server document root, using http://localhost/index.html, it should just show some text "It Works!", but I just get a blank crosswalk window opening.  I've set up lighttpd many times before using minibrowser, but this is the first time using crosswalk.  FYI the port I'm using is port 80.

Finally, has anyone run widgets successfully using the crosswalk wrt?  I'm using /usr/bin/xwalk to open web pages, and xwalkctl to install a widget.

Thanks for any advice.
Mike


MICHAEL JOHNSON
Embedded Software Engineer

Symphony Teleca
Sunley House, 46 Jewry Street, Winchester, Hampshire, SO23 8RY
Phone: +441962868866
Michael.Johnson at Symphonyteleca.com<mailto:Michael.Johnson at Symphonyteleca.com>
www.symphonyteleca.com<http://www.symphonyteleca.com>

[Linkedin]<http://www.linkedin.com/company/4301?trk=tyah>     [Twitter] <https://twitter.com/symphony_teleca>      [Facebook] <https://www.facebook.com/SymphonyTelecaCorp>
________________________________
[cid:image004.png at 01CFB894.D02C52B0]<http://www.symphonyteleca.com/together>

Teleca Limited, a company registered in England & Wales, registration number 2773878, registered office at Sunley House, 46 Jewry Street, Winchester, Hampshire SO23 8RY. VAT registration number GB 674 6583 90

Follow what's going on at Symphony Teleca's blog on www.symphonyteleca.com/blog<http://www.symphonyteleca.com/blog>. Please consider the environment before you print.

Notice to recipient: This e-mail (including any attachments) is meant for the intended recipient only, may contain confidential and proprietary information, and is protected by law. If you received this e-mail in error, please immediately notify the sender of the error by return e-mail, delete this communication and any attachments, and shred any printouts. Unauthorized review, use, dissemination, distribution, copying or taking of any action based on this communication is strictly prohibited.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140815/20d1d898/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 379 bytes
Desc: image001.png
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140815/20d1d898/attachment-0004.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.png
Type: image/png
Size: 359 bytes
Desc: image002.png
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140815/20d1d898/attachment-0005.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.png
Type: image/png
Size: 338 bytes
Desc: image003.png
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140815/20d1d898/attachment-0006.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image004.png
Type: image/png
Size: 26365 bytes
Desc: image004.png
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140815/20d1d898/attachment-0007.png>


More information about the Application-dev mailing list