[Tizen Application-dev] Tizen IVI: MiniBrowser exits with error / Web-application crashes

Ruchi Sharma ruchi.sharma at igate.com
Mon Jul 14 11:27:47 GMT 2014


Hello all,

I have tried the below command before launching MiniBrowser:

export XDG_RUNTIME_DIR=/run/user/5000/

Web-application is launched but still with errors:
root:/home/developer/gst_bins/ruchi> MiniBrowser TestApp.html
ERR<339>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<339>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<339>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<339>:elementary elm_gesture_layer.c:3680 elm_gesture_layer_add() could not add 0xa329d18 as sub object of 0xa302ed0
ERR<339>:elementary elm_layout.c:1847 elm_layout_add() could not add 0xa32ad98 as sub object of 0xa302ed0
edje_object_file_set is error

Kindly let me know what could be the problem ??
What changes I need to do in-order to launch web application properly?

Thanks!

Warm regards,
Ruchi Sharma


From: Ruchi Sharma
Sent: Monday, July 14, 2014 4:47 PM
To: application-dev at lists.tizen.org
Subject: Tizen IVI: MiniBrowser exits with error / Web-application crashes
Importance: High

Hello All,

I am working on latest release of Tizen IVI (Tizen IVI 3.0-M2-March2014)  and trying to run a web application on MiniBrowser through different ways:-


1.       When I just launch MiniBrowser from wayland-terminal  I got the following errors:

sh-4.2$ MiniBrowser
ERR<250>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<250>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<250>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<250>: elementary elm_gesture_layer.c:3680 elm_gesture_layer_add() could not add 0x960dc20 as sub object of 0x95e7458
ERR<250>: elementary elm_layout.c:1847 elm_layout_add() could not add 0x960eca0 as sub object of 0x95e7458

Result: MiniBrowser launched after this error


2.       When I launch my web application through MiniBrowser from wayland-terminal  it shows following error:


bash-4.2# MiniBrowser TestApp.html
ERR<7116>:ecore_wl ecore_wl.c:173 ecore_wl_init() Could not connect to wayland display
CRI<7116>:ewebkit2 /home/abuild/rpmbuild/BUILD/webkit2-efl-123997_0.12.1/Source/WebKit2/UIProcess/API/efl/ewk_main.cpp:96 ewk_init() could not init ecore_wl

Result: Web-application not launched


3.       Connect through SSH and launch the web application on MiniBrowser:


root:/home/developer/gst_bins/ > MiniBrowser TestApp.html
ERR<6885>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<6885>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<6885>: eina_module.c:403 eina_module_symbol_get() safety check failed: m->handle == NULL
ERR<6885>:elementary elm_gesture_layer.c:3680 elm_gesture_layer_add() could not add 0xa3dfa68 as sub object of 0xa3b9510
ERR<6885>:elementary elm_layout.c:1847 elm_layout_add() could not add 0xa3e0ae8 as sub object of 0xa3b9510
edje_object_file_set is error


Reloading...
edje_object_file_set is error
edje_object_file_set is error
edje_object_file_set is error
edje_object_file_set is error
edje_object_file_set is error
edje_object_file_set is error
[4]+  Killed                  MiniBrowser TestApp.html

Result:  Web-application launched , but after some time it exit with the above mentioned error.


4.       A web-application(.wgt) is created from TizenSDK and installed on Tizen and then launched through wrt-launcher:



Result: TestApp is launched properly but after sometime it crashes the system giving below error:

drivers/rtc/hctosys.c: unable to open rtc device

[sdb] No Caching mode page found

[sdb] Assuming drive cache: write through

[sdb] No Caching mode page found


Kindly let me know what could be the problem ??
What changes I need to do in-order to launch web application properly?

Thanks!

Warm regards,
Ruchi Sharma





~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Disclaimer~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Information contained and transmitted by this e-mail is confidential and proprietary to IGATE and its affiliates and is intended for use only by the recipient. If you are not the intended recipient, you are hereby notified that any dissemination, distribution, copying or use of this e-mail is strictly prohibited and you are requested to delete this e-mail immediately and notify the originator or mailadmin at igate.com <mailto:mailadmin at igate.com>. IGATE does not enter into any agreement with any party by e-mail. Any views expressed by an individual do not necessarily reflect the view of IGATE. IGATE is not responsible for the consequences of any actions taken on the basis of information provided, through this email. The contents of an attachment to this e-mail may contain software viruses, which could damage your own computer system. While IGATE has taken every reasonable precaution to minimise this risk, we cannot accept liability for any damage which you sustain as a result of software viruses. You should carry out your own virus checks before opening an attachment. To know more about IGATE please visit www.igate.com <http://www.igate.com>.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/application-dev/attachments/20140714/1c715204/attachment-0001.html>


More information about the Application-dev mailing list