<div dir="ltr"><div><div><div><div><div><div><div>Hello,<br><br></div>I'm new to tizen development on ARTIK 10, and following this guide [<a href="https://blogs.s-osg.org/introduction-tizen-development-artik/">https://blogs.s-osg.org/introduction-tizen-development-artik/</a>] to try gbs and make application for ARTIK 10.<br><br></div>However, when I try to make rpm package I encountered this error:<br><br>---<br>> gbs build -P "tizen_common_3.0b_artik_armv7l" --arch armv7l --include-all<br>info: generate repositories ...<br>warning: No local package repository for arch armv7l<br>info: build conf has been downloaded at:<br>      /var/tmp/wwee3631-gbs/tizen_common_3.0b_artik_armv7l.conf<br>Can't locate Build.pm in @INC (you may need to install the Build module) (@INC contains: /usr/lib/build /usr/bin /usr/bin/build /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/bin/depanneur line 66.<br>BEGIN failed--compilation aborted at /usr/bin/depanneur line 66.<br>error: <gbs>some packages failed to be built<br>---<br><br></div>So I installed Module::Build, but problem perstisted.<br><br></div>I figured out that the newly installed Module::Build, Build.pm is under /usr/share/perl5/Module/Build.pm, so I experimentally moved Build.pm and Build/ folder to parent directory (/usr/share/perl5).<br><br><br>---<br>> gbs build -P "tizen_common_3.0b_artik_armv7l" --arch armv7l --include-all<br>info: generate repositories ...<br>warning: No local package repository for arch armv7l<br>info: build conf has been downloaded at:<br>      /var/tmp/wwee3631-gbs/tizen_common_3.0b_artik_armv7l.conf<br>Can't locate Build/Rpm.pm in @INC (you may need to install the Build::Rpm module) (@INC contains: /usr/lib/build /usr/bin /usr/bin/build /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/bin/depanneur line 67.<br>BEGIN failed--compilation aborted at /usr/bin/depanneur line 67.<br>error: <gbs>some packages failed to be built<br>---<br><br></div>However, this time I can't find Build::Rpm module, and after some search it seems it might be a part of gbs, (located at /usr/lib/build/Build/)<br><br></div>Since I didn't get any .gbs.conf file after I installed gbs, I suspect there was problem with installing gbs or so.<br><br></div>Any tips on this problem will be greatly appreciated.<br><div><div><div><div><div><div><div><div><br><div><div><br clear="all"><div><div><div class="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div>Taehee Jeong<br></div></div><div>Dept of Computer Science and Engineering<br></div>College of Engineering, Seoul National University<br></div></div></div></div></div>
</div></div></div></div></div></div></div></div></div></div></div></div>