[Dev] Change toolchain cross-armv7l-gcc to private-gcc

Dong, Junfeng junfeng.dong at intel.com
Wed Dec 11 09:17:42 GMT 2013


Comments within the lines:

From: dev-bounces at lists.tizen.org [mailto:dev-bounces at lists.tizen.org] On Behalf Of ???
Sent: Wednesday, December 11, 2013 12:15 PM
To: dev at lists.tizen.org
Subject: [Dev] Change toolchain cross-armv7l-gcc to private-gcc

Hello.

I tried to change cross compiler on OBS project from cross-armv7l-gcc to private-gcc to version upgrade.
For this, I worked like this.

1. Make OBS project to verify private-gcc and complete verification build test.
2. Moved toolchain packages (private-gcc, private-glibc, private-binutils, etc…) to OBS staging project
to build Tizen RSA Base packages.

In next step, Base packages can’t resolved private-gcc.
So To change cross-compiler to build each packages, I removed cross-armv7l-gcc that already exist in Base project
As I know it’s possible to change packages name to use “substitute” command in Project Config.
But all package that should be compiled base armv7l are unreasonable status. All packages can’t find private-gcc.

Question.
To resolve ‘unreasonable’ at packages, what job is need?

[Junfeng] Do you mean “unresolved”? you can find what is missing in detail by put the cursor on “unresolved”.
As I know in OBS system, if cross-compiler also exist in Base project. So I just copy to Base project.
Is that wrong?
[Junfeng] don’t know what you are talking about. But if you want to replace cross compiler, You need to clean the project configure at first. Replace the following packages with what you really use, for example:
%if %speedbinutils
Required: cross-arm-binutils-accel
%endif

%if %speedgcc
Required: cross-arm-gcc-accel
%endif
Junfeng

Best Regards,
Geonho Kim.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20131211/71b17767/attachment-0001.html>


More information about the Dev mailing list