[Dev] Mic trying to install 2 versions of one package

Chen, Gui gui.chen at intel.com
Wed Oct 16 02:37:40 GMT 2013


Could you show what packages you have in local repo?
I think possibly some package uses 'libsystemd == %{version}-%{release}' as requires,
So 204-10 and 204-3.5 are both selected.

Thanks
Gui

-----Original Message-----
From: dev-bounces at lists.tizen.org [mailto:dev-bounces at lists.tizen.org] On Behalf Of Aleksander Zdyb
Sent: Tuesday, October 15, 2013 7:54 PM
To: dev at lists.tizen.org
Subject: [Dev] Mic trying to install 2 versions of one package

Hello all!

I'm working on some patches for systemd. I've built it using gbs and put in local repo (systemd-204-10.armv7l).
Now, when I'm trying to build an image using mic, I've got an error[1]:
Warning: repo problem: cannot install both libsystemd-204-10.armv7l and libsystemd-204-3.5.armv7l,

204-3.5 is current release in live repo[2], which I'm using to pull other packages.

Now why would mic try to install both remote and local version of libsystemd. I haven't specified any version anywere. Just "systemd" and "libsystemd" in kickstarter file.
I've done similar thing a few times before: pulling most of packages from remote repo and one or two from local one and it always worked.
Any ideas?

[1] It's a warring really, but it prevents image from being created due to unresolved repo problems [2] http://download.tizen.org/live/Tizen:/Mobile/arm/armv7l/

--
Aleksander Zdyb
Samsung R&D Institute Poland
Samsung Electronics

_______________________________________________
Dev mailing list
Dev at lists.tizen.org
https://lists.tizen.org/listinfo/dev


More information about the Dev mailing list