[Dev] Launching Tizen SDK application on Tizen 3.0

ASHISH SHRIVASTAVA ashish.shri at samsung.com
Fri Apr 4 13:05:06 GMT 2014


Hi,

The issue is related to many modules due to not in sync to tizen.org and due to which the build errors are occuring.
We need to contact to respective module's maintainer to resolve the synch issue.

Here are the list of mainatiner & integrator of all modules and SCM,
https://review.tizen.org/gerrit/#/admin/groups/
https://review.tizen.org/gerrit/#/admin/projects/

I request to all module's maintainer and integrators please synch the changes in review.org with the Tizen 2.2.1.
So below build error can resolve soon,
https://build.tizen.org/project/monitor?blocked=0&building=0&dispatching=0&finished=0&project=Tizen%3AMobile&scheduled=0&signing=0&succeeded=0

Regards,
Ashish

------- Original Message -------
Sender : Semun Lee<sm79.lee at samsung.com>  S5/Senior Engineer/Next Generation Computing Lab./Samsung Electronics
Date   : Apr 04, 2014 16:54 (GMT+05:30)
Title  : RE: [Dev] Launching Tizen SDK application on Tizen 3.0

Hi,

There are many build errors in the Tizen:Mobile project in OBS.

You can check the errors in the below link.
https://build.tizen.org/project/monitor?blocked=0&building=0&dispatching=0&f
inished=0&project=Tizen%3AMobile&scheduled=0&signing=0&succeeded=0

It is a serious problem. I think some repositories are not synced with the
Tizen 2.2.1.
I think Mateusz Malicki failed to run native application because of this
issue.
Those build failures should be fixed as soon as possible.

Best regards,
Semun

> -----Original Message-----
> From: dev-bounces at lists.tizen.org [mailto:dev-bounces at lists.tizen.org] On
> Behalf Of ASHISH SHRIVASTAVA
> Sent: Friday, April 04, 2014 7:02 PM
> To: dev at lists.tizen.org
> Subject: Re: [Dev] Launching Tizen SDK application on Tizen 3.0
> 
> Hello Mateusz Malicki,
> 
> You have mentioned about some bugs in this post, due to this you have made
> the changes in appfw, app-service and security-service modules.
> It will be good to know the issue which you faced and the purpose of your
> changes. We would be happy yo provide assistance in getting the issue
> resolved.
> 
> Regards,
> Ashish Shrivastava
> --------------------------------------------------------------------------
> -------------------------------------------------------------
> 
> Hello
> I am new in Tizen and almost new in English so forgive for glaring errors.
> I tried to run the application on the Tizen 3.0.
> Below are the steps that I need to do to achieve the goal.
> I had to make a few changes in the code and bypass a few bugs which I do
> not
> know how to solve.
> I have described a few problems which can't solve alone. I ask for your
> help.
> I want to change code of appfw, app-service, security-service.
> 
> 1. Execute osp-security-service.
> Take into account the changes introduced in the appfw
> https://review.tizen.org/gerrit/gitweb?p=platform/framework/native/appfw.g
> it
> ;a=commit;h=9663f301c007e5503a08505edff54b8521eb7949
> https://review.tizen.org/gerrit/#/c/18812/
> 
> Possibility to dynamic load by osp-loader(added -pie linker flag)
> https://review.tizen.org/gerrit/#/c/18813/
> 
> 2. Execute osp-app-service.
> 2.1. I think that commit
> https://review.tizen.org/gerrit/gitweb?p=platform/framework/native/app-
> servi
> ce.git;a=commit;h=275a4f30bfb384c5f6eb6f78ecd78b4c3af183d7 should by
> reverted.
> Above commit changed application path from /opt/apps to /opt/usr/apps.
> To launch service path must be set to PATH_OPT_APPS (=/opt/apps) which is
> defined in
> https://review.tizen.org/gerrit/gitweb?p=platform/framework/native/install
> er
> .git;a=blob;f=inc/InstallerDefs.h
> 2.2. Add _AppLaunchCondition::GetLaunchArgs in appfw.
> https://review.tizen.org/gerrit/#/c/18899/
> 
> 3. Execute osp-common-service.
> osp-common-service setup SettingsServer server.
> osp-common-service contain class derived from ServiceApp which construct
> _AppImpl object.
> _AppImpl Construct function creates SettingsService client instance.
> Client is created before SettingServer -- it always fails.
> I think that commit that provide above cyclic dependency should be
> reverted.
> https://review.tizen.org/gerrit/gitweb?p=platform/framework/native/appfw.g
> it
> ;a=commit;h=dbd01564f321df67ee66b6a1212198f48539003b
> For now i use:
> diff --git a/src/app/FApp_AppImpl.cpp b/src/app/FApp_AppImpl.cpp
> index e41f92a..6415e85 100644
> --- a/src/app/FApp_AppImpl.cpp
> +++ b/src/app/FApp_AppImpl.cpp
> @@ -141,7 +141,7 @@ _AppImpl::Construct(const IList* pArgs)
> 
>         _AppInfo::SetAppState(INITIALIZING);
> 
> -       r = _SettingInfoImpl::AddSettingEventListenerForInternal(*this);
> +    //r = _SettingInfoImpl::AddSettingEventListenerForInternal(*this);
>         SysTryLog(NID_APP, !IsFailed(r), "[%s] failed to add setting event
> listener.", GetErrorMessage(r));
> 
>         return E_SUCCESS;
> 
> 4. Execute sample service application (it was build with Tizen SDK).
> Still investigating.
> Hint: with following patch causes application works.
> 
> diff --git a/src/security/FSec_PrivilegeInfo.cpp
> b/src/security/FSec_PrivilegeInfo.cpp
> index bc6621c..f704517 100644
> --- a/src/security/FSec_PrivilegeInfo.cpp
> +++ b/src/security/FSec_PrivilegeInfo.cpp
> @@ -250,7 +250,7 @@ _PrivilegeInfo::Construct(const AppId& appId, const
> String& encryptedPrivileges,
>         memcpy(__bitwisePrivilege, pDecrytpedBitwisePrivilege,
> __bitwiseLength);
>         __appId = appId;
> 
> -       __apiVisibility = visibility;
> +       __apiVisibility = visibility + 1000;
> 
>         std::unique_ptr<IEnumerator> pEnum(null);
>         r = __privilegeList.Construct(32, 0.75);
> 
> 
> Regards,
> Mateusz
> 
> 
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev

<p> </p><p> </p>


More information about the Dev mailing list