[Dev] [SDK/Emulator] Emulator kernel upgrade is postponed and other issues...

Stanislav Vorobiov s.vorobiov at samsung.com
Wed Apr 23 11:26:25 GMT 2014


Hi, SeokYeon

I think I found the cause of this problem, try removing "-soundhw all" from your qemu command line, it should work.
It turned out I had it removed all along, but when I put it back I get a kernel hang.

There must be some problems handling sound with new kernel, I'll try to find out what they are...

On 04/23/2014 06:12 AM, SeokYeon Hwang wrote:
> Sorry for my late reply.
> 
> A mail server was malfunction till yesterday.
> 
> Thekernel load time I meantwas"afterkernel loading->before init start" time.
> 
> [    0.000000] Initializing cgroup subsys cpuset[    0.000000] Initializing cgroup subsys cpu...
> 
> ...
> 
> ...
> 
> Image mount[   12.729651] kjournald starting.  Commit interval 5 seconds[   12.731320] EXT3-fs (vda): using internal journal[   12.732636] EXT3-fs (vda): recovery complete[   12.733517] EXT3-fs (vda): mounted filesystem with writeback data mode***[  
> 12.734886]*mount used greatest stack depth: 6132 bytes leftcreate device filesystemSwitching root
> 
> I meant“12.734886”seconds.
> 
> Itmightbenot related with 3.12 kernel hang-up issue.
> 
> But I’mcuriouswhy“HAX enabled”is much slowerthan“HAX disabled”.
> 
> Back to the hang-up issue, it is notpermanenthang-up.
> 
> It proceedsafter 5 minutes ~ 15 minutes.
> 
> But kernel time is passingonlyfew milliseconds.
> 
> It might bea potential critical problemwhateverkernel version is, so I hope to figure out cause of this, ASAP.
> 
> Thanks.
> 
> -----Original Message-----
> From:Stanislav Vorobiov [mailto:s.vorobiov at samsung.com]
> Sent:Friday, April 18, 2014 4:07 PM
> To:SeokYeon Hwang; dev at lists.tizen.org; 'Ji, John'; ritu.sood at intel.com
> Subject:Re: [Dev] [SDK/Emulator] Emulator kernel upgrade is postponed and other issues...
> 
> Hi,
> 
>> How long kernel load time (after kernel loading -> before "init" 
> 
>> starts) at your Windows PC with HAX enabled and HAX disabled ??
> 
> How do you measure the time between kernel loading and init start ? Do you modify guest filesystem somehow ?
> 
> I've measured time from emulator startup to UI, it's 20-22secs with HAX and about 2m 20secs without HAX
> 
> On 04/18/2014 10:41 AM, SeokYeon Hwang wrote:
> 
>> Yes, It can reproduce even with g_poll patch.
> 
>> We can reproduce it on most of Windows PCs. It may be timing issues 
> 
>> depend on PC's performance, ...
> 
>> 
> 
>> How long kernel load time (after kernel loading -> before "init" 
> 
>> starts) at your Windows PC with HAX enabled and HAX disabled ??
> 
>> 
> 
>> -----Original Message-----
> 
>> From: Stanislav Vorobiov [mailto:s.vorobiov at samsung.com]
> 
>> Sent: Friday, April 18, 2014 2:59 PM
> 
>> To: SeokYeon Hwang;dev at lists.tizen.org<mailto:dev at lists.tizen.org>; 'Ji, John';
> 
>>ritu.sood at intel.com<mailto:ritu.sood at intel.com>
> 
>> Subject: Re: [Dev] [SDK/Emulator] Emulator kernel upgrade is postponed
> 
>> and other issues...
> 
>> 
> 
>> Hi, SeokYeon
> 
>> 
> 
>> This happens even withhttps://review.tizen.org/gerrit/#/c/19414/right ?
> 
>> 
> 
>> Before that patch kernel 3.12 didn't boot at all, but now it boots 
> 
>> every time (fast) and I can't reproduce this hang...
> 
>> 
> 
>> Also, regarding boot delays with HAX, I do experience them on mac os 
> 
>> x, I'm not sure if it's related though...
> 
>> 
> 
>> On 04/18/2014 08:11 AM, SeokYeon Hwang wrote:
> 
>>> I'll postpone to apply 3.12 linux kernel to tizen because of a big
> 
>> problem.
> 
>>>
> 
>>> The problem is that the hang happens for a certain period of time 
> 
>>> (several
> 
>> minutes) when booting in many Windows PC.
> 
>>>
> 
>>> Until resolving the problem, I'll postpone it.
> 
>>>
> 
>>>  
> 
>>>
> 
>>> We need a help to resolve it, especially from HAX developers. 
> 
>>>
> 
>>> Because it happens when running with turned on VT acceleration with HAX.
> 
>>>
> 
>>> The other fact is that guest kernel time is stopped.
> 
>>>
> 
>>> Please treat this with a higher priority.
> 
>>>
> 
>>> The HAX may not be the cause of the problem. However, it will be very
> 
>> helpful if HAX developers help me.
> 
>>>
> 
>>>  
> 
>>>
> 
>>> Also, I have a question about HAX.
> 
>>>
> 
>>> Why does the running with disabled HAX be the faster than the running 
> 
>>> with
> 
>> enabled HAX for the time (loading kernel -> starting init) in Windows?
> 
>>>
> 
>>> It can affect the overall performance in Windows, so please check 
> 
>>> this
> 
>> performance issue.
> 
>>>
> 
>>>  
> 
>>>
> 
>>> Thanks.
> 
>>>
> 
>>>
> 
>>>
> 
>>> _______________________________________________
> 
>>> Dev mailing list
> 
>>>Dev at lists.tizen.org<mailto:Dev at lists.tizen.org>
> 
>>>https://lists.tizen.org/listinfo/dev
> 
>>>
> 
>> 
> 
>> 
> 



More information about the Dev mailing list