[Dev] Common/X11 schedule

Stéphane Desneux stephane.desneux at open.eurogiciel.org
Tue Aug 12 12:37:05 GMT 2014


Hi Boram,

We should review and accept the following changes before submitting X11
packages:

- https://review.tizen.org/gerrit/#/c/25669/
- https://review.tizen.org/gerrit/#/c/25479/

These patches define the new X11 images and adds the missing ones for ARM.

Anyway, you could make a first group submission without these changes
accepted to see what happens: if everything builds fine, I can already
accept the submission (or at least, we will see the few errors to fix).

Thanks
-- 
Stéphane Desneux
Intel OTC - Vannes/FR
gpg:1CA35726/DFA9B0232EF80493AF2891FA24E3A2841CA35726

On 12/08/2014 13:49, Boram Park wrote:
> Hello Stephane
> 
> I made a arm-x11 binary locally by using mic tool with attached 3 files.
> I added xkeyboard-config, xorg-launch-helper, xf86-video-fbdev and
> xf86-input-evdev packages to the binary.
> When I ran Xorg by manually, there seems no problem basically.
> 
> I think now it's ready to send SRs to push our works into Tizen:Common.
> If there is no other issue, I'll send group submission.
> 
> Regards
> Boram
> 
> On 08/06/2014 02:35 PM, Boram Park wrote:
>>
>> 08/02/2014 08:51 AM에 Stéphane Desneux 이(가) 쓴 글:
>>>
>>>>> I'll take a look at desktop-skin.
>>>> Our SCM guy said that the error related with qemu was caused by
>>>> ia32-x11 repo
>>>> things.
>>>> He modified something for devel:x11:common. Then desktop-skin error
>>>> disapeared.
>>>
>>> Good ! What was the change on devel:x11:common ? It could be useful to
>>> copy the change to main project: the devel:x11:common project config
>>> should be exactly aligned on Tizen:Common. If some change has been
>>> done to fix things, we must know.
>>
>> Jinkun said that devel:x11:common used the wrong qemu rpm package of
>> wrong arch (ia32-xxx) and he made devel:x11:common use the correct qemu
>> rpm package.
>>
>>>
>>>> And also zypper issues were also solved by rebuilding.
>>>> Only image-configurations and wayland-fits error remain.
>>>
>>> image-configuration was fixed by Jian-feng Ding and today I've
>>> submitted the changes on wayland-fits. No more error should occur.
>>
>> Thanks.
>>
>>>
>>>> We are going to create a arm-x11 binary image locally and test it
>>>> next week.
>>>
>>> If there are some specific fixes to introduce in ks files, please
>>> report.
>>
>> Creating local arm-x11 binary seems to be related with "Qeustion for
>> creating arm-wayland and arm-x11 images in Tizen:Common" mail.
>> In this case, I can do nothing for this issue. I hope SCM guys solve
>> this issue soon.
>>
>>>
>>> I'm currently working on platform/upstream/generic (tizen branch) and
>>> profile/meta/common (sandbox/sdx/devel) to define:
>>> - inheritable package groups (patterns) and ks scripts defined in
>>> meta-generic (95% done)
>>> - adjust all the images produced for all repos of Tizen:Common
>>> (+specific patterns + specific postscripts) in profile/meta/common.
>>> - fix image-configurations and package-groups to provide the expected
>>> results
>>>
>>> See https://bugs.tizen.org/jira/browse/PTREL-807 for background info
>>> and the reason of the split between platform/upstream/meta-generic and
>>> profile/common/meta.
>>>
>>>> I'll let you know the test result after that.
>>> Thanks !
>>>
>>> On my side, I've no more errors, even with specific intel drivers
>>> (xf86-video-intel, libva-intel-driver) I'll try to make another diff
>>> on Monday and report. We can also expect some working image on our
>>> side soon.
>>>
>>> BR
>>
> 


More information about the Dev mailing list