[Dev] DBus compile error

Joao Marinho Assis j.assis at samsung.com
Wed Aug 13 19:08:26 GMT 2014


Hi all,

 

I’ve being trying to build a simple Dbus test application for Tizen 2.2, but
I have build errors.

 

The app is a simple hello word that includes the dbus header file as
described in a dbus tutorial:

 

#include <stdio.h>

#include <dbus/dbus-glib.h>

 

int main(int argc, char *argv[])

{

     printf("Hello World!\n");

     return 0;

}

 

A “BuildRequires” was added in my .spec file:

BuildRequires:    pkgconfig(dbus-glib-1)

 

 

My .gbs.conf is attached, it basically points to
http://download.tizen.org/releases/2.2/tizen-2.2/

 

When I try to build, it does not find the header file:

 

[   27s] + export FFLAGS

[   27s] + LD_AS_NEEDED=1

[   27s] + export LD_AS_NEEDED

[   27s] + make -j16

[   27s] cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
-fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian
-mfpu=vfpv3 -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb
example-platform-app.c   -o example-platform-app

[   27s] example-platform-app.c:2:28: fatal error: dbus/dbus-glib.h: No such
file or directory

[   27s] compilation terminated.

[   27s] make: *** [example-platform-app] Error 1

[   27s] error: Bad exit status from /var/tmp/rpm-tmp.rvh5t6 (%build)

[   27s] 

[   27s] 

[   27s] RPM build errors:

[   27s]     Bad exit status from /var/tmp/rpm-tmp.rvh5t6 (%build)

 

I checked my root strap folder and dbus was downloaded correctly (with the
date of today):

 

~/GBS-ROOT/local/BUILD-ROOTS/scratch.armv7l.0/usr/include/dbus-1.0/dbus/dbus
-glib.h

 

So I am not sure why it keeps giving me the error. The command used to build
is: 

 

$ gbs build -A armv7l --include-all

 

I also tried doing a “ --clean --clean-repos” and then a “--include-all”,
but also not worked.

 

Thanks very much!

 

 

--
João Marinho C. Assis

Samsung Brazil



 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140813/8db1c2af/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .gbs.conf
Type: application/octet-stream
Size: 168 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140813/8db1c2af/attachment.obj>


More information about the Dev mailing list