[Dev] Tizen Build Using Yocto - bitbake error mesa_10.1.3.bb, do_configure

Anoop Babu babu.anoop at gmail.com
Fri Aug 22 12:39:12 GMT 2014


Dear Kevin,

Thank you for your valuable inputs. I commented out statement related egl
and gallium egl, with that I could proceed to overcome the mesa package
error.
Finally was able to reach  do_rootfs stage, where it broke down stating
mesa installation errors for which I had comment out dependencies as you
had mentioned.
I could over come that error but hit upon another series of error. I have
attached the log files for the same.
Hope clear this hurdle. Expecting you valuable inputs.

Please find the attached log files.

Best regards
Anoop


Best regards
     A.B
P Please think about the environment before printing this e-mail

*7 Switch off as you go | qAlways recycle | P Save a tree...please don't
print this e-mail unless you really need to.*


On Wed, Aug 20, 2014 at 6:18 PM, Kévin THIERRY <
kevin.thierry at open.eurogiciel.org> wrote:

> Hi Anoop,
>
> If don't mind not having mesa maybe you can just remove it from the image
> recipe. In meta-tizen/recipes-image/tizen-core-image-minimal.bb comment
> or remove those lines:
>
> CORE_IMAGE_BASE_INSTALL += "mesa-megadriver"
> CORE_IMAGE_BASE_INSTALL += "libegl-gallium"
> CORE_IMAGE_BASE_INSTALL += "libegl-mesa"
> CORE_IMAGE_BASE_INSTALL += "libgbm"
> CORE_IMAGE_BASE_INSTALL += "libgbm-gallium"
> CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-nouveau"
> CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-swrast"
> CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-vmwgfx"
> CORE_IMAGE_BASE_INSTALL += "mesa-driver-pipe-i915"
> CORE_IMAGE_BASE_INSTALL += "libgles1-mesa"
> CORE_IMAGE_BASE_INSTALL += "libgles2-mesa"
>
> Regarding BlueZ 5 I think it is an upstream recipe and I've never had this
> kind of error. Try to google it and if you find nothing look at what
> bitbake is trying to do directly in the code. You can also ask the Yocto
> guys on the relevant yocto mailing list or directly on IRC. Also you may
> want to clean the bluez5 project and try to build it again in case your
> environment has been corrupted (bitbake bluez5 -c cleanall).
>
> I hope this help,
> Kevin
>
>
>
> On 20/08/2014 14:10, Anoop Babu wrote:
>
>> Dear Kevin, Xavier,
>>
>> I have commented out GALLIUMDRIVERS_append = ",i915" in mesa_%.bbappend
>> under meta-tizen/recipes-graphics/mesa/.
>> Unfortunately I haven't overcome the do configure error for mesa - ERROR:
>> oe_runconf failed.
>>
>> I also hit upon another error.
>> ERROR: Recipe bluez5 is trying to change PR from 'r1' to 'r11'. This will
>> cause do_package_write_* failures since the incorrect data will be used and
>> they will be unable to find the right workdir.
>> ERROR: Function failed: read_subpackage_metadata
>> ERROR: Logfile of failure stored in: /home/sfm/YOCTO/build/tmp/
>> work/cortexa9hf-vfp-neon-poky-linux-gnueabi/bluez5/5.21-r1/
>> temp/log.do_package_write_rpm.31553
>> NOTE: recipe bluez5-5.21-r1: task do_package_write_rpm: Failed
>> ERROR: Task 2107 (/home/sfm/YOCTO/poky/meta/recipes-connectivity/bluez5/
>> bluez5_5.21.bb <http://bluez5_5.21.bb>, do_package_write_rpm) failed
>> with exit code '1'
>>
>>
>> attached the log file for the same.
>>
>> Best regards
>> Anoop
>>
>>
>>
>> On Wed, Aug 20, 2014 at 4:12 PM, Anoop Babu <babu.anoop at gmail.com
>> <mailto:babu.anoop at gmail.com>> wrote:
>>
>>     Thank you Kevin. Yes I have to admit that I have totally gone
>>     wrong here. I will make the changes as suggested.
>>
>>     Regards
>>     Anoop
>>
>>
>>
>>
>>     On Tue, Aug 19, 2014 at 8:54 PM, Kévin THIERRY
>>     <kevin.thierry at open.eurogiciel.org
>>     <mailto:kevin.thierry at open.eurogiciel.org>> wrote:
>>
>>
>>         On 19/08/2014 17:10, Anoop Babu wrote:
>>
>>             Dear Xiaver,
>>
>>             Further to making the changes you have suggested
>>             unfortunately I still cannot get over the error. I doubt
>>             whether mesa_%.bbappend file has more to it than what i
>>             have added based on your inputs. Please share your thoughts
>>             I have attached the logs for your reference.
>>
>>             Best regards
>>               Anoop
>>
>>
>>
>>             On Mon, Aug 18, 2014 at 7:38 PM, Anoop Babu
>>             <babu.anoop at gmail.com <mailto:babu.anoop at gmail.com>
>>             <mailto:babu.anoop at gmail.com
>>
>>             <mailto:babu.anoop at gmail.com>>> wrote:
>>
>>                 Dear Xavier,
>>
>>                 Thank you for your valuable inputs. I do not have
>>             mesa_%.bbappend
>>                 file in mesa. But i have created one and add the
>>             change that you
>>                 have mentioned.
>>
>>                 Best regards
>>                 Anoop
>>
>>         I think you looked in the wrong directory. There is a
>>         mesa_%.bbappend in meta-tizen/recipes-graphics/mesa/. Try the
>>         modification Xavier gave you in this file, it may work (and
>>         remove the one you created).
>>
>>
>>
>>
>>                 On Mon, Aug 18, 2014 at 6:47 PM, Xavier Roche
>>                 <xavier.roche at eurogiciel.fr
>>             <mailto:xavier.roche at eurogiciel.fr>
>>             <mailto:xavier.roche at eurogiciel.fr
>>
>>             <mailto:xavier.roche at eurogiciel.fr>>>
>>
>>                 wrote:
>>
>>                     Hi Anoop,
>>
>>                     I'm currently working on making an arm based yocto
>>             tizen image.
>>                     As you can read in Kevin's weekly report, there
>>             are still
>>                     several things to fix in order to build a suitable
>>             image.
>>                     I will create a specific qemuarm recipe you could
>>             then refer
>>                     to for your IMX6 target. I won't publish this
>>             recipe for the
>>                     moment since major fixes (related on RPM staff)
>>             are supposed
>>                     to be pushed on meta-tizen ASAP..
>>
>>                     In the mid-time I would recommend you to manually
>>             deactivate
>>                     mesa gallium driver in :
>>                     /recipes-graphics/mesa/mesa_%.bbappend :
>>
>>                         -GALLIUMDRIVERS_append = ",i915"
>>                         \ No newline at end of file
>>                         +#GALLIUMDRIVERS_append = ",i915"
>>
>>
>>                     Best regards,
>>
>>                     Xavier
>>
>>
>>
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140822/62838960/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 20140822094840.log
Type: application/octet-stream
Size: 87761 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140822/62838960/attachment-0004.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: log.do_rootfs.17933
Type: application/octet-stream
Size: 56420 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140822/62838960/attachment-0005.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: run.do_rootfs.17933
Type: application/octet-stream
Size: 309 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140822/62838960/attachment-0006.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tizen-core-image-minimal.bb
Type: application/octet-stream
Size: 1575 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140822/62838960/attachment-0007.obj>


More information about the Dev mailing list