[Dev] gbs build error

Negreanu, Adrian M adrian.m.negreanu at intel.com
Mon Feb 17 21:11:33 GMT 2014


On Mon, Feb 17, 2014 at 6:23 PM, Suresh Kanzariya <skanzariya at gmail.com>wrote:

> Hello Friends,
>
> I am getting following error while install gbs in my Ubuntu 12.04 lts.
>
> apt-get install gbs
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  gbs : Depends: depanneur (>= 0.11) but it is not going to be installed
>        Recommends: librpm-tizen (>=
> 4.11.0.1.tizen20130618-tizen20131001) but it is not going to be
> installed
> E: Unable to correct problems, you have held broken packages.
>
> I am totally lost, Please help me to figure out the problem in order
> to install gbs, Please let me know If I am missing any
> module/dependency.
>
> Hi,

I hit a similar  problem on Debian sid.
First, you can try to see why librpm-tizen is failing to install:
   apt-get install librpm-tizen

In my case, it was crypt-ssleay that was conflicting with the some package
in Debian.
I just built crypt-ssleay from source using:
  apt-get build-dep crypt-ssleay
  apt-get source --compile crypt-ssleay







> Thanks.
>
> Regards,
> Suresh
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev
>



-- 
Adrian Marius Negreanu
Intel Open Source Technology Center
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140217/4dead8df/attachment.html>


More information about the Dev mailing list