[Dev] gbs build error

Kanevskiy, Alexander alexander.kanevskiy at intel.com
Mon Feb 24 16:08:16 GMT 2014


On 24/02/14 17:58 , "Suresh Kanzariya" <skanzariya at gmail.com> wrote:

>Hi,
>
>Now contineuing to this thread. Ok, as Qiang said I removed source
>installation and trying to install gbs from apt-get, but I ended up
>with same error.
>
>here is the log
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>Some packages could not be installed. This may mean that you have
>requested an impossible situation or if you are using the unstable
>distribution that some required packages have not yet been created
>or been moved out of Incoming.
>The following information may help to resolve the situation:
>
>The following packages have unmet dependencies:
> gbs : Depends: depanneur (>= 0.11) but it is not going to be installed
>       Recommends: librpm-tizen (>=
>4.11.0.1.tizen20130618-tizen20131001) but it is not going to be
>installed
>E: Unable to correct problems, you have held broken packages.


if you say “apt-get install depanneur” what it would show ?

also, can you please show what do you have as output of “apt-cache policy
depanneur” ?


>
>And while installing librpm-tize, I got
>root at skanzariya:~# apt-get install librpm-tizen
>Reading package lists... Done
>Building dependency tree
>Reading state information... Done
>Some packages could not be installed. This may mean that you have
>requested an impossible situation or if you are using the unstable
>distribution that some required packages have not yet been created
>or been moved out of Incoming.
>The following information may help to resolve the situation:
>
>The following packages have unmet dependencies:
> librpm-tizen : Depends: liblzma5 (>= 5.1.1alpha+20120614) but
>5.1.1alpha+20110809-3 is to be installed
>E: Unable to correct problems, you have held broken packages.

Are you sure that you’re trying to install gbs and tools from repository
intended for Ubuntu 12.04 ?
Just looking at above error message, it looks like you’re trying to
install from either 12.10/13.04 or 13.10 repositories, but not from 12.04.

Please check that you have in your /etc/apt/sources.list line

deb http://download.tizen.org/tools/latest-release/Ubuntu_12.04/ /

and not some other version of Ubuntu.


>
>Now as @adrian said I install liblzma5 from source, but still getting
>the same error.
>
>I have installed Ubuntu 12.04 in virtualbox running inside Mac.
>
>Thanks,
>Suresh
>
>On 2/24/14, Suresh Kanzariya <skanzariya at gmail.com> wrote:
>> Hello Jian,
>>
>> In that thread I was getting error while installing  gbs, and while
>> build packages I got an error so started new thread, but from the
>> discussion with the Qiang, it looks like it is related to the gbs
>> build, since i installed it from source.
>>
>> Qiang,
>> I will now post my updates to the old thread.
>>
>> Thanks.
>> Suresh
>>
>> On 2/24/14, Jian-feng Ding <jian-feng.ding at intel.com> wrote:
>>> Suresh,
>>>
>>> Is it the same issue as the thread "[Dev] gbs error while building
>>> package"?
>>> Or releated to.  If so, how about focus on the discussion in that that
>>> thread,
>>> which is actively tracked by gbs developer Qiang.
>>>
>>> thanks
>>> - jf.ding
>>>
>>> On Sun, Feb 23, 2014 at 12:16:51PM +0530, Suresh Kanzariya wrote:
>>>> I forgot dev to CC. :)
>>>> On 2/18/14, Suresh Kanzariya <skanzariya at gmail.com> wrote:
>>>> > Hello Lukasz,
>>>> >
>>>> > Thanks for the reply. Finally I managed to install gbs in my ubuntu
>>>> > 12.04. I installed it from source downloaded from github and
>>>>installed
>>>> > necessary packages.
>>>> >
>>>> > Now I am able to run gbs. :) Happy.
>>>> >
>>>> > Sincere Regards,
>>>> > Suresh
>>>> >
>>>> > On 2/17/14, Łukasz Stelmach <l.stelmach at samsung.com> wrote:
>>>> >> It was <2014-02-17 pon 17:23>, when Suresh Kanzariya wrote:
>>>> >>> I am getting following error while install gbs in my Ubuntu 12.04
>>>> >>> lts.
>>>> >>>
>>>> >>> apt-get install gbs
>>>> >>> Reading package lists... Done
>>>> >>> Building dependency tree
>>>> >>> Reading state information... Done
>>>> >>> Some packages could not be installed. This may mean that you have
>>>> >>> requested an impossible situation or if you are using the unstable
>>>> >>> distribution that some required packages have not yet been created
>>>> >>> or been moved out of Incoming.
>>>> >>> The following information may help to resolve the situation:
>>>> >>>
>>>> >>> The following packages have unmet dependencies:
>>>> >>>  gbs : Depends: depanneur (>= 0.11) but it is not going to be
>>>> >>> installed
>>>> >>>        Recommends: librpm-tizen (>=
>>>> >>> 4.11.0.1.tizen20130618-tizen20131001) but it is not going to be
>>>> >>> installed
>>>> >>> E: Unable to correct problems, you have held broken packages.
>>>> >>>
>>>> >>> I am totally lost, Please help me to figure out the problem in
>>>>order
>>>> >>> to install gbs, Please let me know If I am missing any
>>>> >>> module/dependency.
>>>> >>
>>>> >> What is the url of the repository you use?
>>>> >>
>>>> >> Have you tried "apt-get update"?
>>>> >>
>>>> >> --
>>>> >> Łukasz Stelmach
>>>> >> Samsung R&D Institute Poland
>>>> >> Samsung Electronics
>>>> >>
>>>> >
>>>> _______________________________________________
>>>> Dev mailing list
>>>> Dev at lists.tizen.org
>>>> https://lists.tizen.org/listinfo/dev
>>>
>>
>_______________________________________________
>Dev mailing list
>Dev at lists.tizen.org
>https://lists.tizen.org/listinfo/dev
>


-- 
Best regards, Alexander Kanevskiy.



---------------------------------------------------------------------
Intel Finland Oy
Registered Address: PL 281, 00181 Helsinki 
Business Identity Code: 0357606 - 4 
Domiciled in Helsinki 

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.


More information about the Dev mailing list