[Dev] gbs build error

Zhang, Qiang Z qiang.z.zhang at intel.com
Tue Feb 25 02:19:15 GMT 2014



> -----Original Message-----
> From: Suresh Kanzariya [mailto:skanzariya at gmail.com]
> Sent: Monday, February 24, 2014 11:59 PM
> To: Ding, Jian-feng
> Cc: Zhang, Qiang Z; Łukasz Stelmach; dev
> Subject: Re: [Dev] gbs build error
> 
> Hi,
> 
> Now contineuing to this thread. Ok, as Qiang said I removed source
> installation and trying to install gbs from apt-get, but I ended up with same
> error.
> 
> here is the log
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created or been
> moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  gbs : Depends: depanneur (>= 0.11) but it is not going to be installed
>        Recommends: librpm-tizen (>=
> 4.11.0.1.tizen20130618-tizen20131001) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> 
> And while installing librpm-tize, I got
> root at skanzariya:~# apt-get install librpm-tizen Reading package lists... Done
> Building dependency tree Reading state information... Done Some packages
> could not be installed. This may mean that you have requested an impossible
> situation or if you are using the unstable distribution that some required
> packages have not yet been created or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  librpm-tizen : Depends: liblzma5 (>= 5.1.1alpha+20120614) but
> 5.1.1alpha+20110809-3 is to be installed
> E: Unable to correct problems, you have held broken packages.
> 
[Qiang] So, We found the root cause now.
> Now as @adrian said I install liblzma5 from source, but still getting the same
> error.
[Qiang] apt package manager does not recognize packages installed from sources.

So, you should install from repos. Note that' all gbs and it's dependencies can be available from official Ubuntu repo and our tools repo.

In your case, it seems that your base system has been updated to a unstable state(some packages are not maintained by upstream).

So please remove liblzma4 from source, then try:

$ apt-get install liblzma5, see what's the root cause in deep.

We need using this way to found what packages conflicts. Remember that it's not missing some package, but some packages installed in your system conflict with official version.

We need find that package and fix the broken.


Thanks
Qiang
> 
> I have installed Ubuntu 12.04 in virtualbox running inside Mac.
> 
> Thanks,
> Suresh
> 
> On 2/24/14, Suresh Kanzariya <skanzariya at gmail.com> wrote:
> > Hello Jian,
> >
> > In that thread I was getting error while installing  gbs, and while
> > build packages I got an error so started new thread, but from the
> > discussion with the Qiang, it looks like it is related to the gbs
> > build, since i installed it from source.
> >
> > Qiang,
> > I will now post my updates to the old thread.
> >
> > Thanks.
> > Suresh
> >
> > On 2/24/14, Jian-feng Ding <jian-feng.ding at intel.com> wrote:
> >> Suresh,
> >>
> >> Is it the same issue as the thread "[Dev] gbs error while building
> >> package"?
> >> Or releated to.  If so, how about focus on the discussion in that
> >> that thread, which is actively tracked by gbs developer Qiang.
> >>
> >> thanks
> >> - jf.ding
> >>
> >> On Sun, Feb 23, 2014 at 12:16:51PM +0530, Suresh Kanzariya wrote:
> >>> I forgot dev to CC. :)
> >>> On 2/18/14, Suresh Kanzariya <skanzariya at gmail.com> wrote:
> >>> > Hello Lukasz,
> >>> >
> >>> > Thanks for the reply. Finally I managed to install gbs in my
> >>> > ubuntu 12.04. I installed it from source downloaded from github
> >>> > and installed necessary packages.
> >>> >
> >>> > Now I am able to run gbs. :) Happy.
> >>> >
> >>> > Sincere Regards,
> >>> > Suresh
> >>> >
> >>> > On 2/17/14, Łukasz Stelmach <l.stelmach at samsung.com> wrote:
> >>> >> It was <2014-02-17 pon 17:23>, when Suresh Kanzariya wrote:
> >>> >>> I am getting following error while install gbs in my Ubuntu
> >>> >>> 12.04 lts.
> >>> >>>
> >>> >>> apt-get install gbs
> >>> >>> Reading package lists... Done
> >>> >>> Building dependency tree
> >>> >>> Reading state information... Done Some packages could not be
> >>> >>> installed. This may mean that you have requested an impossible
> >>> >>> situation or if you are using the unstable distribution that
> >>> >>> some required packages have not yet been created or been moved
> >>> >>> out of Incoming.
> >>> >>> The following information may help to resolve the situation:
> >>> >>>
> >>> >>> The following packages have unmet dependencies:
> >>> >>>  gbs : Depends: depanneur (>= 0.11) but it is not going to be
> >>> >>> installed
> >>> >>>        Recommends: librpm-tizen (>=
> >>> >>> 4.11.0.1.tizen20130618-tizen20131001) but it is not going to be
> >>> >>> installed
> >>> >>> E: Unable to correct problems, you have held broken packages.
> >>> >>>
> >>> >>> I am totally lost, Please help me to figure out the problem in
> >>> >>> order to install gbs, Please let me know If I am missing any
> >>> >>> module/dependency.
> >>> >>
> >>> >> What is the url of the repository you use?
> >>> >>
> >>> >> Have you tried "apt-get update"?
> >>> >>
> >>> >> --
> >>> >> Łukasz Stelmach
> >>> >> Samsung R&D Institute Poland
> >>> >> Samsung Electronics
> >>> >>
> >>> >
> >>> _______________________________________________
> >>> Dev mailing list
> >>> Dev at lists.tizen.org
> >>> https://lists.tizen.org/listinfo/dev
> >>
> >


More information about the Dev mailing list