[Dev] devtmpfs error come out when boot up tizen kernel3.10 on odroid u3

Joonyoung Shim jy0922.shim at samsung.com
Tue Jul 1 01:25:01 GMT 2014


Hi,

On 07/01/2014 03:06 AM, Byonggon Chun wrote:
> hi i try porting tizen on odroid u3.
>
> first of all that is my testing environment.
> ====================================================================
> ...ubuntu 12.04 LTS 64bit && odroid u3
> -newest u-boot with samsung's odroid xu/u3 dts & config file patch
> -tizen kernel 3.10 branch tizen(tizen_odroid_defconfig)
> https://review.tizen.org/gerrit/gitweb?p=platform%2Fkernel%2Flinux-3.10.git;a=shortlog;h=refs%2Fheads%2Ftizen
> -tizen 2.2 releases image(RD-PQ)
> http://download.tizen.org/releases/2.2/tizen-2.2/images/RD-PQ/
>
> uboot bootargs(default)
>    bootargs root=/dev/mmcblk${mmcrootdev}p${mmcrootpart} ${rootopts} 
> ${lpj} ${console}
>    mmcrootdev=0
>    mmcrootpart=2
>    rootopts=rootwait
>    console=console=ttySAC1,115200n8
>
> my sd card partition layout
>
> + -------------------------------------
> +|  Binary   | Block offset| part type |
> +|   name   | SD   | eMMC |(eMMC only)|
> + -------------------------------------
> +| Bl1         | 1    | 0    |  1 (boot) |
> +| Bl2         | 31   | 30   |  1 (boot) |
> +| U-boot    | 63   | 62   |  1 (boot) |
> +| Tzsw      | 2111 | 2110 |  1 (boot) |
> + -------------------------------------
>
> Partition Map for MMC device 0  --   Partition Type: DOS
> Part    Start Sector    Num Sectors     UUID  Type
>   1     2048            50331648        00010fb9-01     0c Boot
>   2     50333696        6291456         00010fb9-02 83
>   3     56625152        2097152         00010fb9-03 83
>   4     58722304        3108864         00010fb9-04 83
>
> 1.boot 2.platform 3.data 4.UMS
> =====================================================================
>
> i use newest version of u-boot with samsung's odroid u3/x2 patch.
> that patch add odroid_config file on uboot and make newest uboot run 
> on odroid u3
> [U-Boot,v3,11/11] odroid: add odroid_config 
> <http://patchwork.ozlabs.org/patch/364559/>
> [U-Boot,v3,10/11] odroid: add odroid U3/X2 device tree description 
> <http://patchwork.ozlabs.org/patch/364555/>
> [U-Boot,v3,09/11] odroid: add board file for Odroid X2/U3 based on 
> Samsung Exynos4412 <http://patchwork.ozlabs.org/patch/364554/>
> [U-Boot,v3,08/11] samsung: misc: use board specific functions to set 
> env board info <http://patchwork.ozlabs.org/patch/364553/>
> [U-Boot,v3,07/11] samsung: board: enable support of multiple board 
> types <http://patchwork.ozlabs.org/patch/364557/>
> [U-Boot,v3,06/11] arm:reset: call the reset_misc() before the cpu 
> reset <http://patchwork.ozlabs.org/patch/364556/>
> [U-Boot,v3,05/11] samsung:board: misc_init_r: call set_dfu_alt_info() 
> <http://patchwork.ozlabs.org/patch/364551/>
> [U-Boot,v3,04/11] samsung: misc: add function for setting 
> $dfu_alt_info <http://patchwork.ozlabs.org/patch/364552/>
> [U-Boot,v3,03/11] board:samsung: check the boot device and init the 
> right mmc driver. <http://patchwork.ozlabs.org/patch/364558/>
> [U-Boot,v3,02/11] board:samsung: add function boot_device() for 
> checking boot medium <http://patchwork.ozlabs.org/patch/364549/>
> [U-Boot,v3,01/11] exynos: pinmux: fix the gpio names for exynos4x12 
> mmc <http://patchwork.ozlabs.org/patch/364550/>
>
> any way uboot working very well..
>
>
> but tizen 3.10 kernel (branch tizen) show error when devtmpfs and call 
> init
> =====================================================================
> [    2.204668] EXT3-fs (mmcblk0p2): error: couldn't mount because of 
> unsupported optional features (2)
> [    2.209209] EXT2-fs (mmcblk0p2): error: couldn't mount because of 
> unsupported optional features (2)
> [    2.221973] EXT4-fs (mmcblk0p2): mounted filesystem with ordered 
> data mode. Opts: (null)
> [    2.225876] VFS: Mounted root (ext4 filesystem) readonly on device 
> 179:2.
> [    2.233423] devtmpfs: error mounting -2

-2 means there is no file or dir.

#define ENOENT           2      /* No such file or directory */

Does your rootfs have /dev directory? Because devtmpfs is mounted at the 
/dev

> [    2.236585] Freeing unused kernel memory: 220K (c0782000 - c07b9000)
> [    2.238475] mmc_host mmc0: Bus speed (slot 0) = 100000000Hz (slot 
> req 200000Hz, actual 200000HZ di)
> [    2.252464] Kernel panic - not syncing: No init found.  Try passing 
> init= option to kernel. See Li.
> ======================================================================
> this is my kenel booting log.
>
> i guess  'VFS: Mounted root (ext4 filesystem) readonly on device 
> 179:2.' this log means kernel success mount ext4 file system.
>
> But i have no idea what 'devtmpfs: error mounting -2' this log meaning.
>
> i think devtmpfs error log meaning something wrong when kernel mount 
> rootfs.
>
> and i think that some thing wrong cause kernel panic.
>
> is that something wrong at my partition layout or bootargs?
>
>
>
>
>
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev



More information about the Dev mailing list