[Dev] Common/Generic profile images usability

Roman Kubiak r.kubiak at samsung.com
Wed May 14 13:38:25 GMT 2014


I got the images running before (the IVI profile) on VMware, so VMware 
itself is not an issue.
My question was really, SHOULD I see something in the image, is there a 
UI in the common profile at all or is this a bare bones sort of OS image 
that contains no UI experience at all.

Anyway i tried the latest wayland common image and it still does not 
work, it looks like weston is not willing to start (it says it can't 
open /dev/dri/card0, the file is there btw and DRM is reporting fine)

I attached some logs to clarify the situation, so profile common latest 
image with wayland on x86_64 does not work in vmware.

My question about Xorg is still not answered, what is the UI for Xorg i 
should expec t to find in the common image (is there some sort of 
default WM that should launch?)

best regards
On 05/13/2014 07:15 PM, Dominig ar Foll (Intel OTC) wrote:
> Roman
>
> the X11 version is not any more maintained. Generic was the old name 
> of the project and when we moved to Common we dropped X11 as stated on 
> the Wiki page.
>   https://wiki.tizen.org/wiki/Common#Display_Architectures
>
> Until now we have not try to create images for vmware, so if you 
> troubleshoot the issue and report your workaround we will be please to 
> see how we could make that mode of operation easier to support.
> The coming release should have the support for the emulator added that 
> might help.
>   https://wiki.tizen.org/wiki/Common#Reference_Hardware
>
> Thanks to let us know.
>
> Dominig ar Foll
> Senior Software Architect
> Open Source Technology Centre
> Intel SSG
>
> Le 13/05/2014 17:25, Roman Kubiak a écrit :
>> I downloaded the latest available common/generic images (common with 
>> wayland and generic with Xorg), but neither of those show any GUI 
>> (i'm using vmware-player to run the images). They start, the system 
>> is booting to the "Graphical Interfcae" target, but the window 
>> manager service is failing (btw, the SMACK rule loading service is 
>> failing too because it assumes that smackfs is mount at /smack, and 
>> it's not it's at /sys/fs/smackfs).
>>
>> Could someone tell me what is the default behaviour for those 
>> profiles. Should some sort of UI show up so I could test 
>> applications/widgets on those profiles, maybe i need to install some 
>> additional packages to get this running ?
>>
>> best regards
>>
>
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev
>

-- 
--------------
  Roman Kubiak
--------------

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140514/43684f9d/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: drm_dmesg.log
Type: text/x-log
Size: 1630 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140514/43684f9d/attachment-0004.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ls_al_dev_dri.log
Type: text/x-log
Size: 226 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140514/43684f9d/attachment-0005.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: systemctl_status.log
Type: text/x-log
Size: 18112 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140514/43684f9d/attachment-0006.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: weston.log
Type: text/x-log
Size: 984 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20140514/43684f9d/attachment-0007.log>


More information about the Dev mailing list