[Dev] [SDK/Emulator] The emulator, emulator-kernel upgrade notice.

Stanislav Vorobiov s.vorobiov at samsung.com
Fri May 16 16:41:54 GMT 2014


Hi, all

As for qemu crash problem I'm starting to suspect that it might be MinGW related, when I use
qemu from IVI sdk everything is ok, but when I build it myself from the same commit I get these problems (even for qemu 1.7),
I use pretty old MinGW with gcc 4.7.2, did anyone encounter problems with this gcc version on windows xp ?
I remember that there have been such issues in the past, but I'm not sure about which gcc version was it.

Regarding second issue (hrtimer) - this is audio related and it's different from FIFORDY problem, I think I saw some patches on the mailing list recently that
fixed some irq problems with intel-hda, need to check that...

On 05/15/2014 06:39 PM, Stanislav Vorobiov wrote:
> Hi, all
> 
> There're problems with qemu 2.0 and Tizen IVI, they started to happen after the merge. I've tried only on Windows XP + Sandy bridge for now.
> Steps to reproduce:
> 1. Launch Tizen IVI image
> 2. Open terminal
> 3. Type "dialer"
> 4. It will startup really slow and "hrtimer: interrupt took 182612036 ns" will be outputed very slowly into kernel log
> 5. Close dialer - qemu will crash
> 
> I couldn't get the backtrace, gdb says stack is corrupted, I could only see 1 function - ig4icd32.dll!DrvCopyContext
> this indicates that the crash **may be** related to OpenGL, but there were no graphics stack changes after
> the merge. What is also strange - if you switch to thread #1 in gdb you'll see that "WSACleanup" function is
> being called, but WSACleanup supposed to be called only on application shutdown, so why is it being called in the middle
> of operation ? Did anyone else experienced problems after qemu merge ?
> 
> On 05/14/2014 06:47 AM, SeokYeon Hwang wrote:
>> Hi, all.
>>
>>  
>>
>> The emulator has been upgraded to QEMU 2.0.
>>
>> The emulator kernel has been upgraded to kernel 3.12.x.
>>
>>  
>>
>> All parts related with “MARU_VGA”, “VirtGL” are removed. So now, the emulator runs with VIGS/YaGL only.
>>
>>  
>>
>> You must re-clone “emulator-kernel” because current “tizen” branch comes from “tizen_linux_3.12”.
>>
>>  
>>
>> Thanks.
>>
>>
>>
>> _______________________________________________
>> Dev mailing list
>> Dev at lists.tizen.org
>> https://lists.tizen.org/listinfo/dev
>>
> 
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev
> 



More information about the Dev mailing list