[Dev] [SDK/Emulator] The emulator, emulator-kernel upgrade notice.

Wang, Wenchao wenchao.wang at intel.com
Tue May 20 12:01:39 GMT 2014


After I re-cloned "emulator-kernel", I found that there was a script, build_x86_ivi.sh, in the project.

Currently, the emulator kernel for IVI is installed in ~/tizen-sdk/platforms/ivi-3.0/emulator-resources/kernel/bzImage. While, the default emulator kernel is ~/tizen-sdk/tools/emulator/data/kernel/bzImage.

Since the kernel image is platform-related, will there be more proper folders to place the bzImage for both in SDK? Or, should we distinguish them by file name in the default folder? As we also need to support mobile feature in Tizen IVI SDK by default.


Best Regards,
Wenchao


-----Original Message-----
From: Dev [mailto:dev-bounces at lists.tizen.org] On Behalf Of Stanislav Vorobiov
Sent: Thursday, May 15, 2014 10:39 PM
To: dev at lists.tizen.org
Subject: Re: [Dev] [SDK/Emulator] The emulator, emulator-kernel upgrade notice.

Hi, all

There're problems with qemu 2.0 and Tizen IVI, they started to happen after the merge. I've tried only on Windows XP + Sandy bridge for now.
Steps to reproduce:
1. Launch Tizen IVI image
2. Open terminal
3. Type "dialer"
4. It will startup really slow and "hrtimer: interrupt took 182612036 ns" will be outputed very slowly into kernel log 5. Close dialer - qemu will crash

I couldn't get the backtrace, gdb says stack is corrupted, I could only see 1 function - ig4icd32.dll!DrvCopyContext this indicates that the crash **may be** related to OpenGL, but there were no graphics stack changes after the merge. What is also strange - if you switch to thread #1 in gdb you'll see that "WSACleanup" function is being called, but WSACleanup supposed to be called only on application shutdown, so why is it being called in the middle of operation ? Did anyone else experienced problems after qemu merge ?

On 05/14/2014 06:47 AM, SeokYeon Hwang wrote:
> Hi, all.
> 
>  
> 
> The emulator has been upgraded to QEMU 2.0.
> 
> The emulator kernel has been upgraded to kernel 3.12.x.
> 
>  
> 
> All parts related with "MARU_VGA", "VirtGL" are removed. So now, the emulator runs with VIGS/YaGL only.
> 
>  
> 
> You must re-clone "emulator-kernel" because current "tizen" branch comes from "tizen_linux_3.12".
> 
>  
> 
> Thanks.
> 
> 
> 
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev
> 

_______________________________________________
Dev mailing list
Dev at lists.tizen.org
https://lists.tizen.org/listinfo/dev


More information about the Dev mailing list