[Dev] Common/Generic profile images usability

Graydon, Tracy tracy.graydon at intel.com
Wed May 21 17:41:12 GMT 2014


Max,

I recommend that, if you haven¹t already gotten the info you need, to ping
Ed Bartosh and Stephane Desneux (added them to thread). I would also
recommend opening a Jira bug for the changes you need for emulator support
and initially assign it to Ed or Stephane, who can then help you out or
redirect accordingly. Regardless, there should be a bug to track these
changes, if there isn¹t one already.

Tracy

On 5/20/14, 11:42 PM, "Yu, Max A" <max.a.yu at intel.com> wrote:

>Hi,
>
>I'd like to know who is the Release Engineer for Tizen:Common. I'm in
>Tizen SDK team and I want to have emulator image built for Tizen:Common.
>I have built emulator image for Tizen:IVI:Release for M14.1. You can see
>that there is a 'emulator' repo for Tizen:IVI:Release at
>https://build.tizen.org/project/show?project=Tizen%3AIVI%3ARelease .
>Which contains the following lines in its Project Configuration:
>
>#This solves emulators needs
>%if "%_repository" == "emulator"
>  Support: emulator-macros
>  Prefer: emulator-yagl
>%endif
>
>I hope the RE for Tizen:Common can do the similar thing to add emulator
>repo. Please kindly let me know if you have any question.
>
>Thanks,
>Max
>
>-----Original Message-----
>From: Dev [mailto:dev-bounces at lists.tizen.org] On Behalf Of José Bollo
>Sent: Friday, May 16, 2014 3:12 PM
>To: Roman Kubiak
>Cc: dev at lists.tizen.org
>Subject: Re: [Dev] Common/Generic profile images usability
>
>Hi Roman,
>
>the emulator-yagl is removed from common because it broke the build.
>We intend to provide emulator packages in common as soon as possible but
>we prefer to first fix ARM building.
>
>Sorry for that. Maybe you can install the emulator from an other repo but
>without warranty
>
>
>Best regards
>José
>
>On gio, 2014-05-15 at 18:43 +0200, Roman Kubiak wrote:
>> I can't find that package on the common-wayland-ia32 repository:
>> root at 10:~# zypper se emulator
>> Loading repository data...
>> Reading installed packages...
>> 
>> S | Name            | Summary                   | Type
>> --+-----------------+---------------------------+--------
>>   | emulator-macros | macros for emulator build | package
>> 
>> Is it somewhere else, my repositories on the image are default:
>> root at 10:~# zypper lr -u
>> # | Alias  | Name   | Enabled | Refresh |
>> URI             
>>                 
>> --+--------+--------+---------+---------+-----------------------------
>> --+--------+--------+---------+---------+-----------------------------
>> --+--------+--------+---------+---------+-----------------------------
>> --+--------+--------+---------+---------+-----------------
>> 1 | common | common | Yes     | No      |
>> http://download.tizen.org/snapshots/tizen/common/common-wayland-ia32/l
>> atest/repos/common/ia32/packages/
>> 
>> 
>> On 05/15/2014 05:48 PM, Stanislav Vorobiov wrote:
>> 
>> > Hi,
>> > 
>> > You're running this in qemu, right ? It looks like you're using
>> > mesa, i.e. that Common image probably has mesa in emul image
>>(mistakenly), you need to install emulator-yagl package, it should then
>>work. But I'm not 100% sure that everything else will work, I have no
>>idea what that Common image is and what it has inside.
>> > 
>> > On 05/15/2014 07:36 PM, Roman Kubiak wrote:
>> > > Well i can't get the DRM backend to work in wayland i tried the
>>latest IVI-emul image and the latest COMMON image both for i386. Weston
>>says (looks like a missing drm driver):
>> > > 
>> > > root at 10:~# weston --tty 1
>> > > Date: 2014-05-15 PDT
>> > > [08:34:28.394] weston 1.4.0
>> > >                http://wayland.freedesktop.org/
>> > >                Bug reports to:
>>https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=west
>>on&version=1.4.0
>> > >                Build:
>> > > [08:34:28.394] OS: Linux, 3.12.18+, #4 PREEMPT Thu May 15 15:57:16
>> > > CEST 2014, i686 [08:34:28.394] Using config file
>>'/etc/xdg/weston/weston.ini'
>> > > [08:34:28.395] Loading module '/usr/lib/weston/drm-backend.so'
>> > > [08:34:28.395] initializing drm backend [08:34:28.396] using
>> > > /dev/dri/card0 [08:34:28.396] Loading module
>> > > '/usr/lib/weston/gl-renderer.so'
>> > > failed to load module: /usr/lib/gbm/gbm_gallium_drm.so: cannot
>> > > open shared object file: No such file or directory [08:34:28.396]
>> > > failed to initialize egl [08:34:28.401] fatal: failed to create
>> > > compositor
>> > > 
>> > > But fbdev works fine.
>> > > 
>> > > best regards
>> > > On 05/15/2014 04:51 PM, Stanislav Vorobiov wrote:
>> > > > Hi, please see below
>> > > > 
>> > > > On 05/15/2014 06:42 PM, Roman Kubiak wrote:
>> > > > > Helo again.
>> > > > > 
>> > > > > I ditched vmware due to licensing issues for now, but thank you
>>for the help i know how to fix it and i understand how to get things
>>running.
>> > > > > 
>> > > > > I jumped to our own emulator based on qemu (there is a very
>>fresh piece of code on tizen.org). I got it to build and run the Common
>>image, weston shows up but starting anything is causing a segfault in
>>the tz-launcher process.
>> > > > > Though i was not able to start weston with the DRM backend,
>> > > > > it's running on fbdev. The VIGS/Yagl implementation in the
>> > > > > kernel/qemu might not be wayland ready,
>> > > > Actually, VIGS/YaGL already runs wayland, you can refer to Tizen
>> > > > IVI emulator, it uses tizen.org QEMU and runs Tizen IVI image.
>>I'm not sure about Common, I never actually tried it.
>> > > > 
>> > > > > but the FBDEV stuff seems to work fine. I don't know what
>> > > > > tz-launcher is doing that it's doing a segfault, i was able to
>>start a weston terminal and that seems to work.
>> > > > > 
>> > > > > The small fix i had to do was adding the display user to the
>> > > > > video group. Also the kernel for the emulator needs to be
>> > > > > rebuilt (the default config in the emulator-kernel repo
>> > > > > assumes that the root disk is /dev/vda and has that hard-coded
>> > > > > in a minimal initramfs that builds with the kernel)
>> > > > > 
>> > > > > Could someone tell me if tz-launcher might need DRM and that's
>>why it's crashing or is that something else i'd need to check ?
>> > > > > 
>> > > > > best regards
>> > > > > 
>> > > > > On 05/14/2014 07:15 PM, VanCutsem, Geoffroy wrote:
>> > > > > > Quick update:
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > I got the Tizen Common Weston desktop up and running under
>> > > > > > VMware using this image:
>> > > > > > http://download.tizen.org/releases/daily/tizen/common/common
>> > > > > > -wayland-x86_64/tizen_20140513.6/
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > The quickest way is to modify the
>> > > > > > /boot/extlinux/extlinux.conf file and add Œsecurity=none¹ to
>>the kernel command-line (workaround for
>>https://bugs.tizen.org/jira/browse/TIVI-2964), a more permanent
>>workaround (but not a complete fix) would be to modify the kernel config
>>to have vmwgfx built-in (instead of a module). I have also verified that
>>such modifications solves the issue (and you can keep security turned on
>>in that case which you really really want).
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > I can push a patch to have Œvmwgfx¹ built-in to Tizen Common.
>>In general, it may be good to re-use some of the specific kernel configs
>>that are described here also in the Tizen Common kernel:
>> > > > > > 
>>https://wiki.tizen.org/wiki/IVI/artem-kernel#Kernel_configuration (look
>>for those that are documented as useful for VMware).
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > Geoffroy
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > *From:*Dev [mailto:dev-bounces at lists.tizen.org] *On Behalf
>> > > > > > Of *VanCutsem, Geoffroy
>> > > > > > *Sent:* Wednesday, May 14, 2014 5:56 PM
>> > > > > > *To:* Roman Kubiak; dev at lists.tizen.org
>> > > > > > *Subject:* Re: [Dev] Common/Generic profile images usability
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > Hi Roman,
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > If you¹re interested, I used to keep some Œrecipes¹ on how
>> > > > > > to run Tizen IVI 2.0 (based on X) under VMware, it¹s
>> > > > > > described here:
>>https://wiki.tizen.org/wiki/IVI/IVI_2.0_VMware. Back then, I had to
>>provide the xorg-x11-drv-vmware driver (as you have pointed out below)
>>and I also had to modify some of the build options used for mesa and
>>libdrm. Feel free to take a look there if you want to get that working
>>but as pointed out by Dominique, we are not focused on X in Tizen 3.0 so
>>I¹m not sure where this would lead you to.
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > A more interesting path would be to get the Wayland image
>> > > > > > running on VMware. I have quickly looked at the kernel used
>> > > > > > in Common and the vmwgfx driver is built as a module which
>> > > > > > means we could be hitting
>> > > > > > https://bugs.tizen.org/jira/browse/TIVI-2964
>> > > > > > <https://bugs.tizen.org/jira/browse/TIVI-2964>. I¹ll see if
>> > > > > > I can run a quick test on my side to validate this. If that¹s
>>the problem, you could try to turn security off (add Œsecurity=none¹ at
>>the kernel command-line) or rebuild the kernel with the Œvmwgfx¹ driver
>>built-in.
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > Geoffroy
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > *From:*Dev [mailto:dev-bounces at lists.tizen.org] *On Behalf
>> > > > > > Of *Roman Kubiak
>> > > > > > *Sent:* Wednesday, May 14, 2014 4:07 PM
>> > > > > > *To:* dev at lists.tizen.org <mailto:dev at lists.tizen.org>
>> > > > > > *Subject:* Re: [Dev] Common/Generic profile images usability
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > Just to update the Xorg image won't work either, there is
>>only one driver included in the image for Xorg and that's the
>>intel_drv.so (bit selfish i think) no fbdev or vmware drivers are
>>present so Xorg will never start.
>> > > > > > Also i can't any service in systemctl that could be some sort
>>of a windows manager.
>> > > > > > 
>> > > > > > best regards
>> > > > > > Roman Kubiak
>> > > > > > 
>> > > > > > On 05/14/2014 03:59 PM, Dominig ar Foll (Intel OTC) wrote:
>> > > > > > 
>> > > > > > 
>> > > > > >     Le 14/05/2014 15:38, Roman Kubiak a écrit :
>> > > > > > 
>> > > > > >         I got the images running before (the IVI profile) on
>>VMware, so VMware itself is not an issue.
>> > > > > >         My question was really, SHOULD I see something in the
>>image, is there a UI in the common profile at all or is this a bare
>>bones sort of OS image that contains no UI experience at all.
>> > > > > > 
>> > > > > >     When booting Tizen Common you should have a  test UX
>>(basic Weston) with several user pre-logged on the system.
>> > > > > >     The background show the sea and several islands.
>> > > > > > 
>> > > > > > 
>> > > > > > 
>> > > > > > 
>> > > > > >     My question about Xorg is still not answered, what is
>> > > > > > the UI for Xorg i should expec t to find in the common image
>> > > > > > (is there some sort of default WM that should launch?)
>> > > > > > 
>> > > > > >     We currently do not build a Tizen Common for X but only
>>Wayland 32 and 64 nits for IA and 32 bits for ARM (work in progress)
>> > > > > >     If someone is interested to take the responsibility of
>>building and maintain X Common images, thanks to speak up.
>> > > > > > 
>> > > > > >     Regards
>> > > > > > 
>> > > > > >     Dominig
>> > > > > > 
>> > > > > > 
>> > > > > > 
>> > > > > > 
>> > > > > >     _______________________________________________
>> > > > > > 
>> > > > > >     Dev mailing list
>> > > > > > 
>> > > > > >     Dev at lists.tizen.org <mailto:Dev at lists.tizen.org>
>> > > > > > 
>> > > > > >     https://lists.tizen.org/listinfo/dev
>> > > > > > 
>> > > > > >  
>> > > > > > 
>> > > > > > --
>> > > > > > --------------
>> > > > > >  Roman Kubiak
>> > > > > > --------------
>> > > > > > 
>> > > > > > Intel Corporation NV/SA
>> > > > > > Kings Square, Veldkant 31
>> > > > > > 2550 Kontich
>> > > > > > RPM (Bruxelles) 0415.497.718.
>> > > > > > Citibank, Brussels, account 570/1031255/09
>> > > > > > 
>> > > > > > This e-mail and any attachments may contain confidential
>> > > > > > material for the sole use of the intended recipient(s). Any
>>review or distribution by others is strictly prohibited. If you are not
>>the intended recipient, please contact the sender and delete all copies.
>> > > > > > 
>> > > > > > Intel Corporation NV/SA
>> > > > > > Kings Square, Veldkant 31
>> > > > > > 2550 Kontich
>> > > > > > RPM (Bruxelles) 0415.497.718.
>> > > > > > Citibank, Brussels, account 570/1031255/09
>> > > > > > 
>> > > > > > This e-mail and any attachments may contain confidential
>> > > > > > material for the sole use of the intended recipient(s). Any
>>review or distribution by others is strictly prohibited. If you are not
>>the intended recipient, please contact the sender and delete all copies.
>> > > > > > 
>> > > > > --
>> > > > > --------------
>> > > > >  Roman Kubiak
>> > > > > --------------
>> > > > > 
>> > > > > 
>> > > > > 
>> > > > > _______________________________________________
>> > > > > Dev mailing list
>> > > > > Dev at lists.tizen.org
>> > > > > https://lists.tizen.org/listinfo/dev
>> > > > > 
>> > > _______________________________________________
>> > > Dev mailing list
>> > > Dev at lists.tizen.org
>> > > https://lists.tizen.org/listinfo/dev
>> > 
>
>_______________________________________________
>Dev mailing list
>Dev at lists.tizen.org
>https://lists.tizen.org/listinfo/dev



More information about the Dev mailing list