[Dev] Installing OSP applications

Lukasz Kostyra l.kostyra at samsung.com
Thu May 22 14:26:50 GMT 2014


Hello,

I'm working in a Domain Separation team which develops containers on Tizen.
I'm doing some research connected with OSP applications. I have to work on a
situation connected with migrating applications from host to a container,
however I came across some problems and questions.

First of all, I wanted to find some information about OSP structure. I
managed to find a page related to package structure in Tizen 2.2.1[0]. I'm
not sure how much of this will be used in Tizen 3.0, if this concept will
change or not - is this a good reference when it comes to OSP app structure
on Tizen 3.0?

Moreover, I tried installing an example native application from Tizen SDK by
using "pkgcmd". I created my native application in Tizen SDK for platform
mobile-3.0 (to be more precise, it was just a Calculator example from SDK),
built it, created a certificate and packaged it (everything done according
to help file included with Tizen SDK). As a result I received a
SM9CoGkWBG-2.0.0-armv7l.tpk package. I sent aforementioned package to my
target device and tried to install it by using pkgcmd - "pkgcmd -i -t tpk -p
/root/SM9CoGkWBG-2.0.0-armv7l.tpk". Unfortunately I receive a FATAL_ERROR
message every time I try to install it. I found a thread on Dev mailing list
(started not so long ago, on 13th of May) connected with pkgcmd command, it
pointed to issue TIVI-3182[1]. From this one, I searched Jira and found
another Jira issue TIVI-1944[2], it was closed and linked to a feature
request PTF-181[3]. These bugs are related to IVI profile, but still these
problems look very familiar to what I achieve. Since [3] had no comments, I
went through [2] comments, compared situation described there to dlogutil
logs I got, checked /etc/package-manager/backend and there's nothing inside.
Is this a known issue for mobile profile? Is there a way to make it work? If
it's possible, I need a solution which would be closest to working
application install on mobile with Tizen.

Of course the problem might be wrong command used, however according to [0]
a .tpk package downloaded from Store would be taken directly to something
called "Package Manager" - I guess that this "Package Manager" is pkgmgr and
its commands. Plus, issues I pointed to all use pkgcmd to install their
packages. Please, correct me in this if I'm wrong.

BRs,

==============================

Łukasz Kostyra
Samsung R&D Institute Poland
Samsung Electronics
E-mail: l.kostyra at samsung.com

==============================

Links:

[0]
https://developer.tizen.org/dev-guide/2.2.1/org.tizen.native.appprogramming/
html/basics_tizen_programming/tizen_app_model/application_package_manager.ht
m

[1] https://bugs.tizen.org/jira/browse/TIVI-3182

[2] https://bugs.tizen.org/jira/browse/TIVI-1944

[3] https://bugs.tizen.org/jira/browse/PTF-181






More information about the Dev mailing list