[Dev] how to install and use encfs in tizen rd-pq(reference phone)

이준민 luckyleaf89 at gmail.com
Sun Oct 26 14:13:32 GMT 2014


Hi, all

I solved my problem easily.

my solution is rpm -ivh option.

But, I had another problem...

First, I made private folder and input below command in sdb(rd-pq).

mount -t ecryptfs ~/private ~/private

it is not working with error.

this is error message ...

Unable to get the version number of the kernel
module. Please make sure that you have the eCryptfs
kernel module loaded, you have sysfs mounted, and
the sysfs mount point is in /etc/mtab. This is
necessary so that the mount helper knows which
kernel options are supported.

Make sure that your system is set up to auto-load
your filesystem kernel module on mount.

Enabling passphrase-mode only for now.

Unable to link the KEY_SPEC_USER_KEYRING into the KEY_SPEC_SESSION_KEYRING;
there is something wrong with your kernel keyring. Did you build key
retention support into your kernel?

how to solve this error...please help me..







2014-10-23 22:34 GMT+09:00 Dariusz Michaluk <d.michaluk at samsung.com>:

>
>  So, I tried to install ecryptfs in rd-pq. I had downloaded
>> ecryptfs-utils.tar.gz and unzip in rd-pq.
>> But ecryptfs did not work on sdb shell.
>> If you know how to use ecryptfs in rd-pq, please reply my letter. TT
>>
>>
> You can download ecryptfs-utils rpm from here (should work on rd-pq):
> http://download.tizen.org/snapshots/tizen/common/latest/
> repos/arm-wayland/packages/armv7l/ecryptfs-utils-104-6.2.armv7l.rpm
>
> alternatively, you can build package with gbs (armv7l architecture)
> https://review.tizen.org/gerrit/gitweb?p=platform/
> upstream/ecryptfs-utils.git;a=summary
>
> then install on device: rpm -i ecryptfs-utils-104-6.2.armv7l.rpm
>
> --
> Dariusz Michaluk
> Samsung R&D Institute Poland
> Samsung Electronics
> d.michaluk at samsung.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20141026/fc2daaf0/attachment.html>


More information about the Dev mailing list