[Dev] Problem using 'repo init -m <manifest.xml>'

JF Ding jian-feng.ding at intel.com
Mon Oct 27 14:26:08 GMT 2014


Geoffroy,  

The <remote> line in manifest file inside snapshots are commented out on purpose. It’s a developer using model balance decision. Because we found, for most the cases, the user will not use the manifest from snapshot alone, instead, the user will init the repo working environment  by using these git trees: /scm/manifest, and then copy the manifest from snapshot to local place like .repo/manifests/, to do the snapshot specific localfullbuild. Then the really effect remote URL definition will be from /scm/manifest, and most of time the remote from snapshot/manifest can only make more efforts to let developers to comment out.

From your description, the repo working environment is also setup by using scm/manifest: ( $repo init -u tizen:manifest -b tizen -m ivi.xml). But there’s something different than our BKM(https://source.tizen.org/documentation/articles/creating-tizen-ivi-images-scratch-one-page). In more details of the difference:

1. copy the snapshot/manifest to overwrite “projects.xml” file.
2. just run ‘repo sync’

Please try again by following the BKM doc.

thanks
- jf.ding


On Monday, October 27, 2014 at 7:46 PM, VanCutsem, Geoffroy wrote:

> Hi folks,
>  
> I used to be able to clone all sources for a specific Tizen IVI image doing the following:
> - mkdir tizen-ivi-image && cd tizen-ivi-image
> - repo init -u tizen:scm/manifest -b tizen -m ivi.xml
> - Copy the manifest file from the image I wan to clone (e.g.: http://download.tizen.org/releases/daily/tizen/ivi/latest/builddata/manifest/tizen-ivi_20141024.6_atom.xml) into '.repo/manifests/'
> - repo init -m tizen-ivi_20141024.6_atom.xml
> - repo sync -j 16
>  
> The 'repo init -m' step now leads to the following error messages (I have tried 5 different, recent manifest files):
> fatal: manifest 'tizen-ivi_20141024.6_atom.xml' not available
> fatal: no remote for project apps/core/preloaded/libslp-memo within /home/gvancuts/Tizen-IVI-3.0-M3-Oct2014/.repo/manifests/tizen-ivi_20141024.6_atom.xml
>  
> I have noticed that the "'remote" line in these manifests are commented out: <!--<remote fetch="ssh://review.tizen.org" name="tizen-gerrit" review="https://review.tizen.org/gerrit"/> <default remote="tizen-gerrit"/>-->
> Turning that line into <remote fetch="ssh://review.tizen.org" name="tizen-gerrit" review="https://review.tizen.org/gerrit"/>
> <default remote="tizen-gerrit"/> solves the problem.
>  
> Does anyone know why the "remote" line in the manifest is now commented out?
>  
> Thanks,
> Geoffroy
>  
> -----------------------------------------------
> Intel Corporation NV/SA
> Kings Square, Veldkant 31
> 2550 Kontich
> RPM (Bruxelles) 0415.497.718.  
> Citibank, Brussels, account 570/1031255/09
>  
>  
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org (mailto:Dev at lists.tizen.org)
> https://lists.tizen.org/listinfo/dev
>  
>  


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20141027/317df3c6/attachment-0001.html>


More information about the Dev mailing list