[Dev] FW: Error: No source package found at <Tizen_Project>

Michael Johnson Michael.Johnson at Symphonyteleca.com
Fri Oct 31 12:45:07 GMT 2014


I used this path as suggested http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/, but GBS is still looking for the trunk folder which doesn't exist, so no progress.

again, see the build.log below:

nohup: ignoring input
gbp:debug: ['git', 'rev-parse', '--is-bare-repository']
gbp:debug: ['git', 'rev-parse', '--git-dir']
gbp:debug: ['git', 'rev-parse', '--show-toplevel']
gbs:info: generate repositories ...
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/repomd.xml
gbs:debug: disable HTTP caching
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/builddata/build.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/build.xml
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/build.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/build.xml
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:error: Traceback (most recent call last):
  File "/usr/bin/gbs", line 602, in <module>
    sys.exit(main(sys.argv))
  File "/usr/bin/gbs", line 596, in main
    return module.main(args)
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 330, in main
    cmd += prepare_repos_and_build_conf(args, buildarch, profile)
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 149, in prepare_repos_and_build_conf
    'following repos:\n%s' % (arch, '\n'.join(repos)))
GbsError: <gbs>no available repositories found for arch i586 under the following repos:
http://download.tizen.org/releases/daily/trunk/ivi/latest/

Regards
________________________________
From: JF Ding [jian-feng.ding at intel.com]
Sent: 31 October 2014 11:29 AM
To: Michael Johnson
Cc: Guan, JunchunX; dev at lists.tizen.org; Li, JinjingX; Lv, RuiX; Huang, Hao H
Subject: Re: [Dev] FW: Error: No source package found at <Tizen_Project>

Maybe wrong URL? http://download.tizen.org/releases/daily/trunk/ivi/latest<http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml> is 404.

You can try this:http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/ instead.


thanks
- jf.ding


On Friday, October 31, 2014 at 7:10 PM, Michael Johnson wrote:

Hi all,

I removed the .git folder and went through the set of commands at the link below again, and it is now giving me a different error, so thanks Junchun for that piece of info.  My build.log now looks like this:

nohup: ignoring input
gbp:debug: ['git', 'rev-parse', '--is-bare-repository']
gbp:debug: ['git', 'rev-parse', '--git-dir']
gbp:debug: ['git', 'rev-parse', '--show-toplevel']
gbs:info: generate repositories ...
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/repomd.xml
gbs:debug: disable HTTP caching
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/builddata/build.xml => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/build.xml
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/build.xml => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/build.xml
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')
gbs:error: Traceback (most recent call last):
  File "/usr/bin/gbs", line 602, in <module>
    sys.exit(main(sys.argv))
  File "/usr/bin/gbs", line 596, in main
    return module.main(args)
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 330, in main
    cmd += prepare_repos_and_build_conf(args, buildarch, profile)
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 149, in prepare_repos_and_build_conf
    'following repos:\n%s' % (arch, '\n'.join(repos)))
GbsError: <gbs>no available repositories found for arch i586 under the following repos:
http://download.tizen.org/releases/daily/trunk/ivi/latest/


So now it's looking for the "trunk" folder, which doesn't exist at that path.  In case you're wondering, I'm using 'snapshot' not 'releases', so I'm not sure why gbs is looking in the releases path.  I'm going to try some things, but if anyone has an idea about what's wrong, don't hesitate to let me know.

Thanks


________________________________
From: Guan, JunchunX [junchunx.guan at intel.com<mailto:junchunx.guan at intel.com>]
Sent: 31 October 2014 8:49 AM
To: Michael Johnson; Ding, Jian-feng
Cc: dev at lists.tizen.org<mailto:dev at lists.tizen.org>; Li, JinjingX; Lv, RuiX; Huang, Hao H
Subject: RE: [Dev] FW: Error: No source package found at <Tizen_Project>


Use repo init, repo sync to clone tizen source, not git init.

So your tizen source top directory should not contain .git directory.

If your tizen source top directory is a git tree, gbs treats it a single project and gbs cannot find packaging directory and then build failed.



From: Michael Johnson [mailto:Michael.Johnson at Symphonyteleca.com]
Sent: Friday, October 31, 2014 2:27 PM
To: Ding, Jian-feng
Cc: dev at lists.tizen.org<mailto:dev at lists.tizen.org>; Li, JinjingX; Lv, RuiX; Guan, JunchunX; Huang, Hao H
Subject: RE: [Dev] FW: Error: No source package found at <Tizen_Project>



Hi Rui,

I've already posted the build.log and the .gbs.conf.  Just look at the email history below.  I'm following the instructions on the following page:

    https://source.tizen.org/documentation/developer-guide/all-one-instructions/creating-tizen-ivi-images-based-on-specific-snapshot-one-page


Junchun,

I had to do :

    git init

in order to clone the source, if I remember correctly.  I'll try removing .git and let you know the outcome.

I'll post the commands I used when following the instructions on the above link, when I get in office in a few hours time.

Cheers.

________________________________

From: Michael Johnson
Sent: 30 October 2014 3:49 PM
To: JF Ding
Cc: dev at lists.tizen.org<mailto:dev at lists.tizen.org>; Li, JinjingX; Lv, RuiX; Guan, JunchunX; hao.h.huang at intel.com<mailto:hao.h.huang at intel.com>
Subject: RE: [Dev] FW: Error: No source package found at <Tizen_Project>

Hi all,

The result of running the following command from withing root tizen-project folder is:

    nohup gbs build -A i586 --threads=4 --baselibs >build.log 2>&1 &

still gives the same error.


ls -la gives:

drwxrwxr-x 12 mjohnson mjohnson 4096 Oct 30 15:36 .
drwxrwxr-x  4 mjohnson mjohnson 4096 Oct 30 15:36 ..
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:39 apps
-rw-rw-r--  1 mjohnson mjohnson  440 Oct 30 15:33 build.log
-r--r--r--  1 mjohnson mjohnson  460 Oct 30 12:40 .gbs.conf
drwxrwxr-x  7 mjohnson mjohnson 4096 Oct 29 11:48 .git
drwxrwxr-x  6 mjohnson mjohnson 4096 Oct 30 14:20 platform
drwxrwxr-x  5 mjohnson mjohnson 4096 Oct 30 12:39 pre-built
drwxrwxr-x  4 mjohnson mjohnson 4096 Oct 28 20:48 profile
drwxrwxr-x  7 mjohnson mjohnson 4096 Oct 30 14:14 .repo
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:50 scm
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:50 sdk
drwxrwxr-x  6 mjohnson mjohnson 4096 Oct 28 20:50 test
drwxrwxr-x  5 mjohnson mjohnson 4096 Oct 28 20:50 tools


.gbs.conf is:

[general]
tmpdir=/var/tmp/
profile = profile.tizen3.0_ivi
work_dir=.
fallback_to_native=true

[repo.tizen3.0_x86]
url=${work_dir}/pre-built/toolchain-x86/

[repo.tizen3.0_arm]
url=${work_dir}/pre-built/toolchain-arm/

[repo.tizen3.0_x86_64]
url=${work_dir}/pre-built/toolchain-x86_64/

[profile.tizen3.0_ivi]
repos=repo.tizen3.0_x86,repo.tizen3.0_arm,repo.tizen3.0_x86_64
buildconf=${work_dir}/scm/meta/build-config/build.conf
exclude_packages=libtool,gettext


Here's the build.log:

nohup: ignoring input
info: the following packages have been excluded build from gbs config:
   libtool
   gettext
info: generate repositories ...
info: start building packages from: /home/mjohnson/workspace/tizen/cloneTizen/bin/tizen-project (git)
2014-10-30 15:33 +0000
gbs 0.22.3
error: No source package found at /home/mjohnson/workspace/tizen/cloneTizen/bin/tizen-project
error: <gbs>some packages failed to be built
[1]+  Exit 1                  nohup gbs build -A i586 --threads=4 --baselibs > build.log 2>&1


Hope this info helps to track down my problem.

Cheers

________________________________

From: JF Ding [jian-feng.ding at intel.com<mailto:jian-feng.ding at intel.com>]
Sent: 30 October 2014 2:03 PM
To: Michael Johnson
Cc: dev at lists.tizen.org<mailto:dev at lists.tizen.org>; Li, JinjingX; Lv, RuiX; Guan, JunchunX; hao.h.huang at intel.com<mailto:hao.h.huang at intel.com>
Subject: Re: [Dev] FW: Error: No source package found at <Tizen_Project>

Michael,



By following the doc Geoffrey mentioned in another mail, have you tried again and can it work now?





thanks

- jf.ding



On Thursday, October 30, 2014 at 9:50 PM, Michael Johnson wrote:

Hi,

The version is gbs 0.22.3, and I was trying to build the whole source.

Thanks for your help!

________________________________

From: JF Ding [jian-feng.ding at intel.com<mailto:jian-feng.ding at intel.com>]
Sent: 30 October 2014 1:45 PM
To: Michael Johnson
Cc: dev at lists.tizen.org<mailto:dev at lists.tizen.org>
Subject: Re: [Dev] FW: Error: No source package found at <Tizen_Project>

Michael,



Would you provide the version of gbs, and the package name that caused the error message? We will double confirm the status of DEVT-148.



thanks

- jf.ding



On Thursday, October 30, 2014 at 7:41 PM, Michael Johnson wrote:



Hi all,

I'm having problems trying to build the Tizen source.  Cloning the source went fine, but I'm now going through https://source.tizen.org/documentation/developer-guide/getting-started-guide/building-packages-locally-gbs, and getting the above error when using the command:

    gbs -d build -A i586 --threads=4 --clean-once --exclude=gcc,cmake,filesystem,aul,libmm-sound,libtool

I'm using the .gbs.conf below that exists after cloning the source.

[general]
tmpdir=/var/tmp/
profile = profile.tizen3.0_ivi
work_dir=.
fallback_to_native=true

[repo.tizen3.0_x86]
url=${work_dir}/pre-built/toolchain-x86/

[repo.tizen3.0_x86_64]
url=${work_dir}/pre-built/toolchain-x86_64/

[profile.tizen3.0_ivi]
repos=repo.tizen3.0_x86,repo.tizen3.0_x86_64
buildconf=${work_dir}/scm/meta/build-config/build.conf
exclude_packages=libtool,gettext

Bug DEVT-148 says "gbs build fails with an error if packaging/ is a symlink", and it says that it is fixed, so I'm wondering if there is anyone having this issue, or is there a different way of building the source that is not mentioned in the documentation?

Any guidance is appreciated.

Thanks
Mike


MICHAEL JOHNSON
Embedded Software Engineer

Symphony Teleca
Sunley House, 46 Jewry Street, Winchester, Hampshire, SO23 8RY
Phone: +441962868866, Fax: +441962868867
Michael.Johnson at Symphonyteleca.com<mailto:Michael.Johnson at Symphonyteleca.com>
www.symphonyteleca.com<http://www.symphonyteleca.com>

Teleca Limited, a company registered in England & Wales, registration number 2773878, registered office at Sunley House, 46 Jewry Street, Winchester, Hampshire SO23 8RY. VAT registration number GB 674 6583 90

Follow what's going on at Symphony Teleca's blog on www.symphonyteleca.com/blog<http://www.symphonyteleca.com/blog>. Please consider the environment before you print.

Notice to recipient: This e-mail (including any attachments) is meant for the intended recipient only, may contain confidential and proprietary information, and is protected by law. If you received this e-mail in error, please immediately notify the sender of the error by return e-mail, delete this communication and any attachments, and shred any printouts. Unauthorized review, use, dissemination, distribution, copying or taking of any action based on this communication is strictly prohibited.

_______________________________________________

Dev mailing list

Dev at lists.tizen.org<mailto:Dev at lists.tizen.org>

https://lists.tizen.org/listinfo/dev





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20141031/54dfdb05/attachment-0001.html>


More information about the Dev mailing list