[Dev] [Help] Failed to build Tizen-3.0-mobile from source

Alejandro Gallardo alexgalu at live.com
Tue Apr 21 06:54:07 GMT 2015


Hi Li Jinjing,

Thanks for your reply. I managed to make some progress with the compilation, this time achieving 471/850 packages, but again it got stuck in gummiboot, system-plugin-emulator and c-ares and the process finished abruptly.

I tried to follow your advice:

- First of all I tried updated the manifest you were referring to at https://review.tizen.org/gerrit/#/c/36736/ 
    Building failed.
- Then I made sure the build config was correct following checking the build-config for build-atom-x11.conf available at https://review.tizen.org/gerrit/#/c/35108/
    Building failed.
- Then I added the .gbs.conf to compile gummiboot and system-plugin-emulator only, pointing the remote repository to the snapshot repo you mentioned.
    Building failed.
- Lastly, I've started all over from scratch but this time downloading the packages from a snapshot (section 2.2.2 in the 'Cloning the Tizen Source' tutorial) rather than checking out all the project sources
    Building failed.

The logs for these packages are pretty much the same as before, and can be found at: https://gist.github.com/anonymous/d78a18d5fb168d76fe01

Am I doing something wrong? What should I do to be able to compile the mobile profile of Tizen 3.0?

Thank you so much.
Alex
From: jinjingx.li at intel.com
To: alexgalu at live.com
CC: dev at lists.tizen.org; chunhua1.liu at samsung.com; jongwoo.chae at samsung.com; jian-feng.ding at intel.com
Subject: RE: [Dev] [Help] Failed to build Tizen-3.0-mobile from source
Date: Wed, 15 Apr 2015 11:08:43 +0000









Hi  Alex
 
I just do “gbs build –A i586” two packages gummiboot and system-plugin-emulator on accepted/tizen_mobile branch with remote repo

http://download.tizen.org/snapshots/tizen/mobile/tizen-mobile_20150415.1/repos/atom-wayland/
 
They could build successfully on my side.
 
The issue you met  maybe because of outdated manifest from
scm/manifest
project on review.tizen.org.
 
Can maintainers help to update the mobile(common) manifest?
You could refer to the patch as
https://review.tizen.org/gerrit/#/c/36736/ .
 
BTW, please check the build-conf in
scm/meta/build-confg
project on review.tizen.org, which could refer to the patch :
https://review.tizen.org/gerrit/#/c/35108/

 
 
 
 
Thanks
Li Jinjing


From: Dev [mailto:dev-bounces at lists.tizen.org]
On Behalf Of Alejandro Gallardo

Sent: Wednesday, April 15, 2015 5:48 PM

To: Ding, Jian-feng

Cc: dev at lists.tizen.org

Subject: Re: [Dev] [Help] Failed to build Tizen-3.0-mobile from source


 

Thanks for your reply JF :)



Yep, I noticed some of the errors were due to the lack of free memory, so I've tried two different approaches:


1. Reducing the number of threads so that all memory is available to that specific thread.

2. Doubling the available ram up to 8 GB while maintaining the 4 threads.



So far I've managed to reduce the number of packages not compiling to just 3 for now (gummiboot, system-plugin-emulator & llvm) but I'm stuck there with some missing files and errors in the Makefile.rules of llvm.



Is there any machine configuration you use or recommend to build the system from scratch?



Thank you!








Date: Wed, 15 Apr 2015 17:18:50 +0800

From: jian-feng.ding at intel.com

To: alexgalu at live.com

CC: dev at lists.tizen.org

Subject: Re: [Dev] [Help] Failed to build Tizen-3.0-mobile from source

AFAIK, because there’s some huge packages in Tizen building, e.g. crosswalk, normally 4GB machine is not enough. In such case, there will be some strange errors.




 


-- 


Thanks


- jf.ding


 


On Wednesday, April 15, 2015 at 5:14 PM, Alejandro Gallardo wrote:




Hi everyone,



I'm beginning with Tizen trying to build Tizen 3.0-mobile from source following the official guide at

https://source.tizen.org/documentation/developer-guide/getting-started-guide/cloning-tizen-source and

https://source.tizen.org/documentation/developer-guide/getting-started-guide/building-packages-locally-gbs . My environment is an Ubuntu 12.04 64 bit using a 4-core Intel i7 processor with 4 GB of RAM and apparently with all the required development tools
 installed.



Once the sources have been checked out I tried to compile them using the suggested command:

gbs build -A i586 --threads=4 --clean-once --exclude=gcc,cmake,filesystem,aul,libmm-sound,libtool 



Using the standard gbs configuration file at the sources directory:

.gbs.conf



[general]

tmpdir=/var/tmp/

profile = profile.tizen3.0_mobile

work_dir=.

fallback_to_native=true



[repo.tizen3.0_x86]

url=${work_dir}/pre-built/toolchain-x86/



[repo.tizen3.0_arm]

url=${work_dir}/pre-built/toolchain-arm/



[repo.tizen3.0_arm64]

url=${work_dir}/pre-built/toolchain-arm64/



[profile.tizen3.0_mobile]

repos=repo.tizen3.0_x86,repo.tizen3.0_arm,repo.tizen3.0_arm64

buildconf=${work_dir}/scm/meta/build-config/build.conf

exclude_packages=libtool,gettext,texinfo







However, after a while the build finishes with the following output:



=== the following packages failed to build due to rpmbuild issue (8) ===

boost: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/boost-1.57.0-0/log.txt

gummiboot: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/gummiboot-43-1/log.txt

system-plugin-emulator: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/system-plugin-emulator-0.0.16-1/log.txt

c-ares: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/c-ares-1.10.0-0/log.txt

v8: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/v8-3.30.30-0/log.txt

glib2: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/glib2-2.43.1-0/log.txt

llvm: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/llvm-3.5.0-0/log.txt

ppl: /home/alex/GBS-ROOT/local/repos/tizen3.0_mobile/i586/logs/fail/ppl-0.11.2-0/log.txt

=== Total succeeded built packages: (135) ===





Looking at the logs they fail due to different reasons: files that don't exist, incorrect CFLAGS used, wrong makefile "recipes". The log errors can be found at

https://gist.github.com/anonymous/6c7ddde3dff48625b0fd/raw/gistfile1.txt





Could any of you guess how to fix the problems and continue building Tizen from source?



I know most efforts by the companies and volunteers involved in the project are dedicated to evolve the platform but it would be highly appreciated if someone takes a look at the documentation and revise it carefully, because it's really important for us developers
 and other companies interested in Tizen to engage. If documentation is not clear and everything fails after several attempts, then the interest may fade away.



Thank you very much in advance.

Best regards,

Alex




_______________________________________________


Dev mailing list


Dev at lists.tizen.org


https://lists.tizen.org/listinfo/dev





 



 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20150421/b48e03a4/attachment-0001.html>


More information about the Dev mailing list