[Dev] Tizen on Raspberry PI 2 using Yocto

Leon Anavi leon.anavi at konsulko.com
Thu Apr 30 08:38:47 GMT 2015


Hi Mauro,

On 21.04.2015 13:24, Mauro Carvalho Chehab wrote:
> Em Tue, 21 Apr 2015 03:20:13 +0300
> Leon Anavi <leon.anavi at konsulko.com> escreveu:
>
>> Hi Mauro,
>>
>> Well done. Thank you for sharing this very useful tutorial!
> Anytime!
>
>> I have Raspberry Pi 2 and tonight I tried the tutorial before going to
>> bed. Following the described steps I managed to build an image but it
>> fails to boot due to a kernel panic. Please have a look at my logs:
>> https://gist.github.com/leon-anavi/386e81df83b0b5b1d62d
>>
>> I got the same result using two different microSD cards. I had a long
>> day so may be I am missing something simple. Have you experienced
>> something similar and could you please provide me hints how to solve it?
> Here, everything is booting smoothly, but I didn't try to use a serial
> console or to run it in kdbg mode. Perhaps it reached some race condition
> at Kernel level. Yet, from this message:
> 	PANIC: Attempted to kill init! exitcode=0x00007f00
>
> I suspect that systemd died for some unknown reason.
>
> That's said, before adding the init to use systemd at cmdline.txt,
> I noticed that, when exiting from init via shutdown, a Kernel panic
> was happening.
>
> So, I suspect that there's a bug at the Raspberry PI 2 Kernel that
> causes a panic at shutdown, depending on the exit condition (as I
> didn't notice such bug when systemd is running on my system).
>

Yesterday I built Tizen:Common image for Raspberry Pi 2 from scratch and 
it booted fine. Several days ago I tried it a pre-compiled image from 
http://files.s-osg.org/tizen-on-rpi2/ It also booted successfully.

Thanks,
Leon

>> Btw some information that might be useful for other developers. The
>> procedure to enable serial debugging on Raspberry Pi 2 is the same as on
>> the old model of the board. File cmdline.txt from the boot partition
>> should be modified and instructions for serial console should be added
>> as in the example below:
>>
>> dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
>> console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4
>> init=/lib/systemd/systemd rw rootwait debug
>>
>> USB to UART cable with serial output 3.3V voltage levels such as Olimex
>> USB-Serial-Cable-F should be connected to GPIO of RPI2 as follows:
>> * The RX line of the cable (GREEN wire if you are using Olimex
>> USB-Serial-Cable-F) should go to pin 8 (TX line) of HummingBoard,
>> * The TX line of the cable (RED wire if you are using Olimex
>> USB-Serial-Cable-F) should go to pin 10 (RX line),
>> * The BLUE wire if you are using Olimex USB-Serial-Cable-F should go to
>> pin 6 (GND).
>>
>> Pay attention that the colours of the cable may vary depending on the
>> vendor. If you have USB console cable from Adafruit please have a look
>> at:
>> https://learn.adafruit.com/adafruits-raspberry-pi-lesson-5-using-a-console-cable/connect-the-lead
>>
>> Thanks,
>> Leon
> Thanks!
> Mauro

-- 
Leon Anavi
Software Engineer
Mob : +359 88 527 7901
konsulko.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20150430/41afdd8e/attachment-0001.html>


More information about the Dev mailing list