[Dev] tizen on yocto build error

RayBloodworth k870818319 at outlook.com
Mon Dec 21 08:52:30 GMT 2015


Hi, Leon

    I'm trying to combine freescale yocto bsp (3.14.18) with tizen-distro layer.
    Packages are all compiled successfully. But error occured when do rootfs:
  package xxxx is intended for a different operating system

    I think there must be any configuration is wrong in the config files.
    Here are bblayers.conf and local.conf :
=============================================================
bblayers.conf
LCONF_VERSION = "5"

BBPATH = "${TOPDIR}"
BSPDIR := "${@os.path.abspath(os.path.dirname(d.getVar('FILE', True)) + '/../..')}"

BBFILES ?= ""
BBLAYERS = " \
  ${BSPDIR}/sources/poky/meta \
  ${BSPDIR}/sources/poky/meta-yocto \
  \
  ${BSPDIR}/sources/meta-openembedded/meta-oe \
  ${BSPDIR}/sources/meta-openembedded/meta-multimedia \
  \
  ${BSPDIR}/sources/meta-fsl-arm \
  ${BSPDIR}/sources/meta-fsl-arm-extra \
  ${BSPDIR}/sources/meta-fsl-demos \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-adaptation/meta \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-adaptation/meta-oe \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-common-base \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-common-share \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-common-devtools \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-common-demo \
  ${BSPDIR}/sources/meta-tizen/meta-tizen-ivi \
"
##Freescale Yocto Release layer
BBLAYERS += " ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-fsl-arm "
BBLAYERS += " ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-fsl-demos "
BBLAYERS += " ${BSPDIR}/sources/meta-browser "
BBLAYERS += " ${BSPDIR}/sources/meta-openembedded/meta-gnome "
BBLAYERS += " ${BSPDIR}/sources/meta-openembedded/meta-networking "
BBLAYERS += " ${BSPDIR}/sources/meta-openembedded/meta-python "
BBLAYERS += " ${BSPDIR}/sources/meta-openembedded/meta-ruby "
BBLAYERS += " ${BSPDIR}/sources/meta-openembedded/meta-filesystems "
BBLAYERS += " ${BSPDIR}/sources/meta-qt5 "
BBLAYERS += " ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-fsl-qt5 "
BBLAYERS += " ${BSPDIR}/sources/meta-fsl-bsp-release/imx/meta-fsl-bluez "
=============================================================
local.conf
MACHINE ??= 'imx6qsabresd'
DISTRO ?= 'tizen-ivi'
PACKAGE_CLASSES ?= "package_rpm"
EXTRA_IMAGE_FEATURES = "debug-tweaks"
USER_CLASSES ?= "buildstats image-mklibs image-prelink"
PATCHRESOLVE = "noop"
BB_DISKMON_DIRS = "\
    STOPTASKS,${TMPDIR},1G,100K \
    STOPTASKS,${DL_DIR},1G,100K \
    STOPTASKS,${SSTATE_DIR},1G,100K \
    ABORT,${TMPDIR},100M,1K \
    ABORT,${DL_DIR},100M,1K \
    ABORT,${SSTATE_DIR},100M,1K" 
PACKAGECONFIG_append_pn-qemu-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
ASSUME_PROVIDED += "libsdl-native"
CONF_VERSION = "1"

BB_NUMBER_THREADS = '4'
PARALLEL_MAKE = '-j 4'

DL_DIR ?= "${BSPDIR}/downloads/"
ACCEPT_FSL_EULA = "1"
PREFERRED_PROVIDER_virtual/mesa = ""

DISTRO_FEATURES_remove = "x11 directfb "

LICENSE_FLAGS_WHITELIST = "commercial"

IMAGE_INSTALL_append = " vim "
IMAGE_INSTALL_remove = " tlm "
PREFERRED_VERSION_rpm = "4.11.0.1"
PREFERRED_VERSION_rpm-native = "4.11.0.1"
RPMROOTFSDEPENDS_remove = "rpmresolve-native:do_populate_sysroot"

DISTRO_FEATURES_append = " systemd"
VIRTUAL-RUNTIME_init_manager = "systemd"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
VIRTUAL-RUNTIME_initscripts = ""
=============================================================

Could you help me with this issue?

BR,
Ray

 		 	   		  


More information about the Dev mailing list