[Dev] Changes in alarm interface.
jiwoong.im at samsung.com
Tue Feb 3 10:31:18 GMT 2015
alarm interface is renamed at 2.3 release while 2.2 still has a legacy interface (please refer to https://developer.tizen.org/dev-guide/2.3.0/org.tizen.mobile.native.apireference/group__CAPI__ALARM__MODULE.html).
I’m trying to change alarm interface’s parameter in capi-appfw-application packages since I didn't find any modules that uses these interface directly
Are there any modules that I didn't recognize using those legacy alarm interface?
Actually the only difference of 2.2 and 2.3 is just parameter keeping its interface name.
The reason why this change was done in 2.3 is to make the naming convention of Web device API and native interface consistency.
(Web device API uses the naming convention, ApplicationControl while native interface uses another name, ApplicationService)
The parameter service_h will be changed to app_control_h and interface name is kept as same with 2.2 internal interface.
int alarm_schedule_after_delay (servicel_h service, int delay, int period, int *alarm_id)
int alarm_schedule_at_date (service_h service, struct tm *date, int period, int *alarm_id)
int alarm_schedule_with_recurrence_week_flag (service_h service, struct tm *date, int week_flag, int *alarm_id)
int alarm_get_service (int alarm_id, servicel_h *service)
#define SERVICE_DATA_ALARM_ID “http://tizen.org/appcontrol/data/alarm_id”
int alarm_schedule_after_delay (app_control_h app_control, int delay, int period, int *alarm_id)
int alarm_schedule_at_date (app_control_h app_control, struct tm *date, int period, int *alarm_id)
int alarm_schedule_with_recurrence_week_flag (app_control_h app_control, struct tm *date, int week_flag, int *alarm_id)
int alarm_get_app_control (int alarm_id, app_control_h *app_control)
#define APP_CONTROL_DATA_ALARM_ID "http://tizen.org/appcontrol/data/alarm_id"
Any other good opinion for this way?
JIRA ticket : TC-2411
Best Regards, Jiwoong Im.
More information about the Dev