[Dev] Keyboard issues with Weston and AGL application suite

Leon Anavi leon.anavi at konsulko.com
Wed Oct 14 10:31:25 GMT 2015


Hi Derek, All,

Derek, I am experiencing similar issues with weston-keyboard as in your 
article "When is a Keyboard Not a Keyboard?" which has been published at 
Samsung OSG blog.

Could you please provide me help how to get Weston 1.6 working with the 
virtual weston-keyboard in the HTML5 apps from the AGL app suite when 
hardware keyboard is not present?

In my case Weston keeps crashing when I type in HTML5 input fields from 
the AGL apps through the virtual weston-keyboard if no hardware keyboard 
is attached. I am working on a Tizen image that contains Wayland and 
Weston 1.6, Crosswalk 11.40.277.0 and libinput 0.6.0. Please have a look 
at my test cases for more details:

* Test case 1, weston.ini:

[input-method]
path=/usr/libexec/weston-keyboard

[keyboard]
keymap_layout=wkb

Results:

1.1. No hardware keyboard: FAIL
Weston crashes when the user tries to launch Browser from the Homescreen 
app:

[00:00:32.676] caught signal: 11

1.2. With hardware keyboard: FAIL

Weston detects the hardware keyboard:

[00:00:07.480] input device 'SEM USB Keyboard', /dev/input/event0 is a 
keyboard
[00:00:07.481] input device 'SEM USB Keyboard', /dev/input/event1 is a 
keyboard

Weston crashes when the user tries to launch Browser from the Homescreen 
app:

[00:00:49.925] caught signal: 11


* Test case 2, weston.ini:

[input-method]
path=

[keyboard]
keymap_layout=wkb

Results:
2.1. No hardware keyboard: OK with remark - there is no virtual keyboard 
(as expected) so there is no way to type.

2.2. With hardware keyboard: FAIL

Weston detects the hardware keyboard:

[00:00:06.586] input device 'SEM USB Keyboard', /dev/input/event0 is a 
keyboard
[00:00:06.587] input device 'SEM USB Keyboard', /dev/input/event1 is a 
keyboard

Weston fails as soon as the user starts to type in HTML5 input field for 
URL at the Browser app through the hardware keyboard:

[00:00:48.006] caught signal: 11

* Test case 3, weston.ini:

[input-method]
path=/usr/libexec/weston-keyboard

[keyboard]
keymap_layout=us

Results:
3.1. No hardware keyboard: FAIL

Weston crashes when the user tries to launch Browser from the Homescreen 
app:

[00:00:28.391] caught signal: 11

3.2. With hardware keyboard: OK

Weston detects the hardware keyboard and both the hardware and virtual 
weston-keyboard work fine:

[00:00:06.767] input device 'SEM USB Keyboard', /dev/input/event0 is a 
keyboard
[00:00:06.771] input device 'SEM USB Keyboard', /dev/input/event1 is a 
keyboard

I want to get weston-keyboard working fine in Weston even if there is no 
hardware keyboard.

Thanks,
Leon

-- 
Leon Anavi
Software Engineer
konsulko.com



More information about the Dev mailing list