[Dev] Fwd: App installation on 2.3.0

유덕인 di.lyu at samsung.com
Tue Feb 9 23:21:39 GMT 2016


Hi Joshua,

The device ID is only valid for Samsung Certification with Samsung Device such as Gear S2.
Have you tried with Tizen Certificate? The certificate registration method is descrbed in https://developer.tizen.org/development/tools/common-tools/certificate-registration
If you use 2.3 Tizen Source for your platform, we need to use Tizen 2.3 SDK.
Regards,
Dugin Lyu

------- Original Message -------
Sender : Joshua Varghese<joshua.varghese at soctronics.com>
Date : 2016-02-08 14:49 (GMT+09:00)
Title : [Dev] App installation on 2.3.0

Hi all,

We are trying to install web-apps (Tizen 2.3) on our platform. However, when we try to install the apps without any certificate, we get a "segmentation fault (Core dumped)" error. So, we tried installing apps with a certificate generated for Samsung Gear S2. Now, we get an error which says "Invalid Certificate". We have a few questions regarding this.

1. Is there anyway to bypass the security certificate check while installation?
2. How does the emulator work without a valid certificate or a dummy certificate and can we use the same process to install it on our board?
3. How do we get the device ID with which we can generate a valid certificate?

P.S: we have SMACK enabled on our board

Thanks & Regards,
Atchyut Sreekar Durga
_______________________________________________
Dev mailing list
Dev at lists.tizen.org
https://lists.tizen.org/listinfo/dev


More information about the Dev mailing list