[Dev] Audit - doesn't work on arm architecture

Tomasz Swierczek t.swierczek at samsung.com
Wed Feb 24 11:58:10 GMT 2016


Anyone who may know why this happens or how to make audit work properly in regular Tizen.org images? 

 

It is a very handy feature that we happen to be using in our privilege-denial-logging tool nicelad (connected with Cynara).

 

BRs,

 

cid:44YDXKW4QKNM at namo.co.kr

 

Tomasz Świerczek

Samsung R&D Institute Poland

Samsung Electronics

Office +48 22 377 95 59

Cell +48 503 135 021

t.swierczek at samsung.com

 

From: Dev [mailto:dev-bounces at lists.tizen.org] On Behalf Of Oskar Świtalski
Sent: Monday, February 15, 2016 8:43 AM
To: dev at lists.tizen.org
Subject: [Dev] Audit - doesn't work on arm architecture

 

Hi All,
I tested audting on many devices and profiles (Tizen 3.0/debian) on arm architecture and everywhere failed to add new rule:

# auditctl -w /etc/passwd
Error sending add rule data request (Invalid argument)

on non arm arch it passes and rule is successfully added.

I founded that EINVAL is returned from sendto to kernel in audit_send() from netlink.c

Best regards,

Oskar Switalski
Samsung R&D Institute Poland
Samsung Electronics
o.switalski at samsung.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/dev/attachments/20160224/1d2eaf1d/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 2228 bytes
Desc: not available
URL: <http://lists.tizen.org/pipermail/dev/attachments/20160224/1d2eaf1d/attachment-0001.png>


More information about the Dev mailing list