[Dev] 'tizen3.0 common' build errors [-A x86_64]

Mats Wichmann mats at osg.samsung.com
Wed Jun 29 13:26:54 GMT 2016


On 06/29/2016 06:02 AM, Mahesh Vithal Talewad wrote:
> Hi All,
> 
>  
> 
> I am newbie to tizen. We have cloned 'tizen 3.0 common' and started to build. We are building for '-A x86_64'.
> 
> However we are facing following build errors [dependency errors and rpmbuild errors]. Kindly checkout the attached logs.
> 
>  
> 
> We have used following remote repo url in .gbs.conif
>
>  url=http://download.tizen.org/snapshots/tizen/common/tizen-common_20160624.2/repos/x86_64-wayland/packages/
> 
>  
> 
> to fix these dependency errors , do i need to change this remote repo url in .gbs.conf, if soo pls let us know the remote repo url.
> 
> kindly help us to fix these errors [dependency error and rpmbuild issues]:

it does look like packages that might provide dependencies flagged as missing are absent from the snapshot you point to.  this doesn't seem so different from what Sayan (your colleague?) posted the other day.

snapshots, by their nature, aren't very stable (note only a couple of weeks worth are around, so if you point to one of these your .gbs.conf will need updating now and then). 

it seems these directories (I looked in download.tizen.org/prerelease as well) represent partial builds.  a milestone build would be more complete, but the last of those is pretty old.

hopefully someone has the right formula here....





More information about the Dev mailing list