[Dev] TIzen SCM Tool Release

Mats Wichmann mats at osg.samsung.com
Tue May 3 16:46:22 GMT 2016


On 05/03/2016 09:29 AM, Chanho Park wrote:
> Hi,
> 
> On Mon, Apr 18, 2016 at 8:45 PM, 박순규 <sk7.park at samsung.com <mailto:sk7.park at samsung.com>> wrote:
> 
>      
> 
>     Hi all,
> 
>      
> 
>     We release Tizen SCM Tools
> 
>     - First release in 2016
> 
>     - http://download.tizen.org/tools/latest-release/ (http://download.tizen.org/tools/archive/16.01/)
> 
>      
> 
>     Major changes:
> 
>     * New distribution support: CentOS 7, Debian 8, Fedora 21, Fedora 22, openSUSE 13.2
> 
>     * Add new options
> 
>     * Bug fixes
> 
>      
> 
>     For more details, please refer to the RELEASE_NOTES .
> 
> 
> 
> When I tried to install gbs tool on my ubuntu 16.04 machine, I couldn't install it.
> 
> I also looked below log when I tried to update the repository. Could you tell me what is the GPG key of your server?
> 
> W: The repository 'http://download.tizen.org/tools/latest-release/Ubuntu_15.04  Release' is not signed.
> N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
> N: See apt-secure(8) manpage for repository creation and user configuration details.
> 
> Anyway, it seems that you'll need to rebuild all tools to support ubuntu 16.04.
> Is there any plans or schedule to support ubuntu 16.04 version?
> 
> sudo apt-get install gbs mic
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  gbs : Depends: depanneur (>= 0.15) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.

I've had the same issues.  In addition there's one more mismatch:

The following packages have unmet dependencies:
 build : Depends: libcrypt-ssleay-perl (= 0.64-tizen20130308) but 0.73.04-1build1 is installed.

16.04 is brand new but it seems emphasis should really be put on long-term support distros - Fedora 20/21 are already obsolete / end-of-lifed, and F22 is only a month or so away from it. opensuse 12.x is also gone. Ubuntu 15.04 is also end-of-lifed (Ubuntu has now gone to 9 months on non-LTS releases). Building for those would seem less important than something like 16.04 which will at least be getting security updates for five years now it's out. (just my opinion, of course)



More information about the Dev mailing list