[Dev] Porting Tizen to Samsung Artik

Paweł Wieczorek p.wieczorek2 at samsung.com
Thu May 12 13:26:01 GMT 2016


Hi Aleksander, Jaehoon, Chanwoo, Raju,

I would like to let you know that Tizen 3.0 snapshots for Tizen:Common 
profile are available for Artik 10 and Artik 5.

Currently, four Artik images are built:

* common-boot-armv7l-artik5,
* common-boot-armv7l-artik10,
* common-headless-3parts-armv7l-artik (generic: for both Artik 5 and 10),
* common-wayland-3parts-armv7l-artik (generic: for both Artik 5 and 10).

Best regards,
Paweł Wieczorek

On 29/12/15 03:16, Chanwoo Choi wrote:
> Hi Aleksander,
>
> On 2015년 12월 29일 11:12, Jaehoon Chung wrote:
>> CC'd Chanwoo.
>>
>> On 12/26/2015 10:23 PM, Aleksander Kurczyk wrote:
>>> Hello!
>>>
>>> I am one of the Samsung Artik 10 alpha testers. I am trying to get Tizen working on my Artik 10 rev. 0.22 (the last alpha one). I have found the manual on how to get it working on Tizen's wiki. It's available here: https://wiki.tizen.org/wiki/ARTIK_10_for_Tizen_3.0. Using those instructions and attached files I have managed to compile the kernel and during boot got the error message "Bad ARM magic".
>>>
>>> I had to fix the attached DTS file. In one line (109) there was missing a semicolon while in another one (541) there was an undeclared before constant "CLK_MOUT_EPLL". I have changed it to "CLK_MAU_EPLL" because those constant is used in the next line. Correct? I also had to change the size od modules.img image (to 32MiB) because the modules couldn't fit there.
>>>
>>> Can someone who also got the Samsung Artik 10 alpha board tell me what am I doing wrong? Has it something to do with the DTS file or maybe I am using wrong toolchain?
> You are right. The exynos5422-artik10.dts has the problem as you mentioned.
> So, I fixed them. I added the semicolon in line 109 and push the patch[1]
> to add the 'CLK_MOU_EPLL' clock as following:
> [1] https://review.tizen.org/gerrit/gitweb?p=platform/kernel/linux-exynos.git;a=commit;h=fb5b25f81caa3e00766b841da4f18c05336ee59f
>
> After you pull the latest linux-exynos.git, the issue might be not happened.
>
> Best Regards,
> Chanwoo Choi
>
> _______________________________________________
> Dev mailing list
> Dev at lists.tizen.org
> https://lists.tizen.org/listinfo/dev



More information about the Dev mailing list