[Dev] Problem with Tizen software keyboard

Dmitry Dmitriev dmitriev.dd at hotmail.com
Tue Jun 4 11:23:56 UTC 2019


Hello!

We porting Tizen 4.0 "mobile" platform to Pico-Pi IMX8M devboard. We wrote several adaptation packages and now Tizen can start on this board with UI (unfortunately without graphics hw acceleration - we try to use Mesa still without success but this is another question) but  we have a big issue with software keyboard - it doesn't work. In "dlogutil" there are messages from keyboard when I tap on some input widget:

D/IMMODULE(  943): wayland_imcontext.c: wayland_im_context_filter_event(3056) > [Mouse-up event] ctx : 0xaaaaf740cd00
E/IMMODULE(  943): wayland_imcontext.c: wayland_im_context_filter_event(3061) > Can't show IME because there is no focus. ctx : 0xaaaaf740cd00

We tried several Tizen 4.0 milestone releases: tizen-4.0-unified_20190306.1, tizen-4.0-unified_20180728.1 (both armv7l and aarch64 versions). Also we tried some Tizen 5 and new Tizen 5.5 releases (for armv7l). And each release have this issue with keyboard on our board but in emulator from Tizen Studio everything works as expected.

What can lead to this problem? Maybe we forgot some flag and just need to set it but where?

Thank you,
Dmitry Dmitriev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.tizen.org/pipermail/dev/attachments/20190604/f9fcfa1a/attachment.html>


More information about the Dev mailing list