<HTML><HEAD><TITLE>Samsung Enterprise Portal mySingle</TITLE>
<META content="text/html; charset=utf-8" http-equiv=Content-Type>
<STYLE id=mysingle_style type=text/css>P {
        MARGIN-TOP: 5px; FONT-FAMILY: Arial, arial; MARGIN-BOTTOM: 5px; FONT-SIZE: 9pt
}
TD {
        MARGIN-TOP: 5px; FONT-FAMILY: Arial, arial; MARGIN-BOTTOM: 5px; FONT-SIZE: 9pt
}
LI {
        MARGIN-TOP: 5px; FONT-FAMILY: Arial, arial; MARGIN-BOTTOM: 5px; FONT-SIZE: 9pt
}
BODY {
        LINE-HEIGHT: 1.4; MARGIN: 10px; FONT-FAMILY: Arial, arial; FONT-SIZE: 9pt
}
</STYLE>

<META name=GENERATOR content=ActiveSquare></HEAD>
<BODY>
<P>Dear all,</P>
<P> </P>
<P>I faced same problem against osp-security-service.</P>
<P>To avoid the build error, I added following into %install section.</P>
<P> </P>
<P>%global __os_install_post  \<BR>    /usr/lib/rpm/brp-compress \<BR>    /usr/lib/rpm/brp-tizen  \<BR>    %{!?disable_docs_package:/usr/lib/rpm/tizen/find-docs.sh %{buildroot}} \<BR>%{nil}<BR></P>
<P>Maybe, there is a problem in rpm macros of 'rpm' package.</P>
<P>'brp-strip-static-archive' is removed by the spec file of 'rpm' package,  thus it have to removed on postscript.</P>
<P> </P>
<P>[   90s] /var/tmp/rpm-tmp.XpS4yV: line 55: /usr/lib/rpm/brp-strip-static-archive: No such file or directory</P>
<P> </P>
<P> </P>
<P>Thanks and regards,</P>
<P>Seungmin Yu</P>
<P> </P>
<P> </P>
<P>------- <B>Original Message</B> -------</P>
<P><B>Sender</B> : Krzysztof Opasiak<k.opasiak@samsung.com> Junior Software Engineer/SRPOL-Kernel & System Framework (SSD)/삼성전자</P>
<P><B>Date</B> : 2013-10-04 01:41 (GMT+09:00)</P>
<P><B>Title</B> : [Dev] Build problems with GBS</P>
<P> </P>Dear all,<BR>I'm working with some packages to help build Tizen image. Recently I<BR>took up osp-channel-service and osp-connectivity-service. I figured out<BR>that the problem was in not using pkgconfig by those two and in missing<BR>dependency to appinfo in appfw package. Please review my patches and<BR>merge them as soon as possible:<BR><BR>[1] https://review.tizen.org/gerrit/10524<BR>[2] https://review.tizen.org/gerrit/10532<BR>[3] https://review.tizen.org/gerrit/10533<BR><BR>When I was trying to build osp-channel-service [2] with my patch I<BR>experienced some new problem with gbs: Build (install part exactly) was<BR>failed due to missing brp-strip-static-archive and<BR>brp-strip-comment-note scripts form rpm. I had to cp them manually from<BR>rpm repository to suitable directory in my build root and then<BR>everything works fine. I know that this is only some walk around but I<BR>have no idea where those errors come from? Can anyone help with it?<BR><BR>BR's<BR><BR>---<BR>Krzysztof Opasiak<BR>Samsung R&D Institute Poland<BR>Samsung Electronics<BR>k.opasiak@samsung.com<BR><BR><BR><BR>_______________________________________________<BR>Dev mailing list<BR>Dev@lists.tizen.org<BR>https://lists.tizen.org/listinfo/dev<BR>
<P> </P>
<P> </P><!--SP:so.yu--><!--so.yu:EP-->
<P> </P>
<TABLE id=confidentialsignimg>
<TBODY>
<TR>
<TD NAMO_LOCK>
<P><IMG border=0 src="cid:QKNMBDIFBEI0@namo.co.kr" width=520></P></TD></TR></TBODY></TABLE></BODY></HTML><img src='http://ext.samsung.net/mailcheck/SeenTimeChecker?do=5b5b806e569672b0f9e51021b99369240af4c5db3b4171331b80d11210c79be9e977dbc47d7378a8f4bcdeced46ed5ee08cece8541bc14eacf878f9a26ce15a0' border=0 width=0 height=0 style='display:none'>