<html dir="ltr">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style id="owaParaStyle" type="text/css">P {margin-top:0;margin-bottom:0;}</style>
</head>
<body ocsi="0" fpstyle="1">
<div style="direction: ltr;font-family: Arial;color: #000000;font-size: 10pt;">I used this path as suggested
<a href="http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/" target="_blank">
http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/</a>, but GBS is still looking for the trunk folder which doesn't exist, so no progress.<br>
<br>
again, see the build.log below:<br>
<br>
nohup: ignoring input<br>
gbp:debug: ['git', 'rev-parse', '--is-bare-repository']<br>
gbp:debug: ['git', 'rev-parse', '--git-dir']<br>
gbp:debug: ['git', 'rev-parse', '--show-toplevel']<br>
gbs:info: generate repositories ...<br>
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/repomd.xml<br>
gbs:debug: disable HTTP caching<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/builddata/build.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/build.xml<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:debug: fetching http://download.tizen.org/releases/daily/trunk/ivi/latest/build.xml => /var/tmp/mjohnson-gbs/gbscachePfWA4a/build.xml<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:error: Traceback (most recent call last):<br>
  File "/usr/bin/gbs", line 602, in <module><br>
    sys.exit(main(sys.argv))<br>
  File "/usr/bin/gbs", line 596, in main<br>
    return module.main(args)<br>
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 330, in main<br>
    cmd += prepare_repos_and_build_conf(args, buildarch, profile)<br>
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 149, in prepare_repos_and_build_conf<br>
    'following repos:\n%s' % (arch, '\n'.join(repos)))<br>
GbsError: <gbs>no available repositories found for arch i586 under the following repos:<br>
http://download.tizen.org/releases/daily/trunk/ivi/latest/<br>
<br>
Regards<br>
<div style="font-family: Times New Roman; color: #000000; font-size: 16px">
<hr tabindex="-1">
<div style="direction: ltr;" id="divRpF337512"><font color="#000000" face="Tahoma" size="2"><b>From:</b> JF Ding [jian-feng.ding@intel.com]<br>
<b>Sent:</b> 31 October 2014 11:29 AM<br>
<b>To:</b> Michael Johnson<br>
<b>Cc:</b> Guan, JunchunX; dev@lists.tizen.org; Li, JinjingX; Lv, RuiX; Huang, Hao H<br>
<b>Subject:</b> Re: [Dev] FW: Error: No source package found at <Tizen_Project><br>
</font><br>
</div>
<div></div>
<div>
<div>Maybe wrong URL? <a href="http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml" target="_blank">http://download.tizen.org/releases/daily/trunk/ivi/latest</a> is 404.</div>
<div><br>
</div>
<div>You can try this:<a href="http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/" target="_blank">http://download.tizen.org/releases/daily/tizen/ivi/tizen-ivi_20141031.3/</a> instead.</div>
<div>
<div><br>
</div>
<br>
<div>thanks</div>
<div>- jf.ding</div>
<div><br>
</div>
</div>
<p style="color:#A0A0A8">On Friday, October 31, 2014 at 7:10 PM, Michael Johnson wrote:</p>
<blockquote type="cite" style="border-left-style:solid; border-width:1px; margin-left:0px; padding-left:10px">
<span>
<div>
<div>
<div style="direction:ltr; font-family:Arial; color:#000000; font-size:10pt">Hi all,<br>
<br>
I removed the .git folder and went through the set of commands at the link below again, and it is now giving me a different error, so thanks Junchun for that piece of info.  My build.log now looks like this:<br>
<br>
nohup: ignoring input<br>
gbp:debug: ['git', 'rev-parse', '--is-bare-repository']<br>
gbp:debug: ['git', 'rev-parse', '--git-dir']<br>
gbp:debug: ['git', 'rev-parse', '--show-toplevel']<br>
gbs:info: generate repositories ...<br>
gbs:debug: fetching <a href="http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml" target="_blank">
http://download.tizen.org/releases/daily/trunk/ivi/latest/repodata/repomd.xml</a> => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/repomd.xml<br>
gbs:debug: disable HTTP caching<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:debug: fetching <a href="http://download.tizen.org/releases/daily/trunk/ivi/latest/builddata/build.xml" target="_blank">
http://download.tizen.org/releases/daily/trunk/ivi/latest/builddata/build.xml</a> => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/build.xml<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:debug: fetching <a href="http://download.tizen.org/releases/daily/trunk/ivi/latest/build.xml" target="_blank">
http://download.tizen.org/releases/daily/trunk/ivi/latest/build.xml</a> => /var/tmp/mjohnson-gbs/gbscacheQ_1QQx/build.xml<br>
gbs:debug: fetching error:(22, 'The requested URL returned error: 404 Not Found')<br>
gbs:error: Traceback (most recent call last):<br>
  File "/usr/bin/gbs", line 602, in <module><br>
    sys.exit(main(sys.argv))<br>
  File "/usr/bin/gbs", line 596, in main<br>
    return module.main(args)<br>
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 330, in main<br>
    cmd += prepare_repos_and_build_conf(args, buildarch, profile)<br>
  File "/usr/lib/pymodules/python2.7/gitbuildsys/cmd_build.py", line 149, in prepare_repos_and_build_conf<br>
    'following repos:\n%s' % (arch, '\n'.join(repos)))<br>
GbsError: <gbs>no available repositories found for arch i586 under the following repos:<br>
<a href="http://download.tizen.org/releases/daily/trunk/ivi/latest/" target="_blank">http://download.tizen.org/releases/daily/trunk/ivi/latest/</a><br>
<br>
<br>
So now it's looking for the "trunk" folder, which doesn't exist at that path.  In case you're wondering, I'm using 'snapshot' not 'releases', so I'm not sure why gbs is looking in the releases path.  I'm going to try some things, but if anyone has an idea about
 what's wrong, don't hesitate to let me know.<br>
<br>
Thanks<br>
<br>
<br>
<div style="font-family:Times New Roman; color:#000000; font-size:16px">
<hr tabindex="-1">
<div style="direction:ltr"><font color="#000000" face="Tahoma" size="2"><b>From:</b> Guan, JunchunX [<a href="mailto:junchunx.guan@intel.com" target="_blank">junchunx.guan@intel.com</a>]<br>
<b>Sent:</b> 31 October 2014 8:49 AM<br>
<b>To:</b> Michael Johnson; Ding, Jian-feng<br>
<b>Cc:</b> <a href="mailto:dev@lists.tizen.org" target="_blank">dev@lists.tizen.org</a>; Li, JinjingX; Lv, RuiX; Huang, Hao H<br>
<b>Subject:</b> RE: [Dev] FW: Error: No source package found at <Tizen_Project><br>
</font><br>
</div>
<div>
<div>
<p style="margin:0px"><span style="font-size:10.5pt; font-family:"Calibri","sans-serif"; color:#1F497D" lang="EN-US">Use repo init, repo sync to clone tizen source, not git init.</span></p>
<p style="margin:0px"><span style="font-size:10.5pt; font-family:"Calibri","sans-serif"; color:#1F497D" lang="EN-US">So your tizen source top directory should not contain .git directory.
</span></p>
<p style="margin:0px"><span style="font-size:10.5pt; font-family:"Calibri","sans-serif"; color:#1F497D" lang="EN-US">If your tizen source top directory is a git tree, gbs treats it a single project and gbs cannot find packaging directory and then build failed.</span></p>
<p style="margin:0px"><span style="font-size:10.5pt; font-family:"Calibri","sans-serif"; color:#1F497D" lang="EN-US"> </span></p>
<div style="border:none; border-left:solid blue 1.5pt; padding:0cm 0cm 0cm 4.0pt">
<div>
<div style="border:none; border-top:solid #B5C4DF 1.0pt; padding:3.0pt 0cm 0cm 0cm">
<p style="margin:0px"><b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"" lang="EN-US">From:</span></b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"" lang="EN-US"> Michael Johnson [<a href="mailto:Michael.Johnson@Symphonyteleca.com" target="_blank">mailto:Michael.Johnson@Symphonyteleca.com</a>]
<br>
<b>Sent:</b> Friday, October 31, 2014 2:27 PM<br>
<b>To:</b> Ding, Jian-feng<br>
<b>Cc:</b> <a href="mailto:dev@lists.tizen.org" target="_blank">dev@lists.tizen.org</a>; Li, JinjingX; Lv, RuiX; Guan, JunchunX; Huang, Hao H<br>
<b>Subject:</b> RE: [Dev] FW: Error: No source package found at <Tizen_Project></span></p>
</div>
</div>
<p style="margin:0px"><span lang="EN-US"> </span></p>
<div>
<p style="margin:0px"><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US">Hi Rui,<br>
<br>
I've already posted the build.log and the .gbs.conf.  Just look at the email history below.  I'm following the instructions on the following page:<br>
    <br>
    <a href="https://source.tizen.org/documentation/developer-guide/all-one-instructions/creating-tizen-ivi-images-based-on-specific-snapshot-one-page" target="_blank">
https://source.tizen.org/documentation/developer-guide/all-one-instructions/creating-tizen-ivi-images-based-on-specific-snapshot-one-page</a><br>
<br>
<br>
Junchun,<br>
<br>
I had to do :<br>
    <br>
    git init <br>
<br>
in order to clone the source, if I remember correctly.  I'll try removing .git and let you know the outcome.<br>
<br>
I'll post the commands I used when following the instructions on the above link, when I get in office in a few hours time.<br>
<br>
Cheers.</span></p>
<div>
<div style="text-align:center; margin:0px" align="center"><span style="color:black" lang="EN-US">
<hr align="center" size="2" width="100%">
</span></div>
<div>
<p style="margin:0px"><b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US">From:</span></b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US"> Michael Johnson<br>
<b>Sent:</b> 30 October 2014 3:49 PM<br>
<b>To:</b> JF Ding<br>
<b>Cc:</b> <a href="mailto:dev@lists.tizen.org" target="_blank">dev@lists.tizen.org</a>; Li, JinjingX; Lv, RuiX; Guan, JunchunX;
<a href="mailto:hao.h.huang@intel.com" target="_blank">hao.h.huang@intel.com</a><br>
<b>Subject:</b> RE: [Dev] FW: Error: No source package found at <Tizen_Project></span><span style="color:black" lang="EN-US"></span></p>
</div>
<div>
<div>
<p style="margin:0px"><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US">Hi all,<br>
<br>
The result of running the following command from withing root tizen-project folder is:<br>
<br>
   <b> nohup gbs build -A i586 --threads=4 --baselibs >build.log 2>&1 &</b><br>
<br>
still gives the same error.<br>
<br>
<br>
<b>ls -la gives:</b><br>
<br>
drwxrwxr-x 12 mjohnson mjohnson 4096 Oct 30 15:36 .<br>
drwxrwxr-x  4 mjohnson mjohnson 4096 Oct 30 15:36 ..<br>
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:39 apps<br>
-rw-rw-r--  1 mjohnson mjohnson  440 Oct 30 15:33 build.log<br>
-r--r--r--  1 mjohnson mjohnson  460 Oct 30 12:40 .gbs.conf<br>
drwxrwxr-x  7 mjohnson mjohnson 4096 Oct 29 11:48 .git<br>
drwxrwxr-x  6 mjohnson mjohnson 4096 Oct 30 14:20 platform<br>
drwxrwxr-x  5 mjohnson mjohnson 4096 Oct 30 12:39 pre-built<br>
drwxrwxr-x  4 mjohnson mjohnson 4096 Oct 28 20:48 profile<br>
drwxrwxr-x  7 mjohnson mjohnson 4096 Oct 30 14:14 .repo<br>
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:50 scm<br>
drwxrwxr-x  3 mjohnson mjohnson 4096 Oct 28 20:50 sdk<br>
drwxrwxr-x  6 mjohnson mjohnson 4096 Oct 28 20:50 test<br>
drwxrwxr-x  5 mjohnson mjohnson 4096 Oct 28 20:50 tools<br>
<br>
<br>
<b>.gbs.conf is:</b><br>
<br>
[general]<br>
tmpdir=/var/tmp/<br>
profile = profile.tizen3.0_ivi<br>
work_dir=.<br>
fallback_to_native=true<br>
<br>
[repo.tizen3.0_x86]<br>
url=${work_dir}/pre-built/toolchain-x86/<br>
<br>
[repo.tizen3.0_arm]<br>
url=${work_dir}/pre-built/toolchain-arm/<br>
<br>
[repo.tizen3.0_x86_64]<br>
url=${work_dir}/pre-built/toolchain-x86_64/<br>
<br>
[profile.tizen3.0_ivi]<br>
repos=repo.tizen3.0_x86,repo.tizen3.0_arm,repo.tizen3.0_x86_64<br>
buildconf=${work_dir}/scm/meta/build-config/build.conf<br>
exclude_packages=libtool,gettext<br>
<br>
<br>
<b>Here's the build.log:</b><br>
<br>
</span><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:red" lang="EN-US">nohup: ignoring input<br>
info: the following packages have been excluded build from gbs config:<br>
   libtool<br>
   gettext<br>
info: generate repositories ...<br>
info: start building packages from: /home/mjohnson/workspace/tizen/cloneTizen/bin/tizen-project (git)<br>
2014-10-30 15:33 +0000<br>
gbs 0.22.3<br>
error: No source package found at /home/mjohnson/workspace/tizen/cloneTizen/bin/tizen-project<br>
error: <gbs>some packages failed to be built<br>
[1]+  Exit 1                  nohup gbs build -A i586 --threads=4 --baselibs > build.log 2>&1<br>
</span><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US"><br>
<br>
Hope this info helps to track down my problem.<br>
<br>
Cheers</span></p>
<div>
<div style="text-align:center; margin:0px" align="center"><span style="color:black" lang="EN-US">
<hr align="center" size="2" width="100%">
</span></div>
<div>
<p style="margin:0px"><b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US">From:</span></b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US"> JF Ding [<a href="mailto:jian-feng.ding@intel.com" target="_blank">jian-feng.ding@intel.com</a>]<br>
<b>Sent:</b> 30 October 2014 2:03 PM<br>
<b>To:</b> Michael Johnson<br>
<b>Cc:</b> <a href="mailto:dev@lists.tizen.org" target="_blank">dev@lists.tizen.org</a>; Li, JinjingX; Lv, RuiX; Guan, JunchunX;
<a href="mailto:hao.h.huang@intel.com" target="_blank">hao.h.huang@intel.com</a><br>
<b>Subject:</b> Re: [Dev] FW: Error: No source package found at <Tizen_Project></span><span style="color:black" lang="EN-US"></span></p>
</div>
<div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">Michael, </span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">By following the doc Geoffrey mentioned in another mail, have you tried again and can it work now?</span></p>
</div>
<div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">thanks</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">- jf.ding</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
</div>
<p><span style="color:#A0A0A8" lang="EN-US">On Thursday, October 30, 2014 at 9:50 PM, Michael Johnson wrote:</span></p>
<blockquote style="border:none; border-left:solid windowtext 1.0pt; padding:0cm 0cm 0cm 8.0pt; margin-left:0cm; margin-top:5.0pt; margin-bottom:5.0pt">
<div>
<div>
<div>
<p style="margin:0px"><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US">Hi,<br>
<br>
The version is gbs 0.22.3, and I was trying to build the whole source.<br>
<br>
Thanks for your help!</span></p>
<div>
<div style="text-align:center; margin:0px" align="center"><span style="color:black" lang="EN-US">
<hr align="center" size="2" width="100%">
</span></div>
<div>
<p style="margin:0px"><b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US">From:</span></b><span style="font-size:10.0pt; font-family:"Tahoma","sans-serif"; color:black" lang="EN-US"> JF Ding [<a href="mailto:jian-feng.ding@intel.com" target="_blank">jian-feng.ding@intel.com</a>]<br>
<b>Sent:</b> 30 October 2014 1:45 PM<br>
<b>To:</b> Michael Johnson<br>
<b>Cc:</b> <a href="mailto:dev@lists.tizen.org" target="_blank">dev@lists.tizen.org</a><br>
<b>Subject:</b> Re: [Dev] FW: Error: No source package found at <Tizen_Project></span><span style="color:black" lang="EN-US"></span></p>
</div>
<div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">Michael, </span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">Would you provide the version of gbs, and the package name that caused the error message? We will double confirm the status of DEVT-148.</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">thanks</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">- jf.ding</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
</div>
<p><span style="color:#A0A0A8" lang="EN-US">On Thursday, October 30, 2014 at 7:41 PM, Michael Johnson wrote:</span></p>
<blockquote style="margin-top:5.0pt; margin-bottom:5.0pt">
<div>
<div>
<div>
<div>
<p style="margin:0px"><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US"> </span></p>
<div>
<div>
<div>
<p style="margin:0px"><span style="font-size:10.0pt; font-family:"Arial","sans-serif"; color:black" lang="EN-US">Hi all,<br>
<br>
I'm having problems trying to build the Tizen source.  Cloning the source went fine, but I'm now going through
<a href="https://source.tizen.org/documentation/developer-guide/getting-started-guide/building-packages-locally-gbs," target="_blank">
https://source.tizen.org/documentation/developer-guide/getting-started-guide/building-packages-locally-gbs,</a> and getting the above error when using the command:<br>
<br>
    gbs -d build -A i586 --threads=4 --clean-once --exclude=gcc,cmake,filesystem,aul,libmm-sound,libtool<br>
<br>
I'm using the .gbs.conf below that exists after cloning the source.<br>
<br>
[general]<br>
tmpdir=/var/tmp/<br>
profile = profile.tizen3.0_ivi<br>
work_dir=.<br>
fallback_to_native=true<br>
<br>
[repo.tizen3.0_x86]<br>
url=${work_dir}/pre-built/toolchain-x86/<br>
<br>
[repo.tizen3.0_x86_64]<br>
url=${work_dir}/pre-built/toolchain-x86_64/<br>
<br>
[profile.tizen3.0_ivi]<br>
repos=repo.tizen3.0_x86,repo.tizen3.0_x86_64<br>
buildconf=${work_dir}/scm/meta/build-config/build.conf<br>
exclude_packages=libtool,gettext<br>
<br>
Bug DEVT-148 says "gbs build fails with an error if packaging/ is a symlink", and it says that it is fixed, so I'm wondering if there is anyone having this issue, or is there a different way of building the source that is not mentioned in the documentation?<br>
<br>
Any guidance is appreciated.<br>
<br>
Thanks<br>
Mike</span></p>
</div>
</div>
</div>
</div>
<p style="margin:0px"><b><span style="font-size:9.0pt; font-family:"Trebuchet MS","sans-serif"; color:#385370" lang="EN-US"><br>
<br>
<strong><span style="font-family:"Trebuchet MS","sans-serif"">MICHAEL JOHNSON</span></strong></span></b><span style="font-size:8.0pt; font-family:"Trebuchet MS","sans-serif"; color:#385370" lang="EN-US"><br>
Embedded Software Engineer</span><span style="color:black" lang="EN-US"> </span></p>
<p style="margin-bottom:12.0pt"><b><span style="font-size:9.0pt; font-family:"Trebuchet MS","sans-serif"; color:#385370" lang="EN-US"><br>
<strong><span style="font-family:"Trebuchet MS","sans-serif"">Symphony Teleca</span></strong></span></b><span style="font-size:8.0pt; font-family:"Trebuchet MS","sans-serif"; color:#385370" lang="EN-US"><br>
Sunley House, 46 Jewry Street, Winchester, Hampshire, SO23 8RY<br>
Phone: +441962868866, Fax: +441962868867<br>
<a href="mailto:Michael.Johnson@Symphonyteleca.com" title="Click to send email to Michael Johnson" target="_blank">Michael.Johnson@Symphonyteleca.com</a></span><span style="font-size:8.0pt; font-family:"Trebuchet MS","sans-serif"; color:black" lang="EN-US"><br>
</span><span style="font-size:8.0pt; font-family:"Trebuchet MS","sans-serif"; color:#385370" lang="EN-US"><a href="http://www.symphonyteleca.com" title="" target="_blank"><span style="color:#385370">www.symphonyteleca.com</span></a><br>
<br>
Teleca Limited, a company registered in England & Wales, registration number 2773878, registered office at Sunley House, 46 Jewry Street, Winchester, Hampshire SO23 8RY. VAT registration number GB 674 6583 90<i><br>
<br>
Follow what's going on at Symphony Teleca's blog on <a href="http://www.symphonyteleca.com/blog" title="" target="_blank">
www.symphonyteleca.com/blog</a>. Please consider the environment before you print.<br>
<br>
Notice to recipient: This e-mail (including any attachments) is meant for the intended recipient only, may contain confidential and proprietary information, and is protected by law. If you received this e-mail in error, please immediately notify the sender
 of the error by return e-mail, delete this communication and any attachments, and shred any printouts. Unauthorized review, use, dissemination, distribution, copying or taking of any action based on this communication is strictly prohibited.</i></span><span style="color:black" lang="EN-US"></span></p>
</div>
<div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">_______________________________________________</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US">Dev mailing list</span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"><a href="mailto:Dev@lists.tizen.org" target="_blank">Dev@lists.tizen.org</a></span></p>
</div>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"><a href="https://lists.tizen.org/listinfo/dev" target="_blank">https://lists.tizen.org/listinfo/dev</a></span></p>
</div>
</div>
</div>
</div>
</blockquote>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
</div>
</div>
</div>
</div>
</div>
</blockquote>
<div>
<p style="margin:0px"><span style="color:black" lang="EN-US"> </span></p>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</span></blockquote>
<div><br>
</div>
</div>
</div>
</div>
</body>
</html>