<div dir="ltr">Hello Paweł,<br><br>Thank you!<br><br>Is this new snapshot compatible with the older Artik 10 version - 0.22?<br><br>--<br>Best regards,<br>Aleksander Kurczyk</div><br><div class="gmail_quote"><div dir="ltr">czw., 12.05.2016 o 15:26 użytkownik Paweł Wieczorek <<a href="mailto:p.wieczorek2@samsung.com">p.wieczorek2@samsung.com</a>> napisał:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Aleksander, Jaehoon, Chanwoo, Raju,<br>
<br>
I would like to let you know that Tizen 3.0 snapshots for Tizen:Common<br>
profile are available for Artik 10 and Artik 5.<br>
<br>
Currently, four Artik images are built:<br>
<br>
* common-boot-armv7l-artik5,<br>
* common-boot-armv7l-artik10,<br>
* common-headless-3parts-armv7l-artik (generic: for both Artik 5 and 10),<br>
* common-wayland-3parts-armv7l-artik (generic: for both Artik 5 and 10).<br>
<br>
Best regards,<br>
Paweł Wieczorek<br>
<br>
On 29/12/15 03:16, Chanwoo Choi wrote:<br>
> Hi Aleksander,<br>
><br>
> On 2015년 12월 29일 11:12, Jaehoon Chung wrote:<br>
>> CC'd Chanwoo.<br>
>><br>
>> On 12/26/2015 10:23 PM, Aleksander Kurczyk wrote:<br>
>>> Hello!<br>
>>><br>
>>> I am one of the Samsung Artik 10 alpha testers. I am trying to get Tizen working on my Artik 10 rev. 0.22 (the last alpha one). I have found the manual on how to get it working on Tizen's wiki. It's available here: <a href="https://wiki.tizen.org/wiki/ARTIK_10_for_Tizen_3.0" rel="noreferrer" target="_blank">https://wiki.tizen.org/wiki/ARTIK_10_for_Tizen_3.0</a>. Using those instructions and attached files I have managed to compile the kernel and during boot got the error message "Bad ARM magic".<br>
>>><br>
>>> I had to fix the attached DTS file. In one line (109) there was missing a semicolon while in another one (541) there was an undeclared before constant "CLK_MOUT_EPLL". I have changed it to "CLK_MAU_EPLL" because those constant is used in the next line. Correct? I also had to change the size od modules.img image (to 32MiB) because the modules couldn't fit there.<br>
>>><br>
>>> Can someone who also got the Samsung Artik 10 alpha board tell me what am I doing wrong? Has it something to do with the DTS file or maybe I am using wrong toolchain?<br>
> You are right. The exynos5422-artik10.dts has the problem as you mentioned.<br>
> So, I fixed them. I added the semicolon in line 109 and push the patch[1]<br>
> to add the 'CLK_MOU_EPLL' clock as following:<br>
> [1] <a href="https://review.tizen.org/gerrit/gitweb?p=platform/kernel/linux-exynos.git;a=commit;h=fb5b25f81caa3e00766b841da4f18c05336ee59f" rel="noreferrer" target="_blank">https://review.tizen.org/gerrit/gitweb?p=platform/kernel/linux-exynos.git;a=commit;h=fb5b25f81caa3e00766b841da4f18c05336ee59f</a><br>
><br>
> After you pull the latest linux-exynos.git, the issue might be not happened.<br>
><br>
> Best Regards,<br>
> Chanwoo Choi<br>
><br>
> _______________________________________________<br>
> Dev mailing list<br>
> <a href="mailto:Dev@lists.tizen.org" target="_blank">Dev@lists.tizen.org</a><br>
> <a href="https://lists.tizen.org/listinfo/dev" rel="noreferrer" target="_blank">https://lists.tizen.org/listinfo/dev</a><br>
<br>
</blockquote></div>