[Tizen General] gbs building third party application:error:libtool not found

Zhang, Qiang Z qiang.z.zhang at intel.com
Fri Aug 1 04:06:53 GMT 2014


Hi Ghanekar,

Thanks for trying building Tizen IVI using GBS.

I'd like to confirm with you the build process first.
1) Have you cloned (repo sync) all tizen ivi source code following: https://source.tizen.org/documentation/developer-guide/all-one-instructions/creating-tizen-ivi-images-based-on-specific-snapshot-one-page

2) Have do built all tizen source code with gbs local full build before building your 3rd part app?

Finally, I suggest that you can just use the following command to build the 3rd part app, by specify remote repo:

$ cd path/to/app
$ gbs build -A i586 -R http://download.tizen.org/snapshots/tizen/ivi-3.0.m14.2/tizen-3.0.m14.2-ivi_20140730.1/repos/atom/packages/


BTW, <local repo path>/repos/tizen3.0_ivi/i586/RPMS is the output of gbs build, and all binary packages under that dir can be take by default, you don't need specify it in command line.

Thanks
Qiang

From: IVI [mailto:ivi-bounces at lists.tizen.org] On Behalf Of Prathamesh P Ghanekar
Sent: Friday, August 1, 2014 11:08 AM
To: general at lists.tizen.org; ivi at lists.tizen.org
Subject: gbs building third party application:error:libtool not found

Hi all,

I am trying to build a third party application against tizen-IVI june release(I also tried building against March release).
I run following command to do a 'gbs build'.

gbs build --include-all -A i586  -R <local repo path>/repos/tizen3.0_ivi/i586/RPMS

I end up getting following error.

[    4s] running setup postinstall script
[    4s] .init_b_cache/scripts/setup.post: line 1: syntax error near unexpected token `name'
[    4s] .init_b_cache/scripts/setup.post: line 1: `for i, name in ipairs({"passwd", "shadow", "group", "gshadow"}) do'
[    4s] initializing rpm db...
[    4s] reordering...binary not found: libtool
[    4s] exit ...

1)I tried -include-all option as well. But, the same error!
2)libtool-2.4.2-0.i686.rpm package is available in the local repository.Also, libtool package is installed on my Ubuntu12.04-32 bit host.
Can you help me out with this error?

Thanks and regards,
Prathamesh Ghanekar

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~Disclaimer~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Information contained and transmitted by this e-mail is confidential and proprietary to IGATE and its affiliates and is intended for use only by the recipient. If you are not the intended recipient, you are hereby notified that any dissemination, distribution, copying or use of this e-mail is strictly prohibited and you are requested to delete this e-mail immediately and notify the originator or mailadmin at igate.com<mailto:mailadmin at igate.com>. IGATE does not enter into any agreement with any party by e-mail. Any views expressed by an individual do not necessarily reflect the view of IGATE. IGATE is not responsible for the consequences of any actions taken on the basis of information provided, through this email. The contents of an attachment to this e-mail may contain software viruses, which could damage your own computer system. While IGATE has taken every reasonable precaution to minimise this risk, we cannot accept liability for any damage which you sustain as a result of software viruses. You should carry out your own virus checks before opening an attachment. To know more about IGATE please visit www.igate.com<http://www.igate.com>.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/general/attachments/20140801/414f155a/attachment-0001.html>


More information about the General mailing list