[Tizen General] [yocto] Build Tizen with yocto work-flow

Alex J Lennon ajlennon at dynamicdevices.co.uk
Fri Aug 1 16:36:43 GMT 2014


On 01/08/2014 16:38, Alex J Lennon wrote:
>> I don't know either but I think it's best to be compliant with both
>> bash and dash, I will try to correct those issues in order to be
>> dash-compliant. Thanks a lot for the feedback ;)
> No problem Kévin. I'm glad you feel it is of some use. I'm getting other
> recipes failing now with bash. What I'll probably do is let it run to
> completion with bitbake -k and collate the failures.
>
> Hopefully that'll be some useful feedback in terms of a build on Ubuntu
>
> Cheers,
>
> Alex
>
>
Kévin,

(1) Install failure for systemd_git.bb

|
/home/ajlennon/yocto/poky/build/tmp/work/core2-32-poky-linux/systemd/git-r0/temp/run.do_install.16014:
line 131: /usr/bin/mkdir: No such file or directory
| WARNING:
/home/ajlennon/yocto/poky/build/tmp/work/core2-32-poky-linux/systemd/git-r0/temp/run.do_install.16014:1
exit 1 from
|   /usr/bin/mkdir -p
/home/ajlennon/yocto/poky/build/tmp/work/core2-32-poky-linux/systemd/git-r0/image//usr/sbin
| ERROR: Function failed: do_install (log file is located at
/home/ajlennon/yocto/poky/build/tmp/work/core2-32-poky-linux/systemd/git-r0/temp/log.do_install.16014)
ERROR: Task 1692
(/home/ajlennon/yocto/meta-tizen/recipes-tizen/systemd/systemd_git.bb,
do_install) failed with exit code '1'

I think this is because of use of  ${prefix}/bin/ for commands in
systemd.inc do_install()

Not sure what the answer is here but if I s|${prefix}/bin/||g in
do_install() then it installs successfully

(2) Install failure for llvm3.3_3.3.bb

I had a couple of funnies with llvm but that could well have been
related to dash/bash as cleaning and rebuilding the recipe fixed it

...

That gets me a rootfs successfully built. Now to work out how to run it
under VirtualBox or how to get MACHINE=qemux86 built up...

Cheers,

Alex



More information about the General mailing list