<div dir="ltr"><div>hi,everyone</div>about the build issues, I find I can build successfully  if I don't point out the "<span style="font-size:14px">--threads" , but it will take a long long time to finish building<br></span><blockquote style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex" class="gmail_quote">info: *** Build Status Summary ***<br>=== the following packages failed to build due to rpmbuild issue (1) ===<br>zlib: /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/repos/tizen_2.3_mobile/armv7l/logs/fail/zlib-1.2.5-2.7/log.txt<br>=== Total succeeded built packages: (564) ===<br>info: generated html format report:<br>     /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/repos/tizen_2.3_mobile/armv7l/index.html<br>info: generated RPM packages can be found from local repo:<br>     /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/repos/tizen_2.3_mobile/armv7l/RPMS<br>info: generated source RPM packages can be found from local repo:<br>     /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/repos/tizen_2.3_mobile/armv7l/SRPMS<br>info: build logs can be found in:<br>     /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/repos/tizen_2.3_mobile/armv7l/logs<br>info: build roots located in:<br>     /data/eriche02/tizen/tizen2.3/gbsbuild_single/local/BUILD-ROOTS/scratch.armv7l.*<br>error: <gbs>some packages failed to be built<br>build tizen cost 44016 s.<br> <br>real 733m35.223s<br>user 669m13.728s<br>sys 89m33.811s</blockquote><div><span style="font-size:14px"><br></span></div><div><span style="font-size:14px">but if I point out the </span>"<span style="font-size:14px">--threads", it will random hang ,  </span><span style="font-size:14px">so is it a multiple packages build issue ?  </span></div><div><span style="font-size:14px">thanks very much</span></div><div><span style="font-size:14px"><br></span></div><div><span style="font-size:14px">cheers,</span></div><div><span style="font-size:14px">ct</span></div></div><div class="gmail_extra"><br><div class="gmail_quote">2016-05-05 11:23 GMT+08:00 Imct cheng <span dir="ltr"><<a href="mailto:imct.cheng@gmail.com" target="_blank">imct.cheng@gmail.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">hi,there,<div><br></div><div>sorry for the spread.</div><div>I am trying to build the tizen2.3 source code in my odoridx2 device,but I met some problems, hope anyone can help me ,thanks.<br><div><br></div><div><font size="4">1.build issues</font></div><div>When I try to build the Tizen 2.3 source code ,I find it will always hang at somewhere, I have to stop it and build again , it will occure several  times(have to stop the building and run the building again ) as below shows, please ignore the package name because it may hang after building  other package</div><div><blockquote style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex" class="gmail_quote">xorg-x11-xkb-utils<br>info: finished building xorg-x11-drv-evdev-multitouch<br>info: *** [302/565] building xorg-x11-xkb-utils-7.9.1-1 armv7l tizen_2.3_mobile (worker: 1) ***<br>info: finished building xorg-x11-drv-evdev<br>info: finished building xorg-x11-xkb-utils<br>info: next pass:<br>xkeyboard-config<br>info: *** [303/565] building xkeyboard-config-2.9.1-5 armv7l tizen_2.3_mobile (worker: 0) ***<br>info: finished building xkeyboard-config<br>info: next pass:<br>xorg-x11-misc-exynos<br>info: *** [304/565] building xorg-x11-misc-exynos-0.0.41-1 armv7l tizen_2.3_mobile (worker: 0) ***<br>info: finished building xorg-x11-misc-exynos</blockquote><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex"><i>....... </i></blockquote><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex"><b><font size="4"><i>hanging here </i></font></b></blockquote></div><div><br></div><div> my build step is:</div><div><br></div><i><b>a. repo init -u ssh://<username>@<a href="http://review.tizen.org:29418/scm/manifest" target="_blank">review.tizen.org:29418/scm/manifest</a> -b tizen_2.3</b></i><br><i><b>b.repo sync</b></i><div><i><b>c. modiy the gbs.conf:</b></i></div><div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex">[general]<br>profile = profile.tizen_2.3_mobile<br>buildroot =/work/tizen_2.3/gbsbuild<br>#profile = profile.tizen_2.3_wearable<br>[repo.tizen_2.3_mobile]<br>url=<a href="http://download.tizen.org/snapshots/2.3-mobile/common/latest/repos/target/packages" target="_blank">http://download.tizen.org/snapshots/2.3-mobile/common/latest/repos/target/packages</a><br># For Emulator<br>## url=<a href="http://download.tizen.org/snapshots/2.3-mobile/common/latest/repos/emulator/packages" target="_blank">http://download.tizen.org/snapshots/2.3-mobile/common/latest/repos/emulator/packages</a><br>[repo.tizen_2.3_wearable]<br>url=<a href="http://download.tizen.org/snapshots/2.3-wearable/common/latest/repos/target/packages" target="_blank">http://download.tizen.org/snapshots/2.3-wearable/common/latest/repos/target/packages</a><br># For Emulator<br>## url=<a href="http://download.tizen.org/snapshots/2.3-wearable/common/latest/repos/emulator/packages" target="_blank">http://download.tizen.org/snapshots/2.3-wearable/common/latest/repos/emulator/packages</a><br>[profile.tizen_2.3_mobile]<br>repos=repo.tizen_2.3_mobile<br>[profile.tizen_2.3_wearable]<br>repos=repo.tizen_2.3_wearable</blockquote></div><div><i><b>d.then build the souce code,use the build.sh:</b></i></div><div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-style:solid;border-left-color:rgb(204,204,204);padding-left:1ex">#!/bin/bash<br>accel_pkgs="bash,bzip2-libs,c-ares,cmake,coreutils,diffutils,eglibc,elfutils-libelf,elfutils-libs,elfutils,fdupes,file,findutils,gawk,gmp,libacl,libattr,libcap,libcurl,libfile,libgcc,liblua,libstdc++,make,mpc,mpfr,ncurses-libs,nodejs,nspr,nss-softokn-freebl,nss,openssl,patch,popt,rpm-libs,rpm-build,sed,sqlite,tar,xz-libs,binutils,gcc,filesystem,aul,libmm-sound,libtool,syspopup,notification,libva,libzypp-bindings,rpm,web-ui-fw,python-doc,rpm,perl,tizen-debug,ise-web-helper-agent"<br>gbs build -A armv7l --threads=4 --clean-once  --exclude=${accel_pkgs},filesystem,aul,libmm-sound,libtool,python-doc,web-ui-fw,webkit2-efl</blockquote></div><div><div><br></div><div>so do you konw what's reason that why the build will hang.</div></div><div><br></div><div><font size="4">2. X11<b> </b></font></div><div>I use the odroidu3/x2 as my board, and I find if I don't connect the HDMI, the X can not start up, so is there any ways to bring up the X when there is no HDMI connect (mean I need the tizen bring up fully without Display devices connect), or maybe just like headless X11</div><div><br></div><div> Thanks</div><div>ct</div><div><br></div><div><br></div></div></div>
</blockquote></div><br></div>