[Tizen Product-dev] Fwd: help on tizen

kishore divvela kishoredivvela at gmail.com
Tue Jun 4 10:54:16 GMT 2013


Hi Joel,

We created a sample application with existing native application. We have
build the package and got TPK files.

So now the next procedure is keep them into one storage and run the
following command right?

native-install -p xxxxxxxx.tpk

Is my understanding correct?


Regards,

Kishore




On Tue, Jun 4, 2013 at 2:17 PM, Clark, Joel <joel.clark at intel.com> wrote:

>  Here is the location for downloads based on the repository you said you
> were using:****
>
>
> http://download.tizen.org/releases/previews/1.0/ivi/tizen-ivi_20120712.3/repos/ivi/source/
> ****
>
>
> http://download.tizen.org/releases/previews/1.0/ivi/tizen-ivi_20120712.3/repos/ivi/ia32/packages/i586/
> ****
>
> ** **
>
> For example one of the sample applications is
> http://download.tizen.org/releases/previews/1.0/ivi/tizen-ivi_20120712.3/repos/ivi/ia32/packages/i586/org.tizen.clock-0.1.2-70.2.i586.rpm
> ****
>
> ** **
>
> regards****
>
> Joel****
>
> ** **
>
> ** **
>
> *From:* kishore divvela [mailto:kishoredivvela at gmail.com]
> *Sent:* Monday, June 03, 2013 11:50 PM
> *To:* Clark, Joel
> *Cc:* VanCutsem, Geoffroy; Ding, Jian-feng; somasekhar.ap at gmail.com;
> product-dev at lists.tizen.org
>
> *Subject:* Re: [Tizen Product-dev] Fwd: help on tizen****
>
> ** **
>
> Hi Joel,Geoffroy,****
>
> We could able to port IVI 1.0 version on to Crossville E6xx platform. ****
>
> On boot up we could see a console. We would like port a application. Can
> you let me know the location to download sample applications.****
>
> Regards,****
>
> Kishore****
>
> ** **
>
> On Fri, May 31, 2013 at 10:27 PM, Clark, Joel <joel.clark at intel.com>
> wrote:****
>
> Since Kishore is building against the July 12, 2012 repositories, he will
> find the EMGD graphics driver for the Intel Atom E6xx.  The driver binary
> (no source is available) is found here****
>
>  ****
>
>
> http://download.tizen.org/releases/previews/1.0/ivi/tizen-ivi_20120712.3/repos/non-oss/ia32/packages/i586/
> ****
>
>  ****
>
> The last Tizen preview with that graphics driver was released in Sept
> 2012. ****
>
>  ****
>
> regards****
>
> Joel****
>
>  ****
>
>  ****
>
> *From:* product-dev-bounces at lists.tizen.org [mailto:
> product-dev-bounces at lists.tizen.org] *On Behalf Of *VanCutsem, Geoffroy
> *Sent:* Friday, May 31, 2013 9:37 AM
> *To:* kishore divvela; Ding, Jian-feng
> *Cc:* somasekhar.ap at gmail.com; product-dev at lists.tizen.org****
>
>
> *Subject:* Re: [Tizen Product-dev] Fwd: help on tizen****
>
>  ****
>
> Hi Kishore,****
>
>  ****
>
> That particular error is most likely caused by the fact your USB stick was
> automatically mounted when you inserted it. You should unmount it first.
> Use ‘sudo umount /dev/sdb*’ for that but do **not** use any ‘eject’
> function from the GUI because that will free up the device node altogether.
> ****
>
>  ****
>
> Be aware though that the Crossville board is not supported in Tizen and I
> would be surprised if you can boot it at all (I’m pretty sure the
> Crossville-ST won’t boot at all and I suspect the same may be true for the
> Crossville-Lapis). In any case, we do not have the graphics drivers (EMGD)
> for the Intel Atom E6xx processor in Tizen so you may find the overall
> experience a bit limited even it you can boot the system.****
>
>  ****
>
> I’d recommend you actually switch to one of the platforms that we support
> in IVI: https://wiki.tizen.org/wiki/IVI/IVI_Platforms****
>
>  ****
>
> Thanks,****
>
> Geoffroy****
>
>  ****
>
> *From:* kishore divvela [mailto:kishoredivvela at gmail.com<kishoredivvela at gmail.com>]
>
> *Sent:* Friday, May 31, 2013 8:02 PM
> *To:* Ding, Jian-feng
> *Cc:* VanCutsem, Geoffroy; product-dev at lists.tizen.org;
> somasekhar.ap at gmail.com
> *Subject:* Re: [Tizen Product-dev] Fwd: help on tizen****
>
>  ****
>
> hi Jf.ding,****
>
> Thanks for all your help so far.****
>
> Now i am loading a image to Crossville platform with ivi image. i have
> installed the bmaptool, and followed the below wikilink for loading the
> image.
>
> *https://wiki.tizen.org/wiki/IVI/IVI_Installation#SectCopyToUSBStick*****
>
> *I am getting the following error *****
>
>
>
>  bmaptool copy
> http://download.tizen.org/releases/previews/1.0/ivi/tizen-ivi_20120712.3/images/ivi-main-min-auto/ivi-main-min-auto-tizen-ivi_20120712.3-sdb.raw.bz2/dev/sdb
> bmaptool: ERROR: cannot open block device '/dev/sdb' in exclusive mode:
> [Errno 16] Device or resource busy: '/dev/sdb'****
>
> Please let me know how to load the image to pendrive.
>
> Regards,****
>
> Kishore****
>
>  ****
>
> On Thu, May 30, 2013 at 5:02 PM, kishore divvela <kishoredivvela at gmail.com>
> wrote:****
>
> Hi Jf.ding,****
>
> Thanks for your help, I am able to create the image with 2.1 sources.****
>
> Regards,****
>
> Kishore****
>
>  ****
>
> On Thu, May 30, 2013 at 6:04 AM, Jian-feng Ding <jian-feng.ding at intel.com>
> wrote:****
>
> I prefer you try the latest tizen-2.1 images:
> http://download.tizen.org/snapshots/2.1/common/tizen-2.1_20130520.2/images/
>
> thanks
> - jf.ding****
>
>
> On Wed, May 29, 2013 at 09:19:08PM +0530, kishore divvela wrote:
> > Hi jf.ding,
> >
> > Thanks for your help. After installing i am able to run gbs and download
> > the package from git, but ssh clone is not working, so i used direct
> > cloning as mentioned in video, and i am able to download the packages.
> >
> > Now i am in process of creating image, for this i followed the below
> steps
> > from
> https://source.tizen.org/documentation/developer-guide/creating-images
> >****
>
> > *1. Original kickstart file has been obtained by following the link
> below:*
> > *
> >
> http://download.tizen.org/snapshots/trunk/common/latest/builddata/image-configs/
> >
> > *
> >
> > * repo --name=Tizen-main
> > --baseurl=
> http://download.tizen.org/snapshots/trunk/common/latest/repos/tizen-main/armv7l/packages/*
> >
> > *There is no files exist in this path.
> > *
> > *
> > *
> > *So i took the kickstart file from****
>
> >
> http://download.tizen.org/snapshots/2.1/common/latest/images/RD-210/RD-210.ks
> ,
> > Is this correct?
> >
> > and later copied the content to one text file and i change the below
> lines****
>
> > and saved to "Downloads" folder on my PC* as per video session.****
>
> >
> >
> > #repo --name=Tizen-main --baseurl=
> >
> https://download.tizendev.org/snapshots/trunk/common/@BUILD_ID@/repos/tizen-main/armv7l/packages/--#save
> >  --ssl_verify=no
> > repo --name=Tizen-main --baseurl=
> >
> http://download.tizen.org/snapshots/trunk/common/latest/repos/main/armv7l/packages/--save
> >  --ssl_verify=no
> >
> > #repo --name=Tizen-base --baseurl=
> >
> https://download.tizendev.org/snapshots/trunk/common/@BUILD_ID@/repos/tizen-base/armv7l/packages/--#ssl_verify=no
> >
> > repo --name=Tizen-base --baseurl=
> >
> http://download.tizen.org/snapshots/trunk/common/latest/repos/base/armv7l/packages/--ssl_verify=no
> >****
>
> > *2. I ran the sudo mic command for creating image.*
> >
> >  *  labpc at labpc-P5GD2-TVM-GB-SI:~/Downloads$ sudo mic create loop
> > --taring-to=RD-210-rs.tar.gz RD-210.ks
> >
> > *
> > *   I am getting the following error*****
>
> >
> > mic 0.19 (Ubuntu 13.04 raring)
> > Info: Substitute macro variable @BUILD_ID@/@ARCH@ in ks: RD-210.ks
> > Info: Retrieving repo metadata:
> >
> > Error <creator>: [Errno 14] HTTP Error 404 :
> >
> http://download.tizen.org/snapshots/trunk/common/latest/repos/main/armv7l/packages/armv7l/repodata/repomd.xml
> > labpc at labpc-P5GD2-TVM-GB-SI:~/Downloads$ sudo mic create loop
> > --taring-to=RD-210-rs.tar.gz RD-210.ks
> > mic 0.19 (Ubuntu 13.04 raring)
> > Info: Substitute macro variable @BUILD_ID@/@ARCH@ in ks: RD-210.ks
> > Info: Retrieving repo metadata:
> > Info: Retrieving 4a1f9ae42efc07f1d9c19a7cb9b8e96376afc25e676a9bc0942Info:
> > Retrieving 9cef6d9c25906b9e920c0772f3f1cded750887ccd640276265bInfo:
> > Retrieving 357a89fbef04c88f07974024d45336194ba691184b9c5539a8eInfo:
> > Retrieving e0ffa2876a0d888fc99a5f9c2097b406c5824fa3134790020f05d ... DONE
> >
> > Info: Use detected arch armv7l.
> > Info: Creating tizen bootstrap ...
> >
> > Warning <bootstrap>: <bootstrap>Can't get rpm binary:
> mic-bootstrap-x86-arm
> > Q: Switch to native mode and continue?(Y/n) y
> > Info: Substitute macro variable @BUILD_ID@/@ARCH@ in ks: RD-210.ks
> > Info: Retrieving repo metadata:
> > Info: Retrieving repomd.xml ... DONE
> > Warning: Failed to load plugin backend/zypppkgmgr: libudev.so.0: cannot
> > open shared object file: No such file or directory
> > Warning: vdso is enabled on your host, which might cause problems with
> arm
> > emulations.
> >     You can disable vdso with following command before starting image
> build:
> >     echo 0 | sudo tee /proc/sys/vm/vdso_enabled
> >
> > Error <creator>: Failed to find group 'common' : No Group named common
> > exists
> >****
>
> > *Which latest release i should use? , also can you send me the kickstart
> > file with correct path for creating image?*
> >
> >
> >
> > Thanks & Regards,
> > Kishore****
>
>  ****
>
>  ****
>
> Intel Corporation NV/SA
> Kings Square, Veldkant 31
> 2550 Kontich
> RPM (Bruxelles) 0415.497.718.
> Citibank, Brussels, account 570/1031255/09****
>
> This e-mail and any attachments may contain confidential material for the
> sole use of the intended recipient(s). Any review or distribution by others
> is strictly prohibited. If you are not the intended recipient, please
> contact the sender and delete all copies.****
>
> ** **
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/product-dev/attachments/20130604/9431f5fc/attachment-0001.html>


More information about the Product-dev mailing list