[Tizen Product-dev] Boot issue - Unable to see GUI

Clark, Joel joel.clark at intel.com
Tue Jun 11 18:30:51 GMT 2013


I have a couple of hints that may help:

1.       The Porting_Guide was not written with Intel IVI (Crossville) systems in consideration.  In particular "charger_detect_boot" has no relevance to https://download.tizen.org/releases/previews/1.0/ivi/

2.       The Crossville Platform uses the EMGD graphics driver.  This driver uses hard coded display parameters.  If the display device does not match the parameters hard coded by the driver, the typical result is the system boots to a black screen. There are several pre-defined display configurations defined in the driver.  The default display configuration is for a 7" LVDS display that was shipped in the Crossville based "IVI Starter Kit, Intel In-Vehicle Infotainment Reference Design".  You can try out other pre-defined display configurations by appending "emgd.configid=x", substituting a small single digit for 'x' (such as 2 or 3 or 4).

*         To change the bootloader command line, log in to the virtual console shell and use "vim" to edit the bootloader menu in /boot/extlinux/extlinux.conf to add the correct bootloader command line options. Specifically add 'emgd.configid=n' where 'n' is the correct configid for your display to the end of the line that starts with "append" below the "kernel" line in the file /boot/extlinux/extlinux.conf. Save these changes so they will be used on the subsequent boots

*         If you want to use other displays with the Tizen IVI "auto" kernel, which targets the Intel<https://wiki.tizen.org/w/index.php?title=Intel&action=edit&redlink=1> Atom* E6xx series processor with the EMGD graphics driver, you will need configure the graphics driver with the correct display parameters. For optimal performance, the display parameters should be encoded in the EMGD kernel module .../emgd/drm/user_config.c. Alternatively, when using X11<https://wiki.tizen.org/w/index.php?title=X11&action=edit&redlink=1>, the display parameters may be coded into the xorg.conf configuration file.

regards
joel


From: kishore divvela [mailto:kishoredivvela at gmail.com]
Sent: Tuesday, June 11, 2013 6:26 AM
To: product-dev at lists.tizen.org; Ding, Jian-feng; Clark, Joel
Cc: Somasekhar Reddy
Subject: Boot issue - Unable to see GUI

Hi ,

I am using Crossville platform E6XX, on this image ported is IVI versions from the below link
https://download.tizen.org/releases/previews/1.0/ivi/

1. System u-boot works properly
2. Boot process runs properly as i see Tizen screen initially
3. Later it initializes all the services as attached and it stops at this screen.

According to the below link, tizen starts with below steps

https://wiki.tizen.org/wiki/Porting_Guide/Tizen_Bootup_Overview

1. sysinit.target
2. basic.target
3. bootmode.target in this step following procedure is written

  *   If kernel boot parameter (i.e. /proc/cmdline) has 'charger_detect_boot' option that is passed by boot loader such as uboot, the platform boots up as charging mode. In this mode, system enters the low power mode and charges the bettery.
  *   If 'charger_detect_boot' option is not in kernel boot parameter, normal boot is started.



i am doubting whether my system entered into normal boot or not.

How do we need to boot Tizen os, is there any other procedure, please let us know.


Regards,
Kishore





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.tizen.org/pipermail/product-dev/attachments/20130611/1208c042/attachment-0001.html>


More information about the Product-dev mailing list